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Introducing New ECDL
Welcome to New ECDL (Version 6). More than just a syllabus update, New ECDL is based on
the changing needs of our candidates. Whether they are a student or an employer, or just
want boost their skills, New ECDL has something to offer.
New ECDL gives candidates more choice, more flexibility and a new model
for lifelong learning.
Other benefits associated with ECDL continue such as:
Quality

Syllabi and tests created by the ECDL Foundation

Recognition

ECDL retains worldwide recognition

Administration

Minimal changes to our systems mean a smooth transition for centres

Support

Our unrivalled level of customer service and support is in place to assist you

Price

Bundle prices remain unchanged

Do it your way – pick your package
Updated modules and new modules mean the ability to choose ECDL modules that are
relevant to your learners.
Create a class as normal then simply pick a package containing your module selection.
Pre-loaded templates consisting of the most popular module combinations will make this easy
for you.
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Computer Essentials

This module sets out essential concepts and skills
relating to the use of devices, file creation and management, networks, and data security.

Module Summary

SYLLABUS OUTLINE

CATEGORY

On completion of this module the candidate will be able to:
Understand key concepts relating to ICT, computers, devices and
software.
Start up and shut down a computer.
Work effectively on the computer desktop using icons, windows.
Adjust the main operating system settings and use built-in help
features.
Create a simple document and print an output.
Know about the main concepts of file management and be able
to efficiently organise files and folders.
Understand key storage concepts and use utility software to
compress and extract large files.
Understand network concepts and connection options and be
able to connect to a network.
Understand the importance of protecting data and devices from
malware, and the importance of backing up data.
Recognise considerations relating to green IT, accessibility, and
user health.

Computers and Devices

ICT
Hardware
Software and Licensing
Start Up, Shut Down

Desktop, Icons, Settings

Desktop and Icons
Using Windows
Tools and Settings

Outputs

Working with Text
Printing

File Management

Networks

WHAT ARE THE BENEFITS OF THIS MODULE?

Covers the key skills and main concepts relating to ICT,
computers, devices, and software.
Certifies best practice in effective computer use.
Developed with input from computer users, subject matter
experts, and practising computer professionals from all over the
world. This process ensures the relevance and range of module
content.

HOW DO I GET STARTED?
To find out more about this module and to locate your nearest
accredited test centre, please visit www.ecdl.org/programmes.

SKILL SET

Security and Well-Being

Introducing Files and Folders
Organising Files and Folders
Storage and Compression

Network Concepts
Network Access

Protecting Data and Devices
Malware
Health and Green IT

ECDL / ICDL Computer Essentials
This module sets out essential concepts and skills relating to the use of devices, file creation
and management, networks and data security.

Module Goals
Successful candidates will be able to:











Understand key concepts relating to ICT, computers, devices and software.
Start up and shut down a computer.
Work effectively on the computer desktop using icons, windows.
Adjust the main operating system settings and use built-in help features.
Create a simple document and print an output.
Know about the main concepts of file management and be able to efficiently organise
files and folders.
Understand key storage concepts and use utility software to compress and extract
large files.
Understand network concepts and connection options and be able to connect to a
network.
Understand the importance of protecting data and devices from malware and of
backing up data.
Recognise considerations relating to green IT, accessibility and user health.

CATEGORY
1 Computers and
Devices

SKILL SET
1.1.1 ICT

1.2 Hardware

© 2012 ECDL Foundation

REF.

TASK ITEM

1.1.1

Define the term Information and
Communication Technology
(ICT).

1.1.2

Identify different types of ICT
services/uses like: Internet
services, mobile technology,
office productivity applications.

1.2.1

Define the term hardware.
Identify the main types of
computers like: desktops,
laptops, tablets. Identify the
main types of devices like:
smartphones, media players,
digital cameras.

1.2.2

Define the terms processor,
Random Access Memory
(RAM), storage. Understand
their impact on performance
when using computers and
devices.
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CATEGORY

SKILL SET

1.3 Software and Licensing

1.4 Start Up, Shut Down

2 Desktop, Icons,
Settings

© 2012 ECDL Foundation

2.1 Desktop and Icons

REF.

TASK ITEM

1.2.3

Identify the main types of
integrated and external
equipment like: printers,
screens, scanners, keyboards,
mouse/trackpad, webcam,
speakers, microphone, docking
station.

1.2.4

Identify common input/output
ports like: USB, HDMI.

1.3.1

Define the term software and
distinguish between the main
types of software like: operating
systems, applications. Know
that software can be installed
locally or available online.

1.3.2

Define the term operating
system and identify some
common operating systems for
computers and devices.

1.3.3

Identify common examples of
applications like: office
productivity, communications,
social networking, media,
design, mobile applications.

1.3.4

Define the term End-User
License Agreement (EULA).
Recognise that software must
be licensed before use.

1.3.5

Outline the types of software
licenses: proprietary, open
source, trial version, shareware,
freeware.

1.4.1

Start a computer and log on
securely using a user name and
password.

1.4.2

Log off, shut down, restart a
computer using an appropriate
routine.

2.1.1

Outline the purpose of the
desktop and the task bar.

2.1.2

Identify common icons like
those representing: files,
folders, applications, printers,
drives, shortcuts/aliases,
recycle bin/wastebasket/trash.

Ref: ECDL / ICDL Computer Essentials - Syllabus - V1.0

CATEGORY

SKILL SET

2.2 Using Windows

2.3 Tools and Settings

3 Outputs

© 2012 ECDL Foundation

3.1 Working with Text

REF.

TASK ITEM

2.1.3

Select and move icons.

2.1.4

Create, rename, move, delete a
shortcut/alias.

2.2.1

Identify the different parts of a
window: title bar, menu bar,
toolbar, ribbon, status bar,
scroll bar.

2.2.2

Open, collapse, expand,
restore down, maximise, resize,
move, close a window.

2.2.3

Switch between open windows.

2.3.1

Use available help functions.

2.3.2

View the computer's basic
system information: operating
system name and version
number, installed RAM.

2.3.3

Change desktop configuration
settings: date and time, volume
settings, background,
resolution.

2.3.4

Change, add, remove keyboard
language. Change default
language.

2.3.5

Shut down a non-responding
application.

2.3.6

Install, uninstall an application.

2.3.7

Connect a device (USB flash
drive, digital camera, media
player) to a computer.
Disconnect a device using an
appropriate routine.

2.3.8

Capture a full screen, active
window.

3.1.1

Open, close a word processing
application. Open, close files.

3.1.2

Enter text into a document.

3.1.3

Copy, move text within a
document, between open
documents. Paste a screen
capture into a document.

Ref: ECDL / ICDL Computer Essentials - Syllabus - V1.0

CATEGORY

SKILL SET

3.2 Printing

4 File Management

© 2012 ECDL Foundation

4.1 Introducing Files and
Folders

REF.

TASK ITEM

3.1.4

Save and name a document.

3.2.1

Install, uninstall a printer. Print
a test page.

3.2.2

Set the default printer from an
installed printer list.

3.2.3

Print a document from a word
processing application.

3.2.4

View, pause, restart, cancel a
print job.

4.1.1

Understand how an operating
system organises drives,
folders, files in a hierarchical
structure. Navigate between
drives, folders, sub-folders,
files.

4.1.2

Display file, folder properties
like: name, size, location.

4.1.3

Change view to display files
and folders like: tiles, icons, list,
details.

4.1.4

Identify common file types like:
word processing, spreadsheet,
presentation, portable
document format (pdf), image,
audio, video, compressed,
executable files.

4.1.5

Open a file, folder, drive.

4.1.6

Recognise good practice in
folder, file naming: use
meaningful names for folders
and files to help with searching
and organisation.

4.1.7

Create a folder.

4.1.8

Rename a file, folder.

4.1.9

Search for files by properties:
all or part of file name using
wildcards if necessary, content,
date modified.

4.1.10

View list of recently used files.

Ref: ECDL / ICDL Computer Essentials - Syllabus - V1.0

CATEGORY

SKILL SET
4.2 Organising Files and
Folders

4.3 Storage and Compression

5 Networks

© 2012 ECDL Foundation

5.1 Network Concepts

REF.

TASK ITEM

4.2.1

Select individual, adjacent, nonadjacent files, folders.

4.2.2

Sort files in ascending,
descending order by name,
size, type, date modified.

4.2.3

Copy, move files, folders
between folders, drives.

4.2.4

Delete files, folders to the
recycle bin/wastebasket/trash
and restore to original location.

4.2.5

Empty the recycle
bin/wastebasket/trash.

4.3.1

Identify the main types of
storage media like: internal
hard disk, external hard disk,
network drive, CD, DVD, Bluray Disc, USB flash drive,
memory card, online file
storage.

4.3.2

Identify file size, folder size,
storage capacity measurements
like: KB, MB, GB, TB.

4.3.3

View available space on a
storage device.

4.3.4

Understand the purpose of file,
folder compression.

4.3.5

Compress files, folders.

4.3.6

Extract compressed files,
folders to a location on a drive.

5.1.1

Define the term network.
Outline the purpose of a
network: to share, access data
and devices securely.

5.1.2

Define the term Internet.
Identify some of its main uses
like: World Wide Web (WWW),
VoIP, e-mail, IM.

5.1.3

Define the terms intranet, virtual
private network (VPN) and
identify their main uses.

Ref: ECDL / ICDL Computer Essentials - Syllabus - V1.0

CATEGORY

SKILL SET

5.2 Network Access

6 Security and
Well-Being

6.1 Protecting Data and
Devices

6.2 Malware

© 2012 ECDL Foundation

REF.

TASK ITEM

5.1.4

Understand what transfer rate
means. Understand how it is
measured: bits per second
(bps), kilobits per second
(kbps), megabits per second
(mbps), gigabits per second
(gbps).

5.1.5

Understand the concepts of
downloading from, uploading to
a network.

5.2.1

Identify the different options for
connecting to the Internet like:
phone line, mobile phone,
cable, wi-fi, wi-max, satellite.

5.2.2

Define the term Internet Service
Provider (ISP). Identify
important considerations when
selecting an internet
subscription option like: upload
speed, download speed and
quota, cost.

5.2.3

Recognise the status of a
wireless network:
protected/secure, open.

5.2.4

Connect to a wireless network.

6.1.1

Recognise good password
policies like: create with
adequate length, adequate
character mix, do not share,
change regularly.

6.1.2

Define the term firewall and
outline its purpose.

6.1.3

Understand the purpose of
regularly backing up data to a
remote location.

6.1.4

Recognise the importance of
regularly updating software like:
anti-virus, application, operating
system software.

6.2.1

Understand the term malware.
Identify different types of
malware like: virus, worm,
Trojan, spyware.

6.2.2

Be aware how malware can
infect a computer or device.

Ref: ECDL / ICDL Computer Essentials - Syllabus - V1.0

CATEGORY

SKILL SET

6.3 Health and Green IT

© 2012 ECDL Foundation

REF.

TASK ITEM

6.2.3

Use anti-virus software to scan
a computer.

6.3.1

Recognise ways to help ensure
a user’s well-being while using
a computer or device like: take
regular breaks, ensure
appropriate lighting and
posture.

6.3.2

Recognise computer and
device energy saving practices:
turning off, adjusting automatic
shutdown, backlight, sleep
mode settings.

6.3.3

Recognise that computers,
devices, batteries, printer
cartridges and paper should be
recycled.

6.3.4

Identify some options available
for enhancing accessibility like:
voice recognition software,
screen reader, screen
magnifier, on-screen keyboard,
high contrast.
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Quick Reference

Computer Essentials									Quick Reference
This quick reference is for understanding the main concepts of ICT and using the computer and managing files on Windows 7

This module sets out essential concepts and skills relating to the use of devices, file
creation and management, networks and data security.
Successful candidates will be able to:

Keyboard Shortcuts & Commands

•

Understand key concepts relating to ICT, computers, devices and software.

•

Start up and shut down a computer.

•

Work effectively on the computer desktop using icons, windows.

•

Adjust the main operating system settings and use built-in help features.

•

Create a simple document and print an output.

•

Know about the main concepts of file management and be able to efficiently
organise files and folders.

Purpose

Keyboard
Shortcut

Purpose

Keyboard
Shortcut

•

Understand key storage concepts and use utility software to compress and
extract large files.

Open menu

ALT+LETTER

Undo

CTRL+Z

•

Help

F1

Up one screen

PAGE UP

Understand network concepts and connection options and be able to connect
to a network.

Cut

CTRL+X

Down one screen

PAGE DOWN

•

Understand the importance of protecting data and devices from malware and of
backing up data.

Copy

CTRL+C

Beginning of a line

HOME

•

Recognise considerations relating to green IT, accessibility and user health.

Paste

CTRL+V

End of line

END

1

Computers and Devices

1.1

ICT
Define the term Information and
Communication Technology (ICT).
• ICT - Using digital technology to access, store
and process information into an organized and
understandable form
Identify different types of ICT services and
uses like:
• Internet services - Examples include online
banking, online shopping, e-mail and data
transfer
• Mobile technology - Examples include using
the internet on smartphones, laptops
• Office productivity applications - Examples
include word processing, spread sheets,
presentation software
Hardware
Define the term hardware.
Hardware - Physical, tangible items that form part
of a computer system
Identify the main types of computers like:

1.1.1

1.1.2

1.2
1.2.1

1.2.1

Types of Computer

1.2.1

Desktop

A traditional stand-alone or
networked computer

Laptop

A small, portable computer
designed for mobile, flexible
use

Tablet

A small, mobile, hand-held
computer that combines
computing and Internet access

processing information
RAM - Working temporary memory that loses
its data when the computer is shut down
• Storage - Internal or external devices that
retain saved data.
• The type and speed of the processor, the
amount of RAM used, and the amount of
available storage space, can have an impact
on the computer’s overall performance.
1.2.3 Identify the main types of integrated and
external equipment like:
Devices that print
information on
Printers
paper or other
materials
Screens

Devices that
display text and
graphics

Scanners

Devices that read
images or text and
convert the data into
digital information

Keyboards

Typing devices used to
issue commands and
enter characters

Mouse/
Trackpad

A pointing device used
to select items and
issue commands

Web
camera
(webcam)
Speakers

Devices that produce
sound waves audible
to the human ear

Microphone

A device used to
digitally capture sound

Docking
Station

A device that connects
a laptop computer to
other devices

Identify the main types of devices like:
Types of Devices
Smart
Phone

Used for phone calls,
e-mail, Internet browsing,
and working with mobile
applications

Media
Player

Used to download and
play music and videos

Digital Camera

Used to take photographs in
digital format

Define the terms processor, Random Access
Memory (RAM), storage. Understand their
impact on performance when using computers
and devices.
• Processor - An important component for

1.3.2

1.3.3

1.3.4

1.3.5

1.2.4

1.3
1.2.2

A video camera used
to capture a digital
video

1.3.1

Identify common input/output ports like:
• Universal Serial Bus (USB) - Typically used to
connect storage and other devices
• High-Definition Multimedia Interface (HDMI) Typically used to connect media devices
Software and Licensing
Define the term software and distinguish
between the main types of software like:
operating systems, applications. Know that
software can be installed locally or available
online.

Software - Applications or programs that
perform specific tasks, such as word
processing or graphics editing
• Operating system - Controls the computer,
schedules tasks, manages storage, and
handles communication with other devices.
• Applications software - Designed for specific
tasks such as presentations or spreadsheets.
• Software can be installed on a specific
computer or device, on a network or accessed
via the cloud.
Define the term operating system and
identify some common operating systems for
computers and devices.
• Operating system - Software that schedules
tasks, manages storage and handles
communication with other devices
• Examples include Windows, Linux, Mac OS X
Identify common examples of applications like:
• Office productivity - Examples include word
processing and spreadsheets
• Communications - Examples include e-mail
and instant messaging
• Social networking - Examples include websites
that allows users to connect and exchange
status updates and comments
• Media - Examples include news applications
and social media applications
• Design - Examples include photo-editing and
desktop publishing
• Mobile applications - Examples include online
storage applications and e-mail applications
Define the term End-User License Agreement
(EULA). Recognise that software must be
licensed before use.
• EULA - A legal agreement between the user of
software and the software manufacturer
• Users should ensure all software used is fully
licensed before use.
Outline the types of software licenses:
• Proprietary - Software that must be bought
before use
• Open source - Free software that makes its
source code available
• Trial version - Software that can be used for
a restricted time only and users will have to
purchase to use further
• Shareware - Software that is distributed
on a try-before-you-buy basis with limited
functionality
• Freeware - Free copyrighted software
•

•

1.4

Start Up, Shut Down

© 2012, ECDL Foundation. This Quick Reference may be used by candidates to assist in preparation for this ECDL module test. ECDL Foundation does not warrant that use of this guide will ensure passing of the test.
Screen shots used with permission from Microsoft.

2.1

Start a computer and log on securely using a
user name and password.
• Make sure that both the computer and monitor
are plugged into a power source.
• Turn on the computer and the monitor.
• Enter a user name and password when
requested.
• Press the Return key.
Log off a computer using an appropriate
routine.
• Close any open files and applications.
• Click the Start button.
• Select the Shut Down arrow.
• Click Log off.
Shut down a computer using an appropriate
routine.
• Close any open files and applications.
• Click the Start button.
• Click Shut Down.
Restart a computer using an appropriate
routine.
• Close any open files and applications.
• Click the Start button.
• Select the Shut Down arrow.
• Click Restart.
Desktop and Icons

2

Desktop, Icons, Settings

2.1.1

Outline the purpose of the desktop and the
task bar.
• Desktop - Displays icons for files, folders and
applications
• Task bar- Shows active applications, files and
folders and other icons
Identify common icons like those representing:

1.4.1

1.4.2

1.4.2

1.4.2

2.1.2

2.2.1

Quick Reference

Identify the different parts of a window:
1. Title bar
2. Menu
3. Toolbar/Ribbon
4. Status bar
5. Scroll bar.
1

2

3

5
2.3.4

2.2.2

FILES

FOLDERS
2.2.3

4
Open, collapse, expand, restore down,
maximise, resize, move, close a window.
• To open a window, select the file or folder,
right-click and select Open.
• To collapse a window, click the Minimise
button in the upper right corner of the window.
• To expand a window, move the mouse to the
edge of the Title bar and drag the window to
increase the size.
• To restore down a window, click the Restore
Down button in the upper right corner of the
window.
• To maximise a window, click the Maximise
button in the upper right corner of the window.
• To resize a window, move the mouse over
the Title bar and drag the window to size
preferred.
• To move a window, move the mouse over
the Title bar and drag the window to a new
location.
• To close a window, click the Close button in
the upper right corner of the window.
Switch between open windows.

2.3.4

2.3.4

APPLICATIONS
•
PRINTERS

DRIVES

•
2.3
2.3.1

SHORTCUTS/ALIASES
RECYCLE BIN/WASTEBASKET/
TRASH
2.1.3

2.1.4

2.1.4

2.1.4

2.1.4

Select and move icons.
• On the desktop, click on an icon and drag and
drop to a new location.
Create a shortcut/alias.
• Select location to move shortcut to.
• Right-click and click Create shortcut.
Rename a shortcut/alias.
• Right-click on the shortcut icon.
• Click Rename.
• Enter new name.
Move a shortcut/alias.
• Right-click on the shortcut icon.
• Click Cut.
• Select location to move shortcut to.
• Right-click and select Paste.
Delete a shortcut/alias.
• Right-click on the shortcut icon.
• Click Delete.
• Click Yes to confirm deletion.

2.3.2

2.3.3

2.3.3

2.3.3

2.3.3

2.2

Using Windows

Right-click on the desktop and click Screen
resolution.
• Click the Resolution box.
• Click on the Resolution field arrow and drag
the slider to specify a screen resolution.
• Click Apply.
Change keyboard language.
• Click the Start button.
• Click Control Panel.
• Click Region and Language.
• Click on the Keyboards and Languages tab.
• Click Change Keyboards.
• Click on the preferred keyboard language.
• Click OK.
Add keyboard language.
• Click the Start button.
• Click Control Panel.
• Click Region and Language.
• Click on the Keyboards and Languages tab.
• Click Change Keyboards.
• Click Add.
• Click on the expandable button next to the
language required.
• Click on the expandable button next to the
keyboard.
• Check the language checkbox option
preferred.
• Click OK.
Remove keyboard language.
• Click the Start button.
• Click Control Panel.
• Click Region and Language.
• Click on the Keyboards and Languages tab.
• Click Change Keyboards.
• Select the keyboard language to remove.
• Click Remove
• Click OK.
Change default language.
• Click the Start button.
• Click Control Panel.
• Click Region and Language.
• Click on the Keyboards and Languages tab.
• Click Change Keyboards.
• Select the language button in Default language
input field.
• Select from the list of installed default
languages.
• Click OK.
Shut down a non-responding application.
• Press the Ctrl+Alt+Delete keys.
• Click the Start Task Manager button.
• In the Applications tab select the application.
• Click End Task.
Install an application.
• Click the Start button.
• Click Control Panel.
• Double-click Add or Remove Programs.
• Click Add New Programs.
• Click Install a program from the network.
• Select program to install to begin the wizard.
• Follow the wizard instructions.
Uninstall an application.
•

Move the mouse over the application icons
on the Task Bar so any open windows are
displayed.
Click the required window icons found on the
Task Bar.

Tools and Settings
Use available help functions.
• Click the Start button.
• Click Help and Support.
• Enter the query into the Search Help search
box.
• Press the Return key.
View the computer’s basic system information:
operating system name and version number,
installed RAM.
• Click the Start button.
• Click Control Panel.
• Click System.
Change desktop configuration settings: date
and time.
• Click the time shown on the right side of the
Task Bar.
• Click Change Date and time settings.
• Click Change Date and time.
• Enter a date and time.
• Click Apply.
Change desktop configuration settings: volume
settings.
• Double-click the speaker button on the right
side of the Task Bar.
• Adjust the volume as required.
Change desktop configuration settings:
background.
• Right-click on the desktop and click
Personalize.
• Click a theme to change the desktop
background.
• Click Apply.
Change desktop configuration settings:
resolution.

2.3.4

2.3.5

2.3.6

2.3.6

•
•
•

Click the Start button.
Click Control Panel.
Click Programs and Features.

2.3.7

2.3.7

2.3.8
2.3.8

3
3.1
3.1.1

3.1.1

3.1.1

3.1.1

3.1.2

3.1.3

3.1.3

3.1.3

3.1.4

3.2
3.2.1

3.2.1

3.2.1

3.2.2

• Select the application to uninstall.
• Click Uninstall/Change.
• Click Yes.
Connect a device (USB flash drive, digital
camera, media player) to a computer.
• Insert the flash drive (or cable for other device)
into the USB port on the computer.
• The computer will signal that a new device has
been detected.
• Save or view files and folders as needed.
Disconnect a device using an appropriate
routine.
• Click on the USB device icon on the Task Bar.
• Select Eject USB Disk and remove the USB
flash drive.
Capture a full screen.
• Press the Print Screen key.
Capture an active window.
• Open a window on the desktop.
• Press the Alt key + Print Screen key.

Outputs
Working with Text
Open a word processing application.
• Click the Start button.
• Select All Programs.
• Click Microsoft Word 2010.
Close a word processing application.
• Click the File button.
• Click Exit.
Open files.
• Click the File button.
• Click Open.
• Select the document to open and click Open.
Close files.
• Click the File button.
• Click Close.
Enter text into a document.
• Click into the open word processing
document.
• Enter the text.
Copy text within a document, between open
documents.
• Select the text to copy.
• On the Home tab, in the Clipboard group, click
the Copy button.
• Click in a new location within the document or
within another open document.
• On the Home tab in the Clipboard group, click
the Paste button.
Move text within a document, between open
documents.
• Select the text to move.
• On the Home tab, in the Clipboard group, click
the Cut button.
• Click in a new location within the document or
within another open document.
• On the Home tab in the Clipboard group, click
the Paste button.
Paste a screen capture into a document.
• After taking the screen capture, click in a new
location within the document.
• On the Home tab in the Clipboard group, click
the Paste button.
Save and name a document.
• Click the File button.
• Click Save.
• Create a file name and select the location.
• Click Save.
Printing
Install a printer.
• Click the Start button.
• Click Devices and Printers.
• Click Add a printer.
• Follow the wizard instructions.
Uninstall a printer.
• Click the Start button.
• Click Devices and Printers.
• Select the printer.
• Right-click and select Remove device.
• Click Yes to confirm removal.
Print a test page.
• Right-click a printer.
• Click Printer properties.
• On the General tab, click Print Test Page.
• Click OK.
Set the default printer from an installed printer
list.
• Click the Start button.
• Click Devices and Printers.

3.2.3

3.2.4

• Select a printer to set as default printer.
• Right-click and click Set as Default Printer.
Print a document from a word processing
application.
• In an open document, click the File button.
• Select Print.
• Click Print.
View, pause, restart, cancel a print job.
• To view a print job, double-click on the Printer
icon on the Task Bar.
• To pause a print job, right-click the print job
and select Pause.
• To restart a print job, right-click the print job
and select Restart.
• To delete a print job, right-click the print job
and select Cancel.

4.1.1

4.1.1

4.1.6

4.1.7

4.1.8

4.1.9

4 File Management
4.1

4.1.5

Introducing Files and Folders
Understand how an operating system organises drives, folders, files in a hierarchical
structure.
• Windows Explorer displays the hierarchical
structure of files, folders, and drives on your
computer.
Navigate between drives, folders, sub-folders,
files.

4.1.9

4.1.9

4.1.9

Click the Start button.
Click Computer.
Double-click on the drive where the folder or
file is located.
• Locate the folder and file name on the
drive.
Display file, folder properties like: name, size,
location.
• Right-click on the file or folder.
• Select Properties.
• Click OK.
Change view to display files and folders like:
tiles, icons, list, details.
• In an open window, click on the Change your
view button.
• Click on a preferred option to view files or
folders.
Identify common file types like:
•
•
•

4.1.2

4.1.3

4.1.4

Common File Type

File Extension

Word Processing

.docx

Spreadsheet

.xlsx

Presentation

.pptx

Portable Document
Format

.pdf

Image

.gif, .jpg, .bmp

Audio

.mp3

Video

.avi

Compressed

.zip

Executable

.exe

4.1.10

4.2
4.2.1
4.2.1

File
Icon
4.2.1

4.2.2

4.2.2

4.2.2

Quick Reference

Open a file, folder, drive.
• Select the file, folder or drive to open.
• Right-click and click Open.
Recognise good practice in folder, file naming:
• Use meaningful names for folders and files to
help with searching and organisation.
Create a folder.
• Navigate to where the folder will be created.
• Right-click and click New.
• Click Folder.
• Enter a folder name and press the Return key.
Rename a file, folder.
• Right-click on the file or folder to re-name.
• Click Rename.
• Enter a new name.
• Press the Return key.
Search for files by properties: all or part of file
name.
• Double-click the Windows Explorer icon on the
Task Bar.
• In the search field enter a full file name or part
of a file name.
• Click Search.
Search for files by properties: using wildcards
if necessary
• Double-click the Windows Explorer icon on the
Task Bar.
• In the search field use wildcards in the criteria
boxes to perform search.
• Enter *.txt to find all files with the extension
.txt.
• Enter b*.* to find all files that begin with the
letter b.
• Click Search.
Search for files by properties: by content.
• Click the Start button.
• Click Search.
• Enter text.
Search for files by properties: by date modified.
• Double-click the Windows Explorer icon on the
Task Bar.
• Click in the Search Libraries field.
• Click Date modified.
• Select date required from displayed calendar.
View list of recently used files.
• Click the Start button.
• Select Recent Items.
• If the Recent Items button is not already
installed, right-click the Task Bar and click
Properties.
• In the Start Menu tab, click Customize.
• In the dialog displayed, check the Recent
Items checkbox.
• Click OK.
Organising Files and Folders
Select individual files, folders.
• Click on a file or folder.
Select adjacent files, folders.
• Click the first file or folder, hold down the Shift
key, and then click the last file or folder.
• Release the Shift key.
Select non-adjacent files, folders.
• Hold down the Ctrl key, and then click each file
or folder to select.
Sort files in ascending, descending order by
name.
• Click the View menu.
• Select Sort by.
• Click Name to sort files by name in ascending
order.
• Click the View menu.
• Select Sort by.
• Click Descending to sort in descending order.
Sort files in ascending, descending order by
size.
• Click the View menu.
• Select Sort by.
• Click Size to sort files by size in ascending
order.
• Click the View menu.
• Select Sort by.
• Click Descending to sort in descending order.
Sort files in ascending, descending order by
type.
• Click the View menu.
• Select Sort by.
• Click Type to sort files by name in ascending
order.
• Click the View menu.
• Select Sort by.
• Click Descending to sort in descending order.

4.2.2

4.2.3

4.2.3

4.2.4

4.2.4

4.2.5

4.3
4.3.1

Sort files in ascending, descending order by
date modified.
• Double-click on the folder containing the files
to sort.
• Click the View menu.
• Select Sort by.
• Click Date Modified to sort files by date
modified in ascending order.
•
Click the View menu.
• Select Sort by.
• Click Descending to sort in descending order.
Copy files, folders between folders, drives.
• Right-click on the file or folder to copy.
• Click Copy.
• Click on the new location.
• Right-click and click Paste.
Move files, folders between folders, drives.
• Right-click on the file or folder to move.
• Click Cut.
• Click on the new location.
• Right-click and click Paste.
Delete files, folders to the recycle bin/
wastebasket/trash.
• Right-click on the file or folder to delete.
• Click Delete.
• Click Yes to confirm deletion.
Restore files, folders to original location.
• Double-click the Recycle Bin icon.
• Select the items to restore.
• On the Recycle Bin Tasks pane, click Restore
the selected items.
Empty the recycle bin/wastebasket/trash.
• Open the Recycle Bin.
• On the Recycle Bin Tasks pane, click Empty
Recycle Bin.

5.1

Compress files, folders.
• Select files.
• Right-click on files.
• Select Send To.
• Select Compressed (zipped) Folder.
Extract compressed files, folders to a location
on a drive.
• Right-click on the compressed file icon.
• Select Extract All.
Network Concepts

5

Networks

5.1.1

Define the term network.
• Network- More than one computer or device
connected together to share data, applications
or peripherals
Outline the purpose of a network:
• Share, access data and devices securely
Define the term Internet. Identify some of its
main uses like: World Wide Web (WWW), VoIP,
e-mail, IM.
• Internet - A global network connecting millions
of computers worldwide
• Main uses - To provide access to information
via the World Wide Web, to allow conversations over the internet (VoIP), to allow digital
message exchange via email and to allow
real-time text messaging via instant messaging
Define the terms intranet, virtual private network (VPN) and identify their main uses.
• Intranet - A private Internet used internally
within an organisation to store internal documents, training material or business specific
applications
• VPN - A network used to connect remote
users securely to a business network to share
data and communicate.
Understand what transfer rate means. Understand how it is measured: bits per second
(bps), kilobits per second (kbps), megabits per
second (mbps), gigabits per second (gbps).
• Transfer rate - The rate at which information is
transferred to or from a disk drive
• Measured in bits per second (bps), kilobits per
second (kbps), megabits per second (mbps),
gigabits per second (gbps).
Understand the concepts of downloading from,
uploading to a network.
• Downloading - To copy a file or image from a
web page
• Uploading - To copy a file or image from a
computer to a web page
Network Access
Identify the different options for connecting to
the Internet like:
• Phone line
• Mobile technology
• Cable
• Wi-fi
• Wi-max
• Satellite
Define the term Internet Service Provider (ISP).
• Internet Service Provider (ISP) - An organisation that provides access to the Internet
Identify important considerations when
selecting an Internet subscription option like:
• Upload speed
• Download speed
• Download quota
• Cost
Recognise the status of a wireless network:
• Protected/secure - The network is protected to
prevent unauthorised access.
• Open - The network is accessible to all
Connect to a wireless network.
• Double-click on the wireless connection icon
on the Task Bar.
• Select desired network and connect, using a
password if required.

4.3.5

4.3.6

5.1.1
5.1.2

5.1.3

Storage and Compression
Identify the main types of storage media like:
5.1.4

Storage
Media

Description

Internal hard
disk

A non-volatile, random access
storage device for digital data

External
hard disk

A hard disk located outside the
computer

Network
drive

A drive shared by multiple users
or devices

CD

An optical disc used to store music

DVD

An optical disc used to store video

Blu-ray Disc

A high definition optical disc used
to store media with up to five times
greater storage than DVDs

USB flash
drive

A portable digital storage device

Memory
card

A digital storage device used in
cameras and other devices

5.1.5

5.2

Online file
storage

A file storage service available over
the Internet

Identify file size, folder size, storage capacity
measurements like:

5.2.1

5.2.2

5.2.2

4.3.2

Unit Bit

Size

Comparable To

Kilobyte
(KB)

1,024
Bytes

½ page of plain
text

Megabyte
(MB)

1,024 KB

700 pages of
plain text or one
picture/graphic

Gigabyte
(GB)

1, 024 MB

A set of
encyclopaedias

Terabyte
(TB)

1,024 GB

A bookstore full
of books

4.3.3

4.3.4

View available space on a storage device.
• Select the drive or device.
• Right-click and select Properties.
• Click OK.
Understand the purpose of file, folder compression.
• Compressing files decreases a file’s size and
reduces the amount of space used for storage.

5.2.3

5.2.4

6.1
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6.1.1

6.1.2

6.1.3

6.1.4

6.2
6.2.1

6.2.2

6.2.3

6.3
6.3.1

6.3.2

6.3.3

6.3.4

Quick Reference

Firewall - A security system designed to protect a network against external threats
Understand the purpose of regularly backing
up data to a remote location.
• Important to have an off-site backup copy of
files in case of unforeseen network, hardware
or software problems, so that a copy of the
data is available if the original data were to
become unusable
Recognise the importance of regularly
updating software like: anti-virus,
application, operating system software.
• Update anti-virus regularly to detect new
viruses
• Update application and operating system
software regularly to fix known problems and
security risks
Malware
Define the term malware. Identify different
types of malware like: virus, worm, Trojan,
spyware.
• Malware - Malicious software designed to
install itself on a computer without the owner’s
consent
• Virus - Intrusive programs that infect computer
files and may cause damage
• Worm - Self-replicating malware that uses a
computer network to send copies of itself to
other computers
• Trojan - Destructive program that masquerades as an application.
• Spyware - Malware that collects information
on user browser habits without their consent
Be aware how malware can infect a computer
or device.
• Viruses can be transmitted via the installation
of a program from an insecure source on the
Internet, a CD- ROM, an online bulletin board,
or e-mail attachments.
Use anti-virus software to scan a computer.
• Open the virus scanning application.
• Enter the specific drive(s), folder(s) and name
of file to scan.
• Perform the scan.
Health and Green IT
Recognise ways to help ensure a user’s wellbeing while using a computer or device like:
• Take regular breaks
• Ensure appropriate lighting and posture
• Lighting should be bright enough and correctly
positioned.
• Correct positioning of the computer, desk and
seat will minimise bad posture.
Recognise computer and device energy saving
practices:
• Turning off - When not in use
• Adjusting automatic shut down - After a specified number of minutes not used
• Adjusting backlight - This can be decreased
• Adjusting sleep mode settings - This can be
activated after pre-set timings
Recognise that computers, devices, batteries,
printer cartridges and paper should be
recycled.
Identify some options available for enhancing
accessibility like:
•

Type

Description

Voice
recognition
software

Translates voice commands and
is used in place of a mouse and
keyboard

Screen
reader

Reads aloud information from a
computer display, for users with
impaired vision

Screen
magnifier

Displays enlarged screen content

Security and Well-Being

On-screen
keyboard

Provides an alternative to a
physical keyboard or inputting data

Recognise good password policies like:
• Create with adequate length
• Create with adequate character mix
• Do not share
• Change regularly
Define the term firewall and outline its purpose.

High
contrast

Makes the screen easier to view
for users

Protecting Data on Computers and Devices
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Online Essentials

This module sets out essential concepts and skills
relating to web browsing, effective information search,
online communication and e-mail.

Module Summary

SYLLABUS OUTLINE

CATEGORY

SKILL SET

On completion of this module the candidate will be able to:
Understand web browsing and online security concepts.
Use the web browser and manage browser settings, bookmarks,
and web outputs.
Search effectively for online information and critically evaluate
web content.
Understand key copyright and data protection issues.
Understand concepts of online communities, communications
and email.
Send, receive e-mails and manage email settings.
Organise and search emails and use calendars.

Web Browsing Concepts

Web Browsing

Web-Based Information

WHAT ARE THE BENEFITS OF THIS MODULE?

Covers the key skills needed to understand the main concepts
relating to web browsing and online security.
Certifies best practice in effective online computer use.
Developed with input from computer users, subject matter
experts, and practising computer professionals from all over the
world. This process ensures the relevance and range of module
content.

HOW DO I GET STARTED?
To find out more about this module and to locate your nearest
accredited test centre, please visit www.ecdl.org/programmes.

Communication
Concepts

Using E-mail

Key Concepts
Security and Safety

Using the Web Browser
Tools and Settings
Bookmarks
Web Outputs

Search
Critical Evaluation
Copyright, Data Protection

Online Communities
Communication Tools
E-mail Concepts

Sending E-mail
Receiving E-mail
Tools and Settings
Organising E-mails
Using Calendars

ECDL / ICDL Online Essentials
This module sets out essential concepts and skills relating to web browsing, effective
information search, online communication and e-mail.

Module Goals
Successful candidates will be able to:








Understand web browsing and online security concepts.
Use the web browser and manage browser settings, bookmarks, web outputs.
Search effectively for online information and critically evaluate web content.
Understand key copyright and data protection issues.
Understand concepts of online communities, communications and e-mail.
Send, receive e-mails and manage e-mail settings.
Organise and search e-mails and use calendars.
CATEGORY

1 Web Browsing
Concepts

SKILL SET
1.1 Key Concepts

1.2 Security and Safety

© 2012 ECDL Foundation
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TASK ITEM

1.1.1

Understand the terms: Internet,
World Wide Web (WWW),
Uniform Resource Locator (URL),
hyperlink.

1.1.2

Understand the structure of a web
address. Identify common types
of domains like: geographical,
organisation (.org, .edu, .com,
.gov).

1.1.3

Define the term web browser.
Identify common web browsers.

1.1.4

Outline different Internet activities
like: information searching,
shopping, learning, publishing,
banking, government services,
entertainment, communication.

1.2.1

Recognise ways to protect
yourself when online: purchase
from secure reputable websites,
avoid unnecessary disclosure of
personal and financial
information, log off from websites.

1.2.2

Define the term encryption.

1.2.3

Identify a secure website: https,
lock symbol.
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CATEGORY

2 Web Browsing

SKILL SET

2.1 Using the Web Browser

2.2 Tools and Settings
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REF.

TASK ITEM

1.2.4

Define the term digital certificate.

1.2.5

Recognise options for controlling
Internet use like: supervision, web
browsing restrictions, download
restrictions.

2.1.1

Open, close a web browsing
application.

2.1.2

Enter a URL in the address bar
and go to the URL.

2.1.3

Refresh a web page, stop a web
page downloading.

2.1.4

Activate a hyperlink.

2.1.5

Open a web page in a new tab,
new window.

2.1.6

Open, close tabs, windows.
Switch between tabs, windows.

2.1.7

Navigate between pages:
backwards, forwards, home page.

2.1.8

Show previously visited URLs
using history.

2.1.9

Complete, submit, reset a webbased form.

2.1.10

Use a web tool to translate a web
page, text.

2.2.1

Set the web browser home page.

2.2.2

Understand the term pop-up.
Allow, block pop-ups.

2.2.3

Understand the term cookie.
Allow, block cookies.

2.2.4

Use available help functions.

2.2.5

Display, hide built-in toolbars.
Restore, minimise the ribbon.

2.2.6

Delete history, temporary internet
files, saved form data.
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CATEGORY

SKILL SET
2.3 Bookmarks

2.4 Web Outputs

3 Web-Based
Information

3.1 Search

3.2 Critical Evaluation
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TASK ITEM

2.3.1

Add, delete a bookmark /
favourite.

2.3.2

Show bookmarks / favourites.

2.3.3

Create, delete a bookmarks /
favourites folder. Add web pages
to a bookmarks / favourites folder.

2.4.1

Download, save files to a location.

2.4.2

Copy text, image, URL to another
location like: document, e-mail.

2.4.3

Preview, print a web page,
selection from a web page using
available printing options.

3.1.1

Define the term search engine
and name some common search
engines.

3.1.2

Carry out a search using a
keyword, phrase.

3.1.3

Refine a search using advanced
search features like: exact
phrase, date, language, media
type.

3.1.4

Search a web-based
encyclopaedia, dictionary.

3.2.1

Understand the importance of
critically evaluating online
information. Understand the
purpose of different sites like:
information, entertainment,
opinion, sales.

3.2.2

Outline factors that determine the
credibility of a website like:
author, referencing, up-to-date
content.

3.2.3

Recognise the appropriateness of
online information for a particular
audience.
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CATEGORY

SKILL SET
3.3 Copyright, Data
Protection

4 Communication
Concepts

4.1 Online Communities

4.2 Communication Tools

4.3 E-mail Concepts
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TASK ITEM

3.3.1

Define the terms copyright,
intellectual property. Recognise
the need to acknowledge sources
and/or seek permission as
appropriate.

3.3.2

Recognise the main data
protection rights and obligations in
your country.

4.1.1

Understand the concept of an
online (virtual) community. Identify
examples like: social networking
websites, Internet forums, web
conferencing, chat, online
computer games.

4.1.2

Outline ways that users can
publish and share content online:
blogs, microblogs, podcasts,
images, audio and video clips.

4.1.3

Recognise ways to protect
yourself when using online
communities: apply appropriate
privacy settings, restrict available
personal information, use private
messaging when appropriate,
disable location information,
block/report unknown users.

4.2.1

Define the term Instant
Messaging (IM).

4.2.2

Define the terms short message
service (SMS), multimedia
message service (MMS).

4.2.3

Define the term Voice over
Internet Protocol (VoIP).

4.2.4

Recognise good practice when
using electronic communication:
be accurate and brief, use clear
subject headings, do not
inappropriately disclose personal
details, do not circulate
inappropriate content, spell check
content.

4.3.1

Define the term e-mail and outline
its main uses.
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5 Using E-mail

SKILL SET

5.1 Sending E-mail

5.2 Receiving E-mail
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TASK ITEM

4.3.2

Identify the structure of an e-mail
address.

4.3.3

Be aware of possible problems
when sending file attachments
like: file size limits, file type
restrictions.

4.3.4

Outline the difference between
the To, Copy (Cc), Blind copy
(Bcc) fields and recognise their
appropriate use.

4.3.5

Be aware of the possibility of
receiving fraudulent and
unsolicited e-mail. Be aware of
the possibility of an e-mail
infecting the computer.

4.3.6

Define the term phishing.

5.1.1

Access an e-mail account.

5.1.2

Outline the main purpose of
standard e-mail folders: Inbox,
Outbox, Sent, Deleted / Trash
Items, Draft, Spam/Junk.

5.1.3

Create an e-mail.

5.1.4

Enter one or more e-mail
addresses, distribution list in the
To, Copy (Cc), Blind copy (Bcc)
fields.

5.1.5

Enter an appropriate title in the
subject field and enter, paste text
into the body of an e-mail.

5.1.6

Add, remove a file attachment.

5.1.7

Send an e-mail with, without
priority.

5.2.1

Open, close an e-mail.

5.2.2

Use the reply, reply to all function,
and identify when these should be
used.

5.2.3

Forward an e-mail.
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SKILL SET

5.3 Tools and Settings

5.4 Organising E-mails

5.5 Using Calendars
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TASK ITEM

5.2.4

Open, save a file attachment to a
location.

5.2.5

Preview, print a message using
available printing options.

5.3.1

Use available help functions.

5.3.2

Display, hide built-in toolbars.
Restore, minimise the ribbon.

5.3.3

Create and insert a text e-mail
signature.

5.3.4

Turn on, turn off an automatic out
of office reply.

5.3.5

Recognise e-mail status as read,
unread. Mark an e-mail as read,
unread. Flag, unflag an e-mail.

5.3.6

Create, delete, update a contact,
distribution list / mailing list.

5.4.1

Add, remove message inbox
headings like: sender, subject,
date received.

5.4.2

Search for an e-mail by sender,
subject, e-mail content.

5.4.3

Sort e-mails by name, by date, by
size.

5.4.4

Create, delete an e-mail
folder/label. Move e-mails to an email folder/label.

5.4.5

Delete an e-mail. Restore a
deleted e-mail.

5.4.6

Empty the e-mail bin/deleted
items /trash folder.

5.4.7

Move a message to, remove a
message from a junk folder.

5.5.1

Create, cancel, update a meeting
in a calendar.
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TASK ITEM

5.5.2

Add invitees, resources to a
meeting in a calendar. Remove
invitees, resources from a
meeting in a calendar.

5.5.3

Accept, decline an invitation.
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Online Essentials										Quick Reference
This quick reference is for Microsoft Internet Explorer 9.0 and Outlook 2010

This module sets out essential concepts and skills relating to web
browsing, effective information search, online communication
and e-mail.
Successful candidates will be able to:
•

Understand web browsing and online security concepts.

•

Use the web browser and manage browser settings, bookmarks, web outputs.

•

Search effectively for online information and critically evaluate web content.

•

Understand key copyright and data protection issues.

•

Understand concepts of online communities, communications and e-mail.

•

Send, receive e-mails and manage e-mail settings.

•

Organise and search e-mails and use calendars.

Keyboard Shortcuts & Commands
Purpose

Keyboard Shortcut

Purpose

Keyboard Shortcut

Open menu

ALT+LETTER

Undo

CTRL+Z

Help

F1

Up one screen

PAGE UP

Cut

CTRL+X

Down one screen

PAGE DOWN

Copy

CTRL+C

Beginning of a line

HOME

Paste

CTRL+V

End of line

END

1 Web Browsing Concepts
1.1
1.1.1

1.1.2

Key Concepts
Understand the terms: Internet, World Wide
Web (WWW), Uniform Resource Locator (URL),
hyperlink.
• Internet - A global network connecting millions
of computers worldwide
• World Wide Web (WWW) - A collection of
linked documents residing on Internet servers
around the world
• Uniform Resource Locator (URL) - An address
for web pages found on the Internet
• Hyperlink - A link that transfers the user from
one web page to another web page by clicking
on a highlighted word or icon
Understand the structure of a web address.
• Protocol - Usually http:// (Hypertext Transfer
Protocol) this defines how the information is
transmitted
• WWW - Indicates the website is on the World
Wide Web
• Domain - The section of the Internet owned by
the website
• Extension - Identifies either the type of
organisation or the country of origin of the
website.

1.2
1.2.1
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Protocol
www Domain
Extension
Identify common types of domains like:
geographical, organisation (.org, .edu, .com,
.gov).
• Geographical domain - Two letter identifier that
lists where the website is registered
• Organisation domain - Three letter identifier
that identifies if the organisation is commercial,
governmental, educational, non- profit making
etc.
Define the term web browser. Identify common
web browsers.
• Web browser - A software program used to
view information on the World Wide Web
• Examples - Firefox, Google Chrome, Internet
Explorer, Safari
Outline different Internet activities like:
• Information searching
• Shopping
• Learning
• Publishing
• Banking
• Government services

• Entertainment
• Communication
Security and Safety
Recognise ways to protect yourself when
online:
• Purchase from secure reputable websites More likely to have secure payment and data
protection
• Avoid unnecessary disclosure of personal and
financial information - Helps avoid identity
theft
• Log off from websites - Prevents others using
your personal details
Define the term encryption.
• Encryption - The encoding of data to prevent
unauthorised access
Identify a secure website: https, lock symbol.
• https - (Hypertext Transfer Protocol Secure) is
displayed in the Address Bar
• Lock symbol - Displayed in the Address Bar
Define the term digital certificate.
• Digital certificate - Certifies the validity and
credentials of a website
Recognise options for controlling Internet use
like:
• Supervision - Physical or software monitoring
of Internet activity
• Web browsing restrictions - Using browser
settings to control web browsing
• Download restrictions - Limiting the type or
amount of data downloaded
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2 Web Browsing
2.1
2.1.1

2.1.1

2.1.2

2.1.3

2.1.3

Using the Web Browser
Open a web browsing application.
• Click the Start Button.
• Select All Programs.
• Click Internet Explorer.
Close a web browsing application.
• Click the Close button in the top right of the
window.
• If message displayed, click Close all tabs.
Enter a URL in the address bar and go to the
URL.
• Click into the address bar.
• Enter the URL.
Refresh a web page.
• Click the Refresh button beside the Address
Bar.
Stop a web page downloading.

2.1.8

2.1.9

2.1.10

• Click the Stop button beside the Address Bar.
Activate a hyperlink.
• Place the mouse pointer over the hyperlink.
• Click on the hyperlink.
Open a web page in a new tab
• Open a Web page.
• Right-click on a link.
• Click Open in new tab.
Open a web page in a new window.
• Right-click on a link.
• Click Open in new window.
Open, close tabs, windows.
• To open a tab, click on the New Tab icon at the
top of the browser window.
• To close a tab, click the Close Tab icon in the
corner of the open tab.
• To open a window, click the Page menu on the
Command Bar and click New Window.
• To close a window, click on the Internet
Explorer icon on the taskbar and click the
Close button.
Switch between tabs, windows.
• To switch between tabs, click on the tab
required at the top of the browser window.
• To switch between windows, click on the
Internet Explorer icon on the Task Bar and
select the window required.
Navigate between pages: backwards, forwards,
home page.
• To show the previous web page visited, click
the Back button beside the Address Bar.
• To show the next web page visited, click the
Forward button beside the Address Bar.
• Click the Home button on the Command Bar.
Show previously visited URLs using history.
• Click the View favorites, feeds, and history
button.
• On the History tab, click on a date.
Complete, submit, reset a web-based form.
• To complete a form, click into each form field
and enter text or select from given options as
required.
• To send the entered data from the form to the
server, click Submit.
• To remove any entered data in the form and
start again, click Reset.
Use a web tool to translate a web page, text.
• To translate a web page, right-click and click
Translate with Bing.
• To translate text, select the text, right-click and
click Translate with Bing.

© 2012, ECDL Foundation. This Quick Reference may be used by candidates to assist in preparation for this ECDL module test. ECDL Foundation does not warrant that use of this guide will ensure passing of the test.
Screen shots used with permission from Microsoft.

2.2

Tools and Settings
2.3.3

2.4
2.4.1

2.4.1

2.2.1

2.2.2

2.2.2

2.2.3

2.2.3

2.2.4

2.2.5

2.2.5

2.2.6

2.3
2.3.1

2.3.1

2.3.2

2.3.3

2.3.3

Set the web browser home page.
• Navigate to the web page to set as the home
page.
• Click the Tools button on the Command Bar.
• Click Internet Options.
• Click Use current.
• Click OK.
Understand the term pop-up.
• Pop-up- A new browser window that opens
unrequested over current web page and
usually contain advertisements
Allow, block pop-ups.
• Click the Tools button.
• Click Internet Options.
• Select the Privacy tab.
• To allow pop-ups, uncheck the Turn on Pop-up
Blocker checkbox.
• To block pop-ups, check the Turn on Pop-up
Blocker checkbox.
• Click OK.
Understand the term cookie.
• Cookie - A text file stored on a user’s
computer that monitors their web habits
Allow, block cookies.
• Click the Tools button.
• Click Internet Options.
• Click the Privacy tab.
• Under Settings, move the slider to the top to
block all cookies or to the bottom to allow all
cookies.
• Click OK.
Use available help functions.
• Click the Help button
on the Command Bar.
• Click Internet Explorer Help.
Display, hide built-in toolbars.
• Right-click near the top of the window.
• To display a toolbar, click on the toolbar name
so that a check mark is showing.
• To hide a toolbar, click on the toolbar name to
remove the checkmark.
Restore, minimise the ribbon.
• To minimise the ribbon, click F11.
• To restore the ribbon, click F11.
Delete history, temporary internet files, saved
form data.
• Click the Tools button.
• Click Internet Options.
• In the General tab, in the Browsing History
field, click Delete.
• To delete history, check the History checkbox.
• To delete temporary internet files, check the
Temporary Internet Files check box.
• To delete saved form data, check the Form
Data check box.
• Click Delete.
Bookmarks
Add a bookmark / favourite.
• Go to a web page.
• Click the Favorites button.
• Click the Add to Favorites button.
• Click Add.
Delete a bookmark / favourite.
• Click the Favorites button.
• Click the Add to Favorites arrow.
• Click Organize Favorites.
• Select a web page and click Delete.
• Click Close.
Show bookmarks / favourites.
• Click the Favorites button.
• On the Favorites tab, click a web page.
Create a bookmarks / favourites folder.
• Click the Favorites button.
• Click the Add to Favorites arrow.
• Click Organize Favorites.
• Click New Folders and name the folder.
Delete a bookmarks / favourites folder.
• Click the Favorites button.
• Click the Add to Favorites arrow.

2.4.2

2.4.2

2.4.3
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• Click Organize Favorites.
• Select a folder and click the Delete button.
Add web pages to a bookmarks / favourites
folder.
• Click the Favorites button.
• Click the Add to Favorites button.
• Click the Create in arrow and select a folder to
store the bookmark in.
• Click Add.
Web Outputs
Download files to a location.
• Right-click on the item.
• Select Save Target As.
• Create a filename and select the location.
• Click Save.
Save files to a location.
• Click the Page button on the Command Bar.
• Click Save As.
• Select a location.
• Enter the file name.
• Click Save.
Copy text, image to another location like:
document, e-mail.
• Right-click on the text or image.
• Select Copy.
• Open a document or e-mail.
• Right-click and click Paste.
Copy URL from a web page to another location
like: document, e-mail.
• Click in the address bar.
• Select the URL.
• Right-click and click Copy.
• Open a document or e-mail.
• Right-click and click Paste.
Preview, selection from a web page using
available printing options.
• On the Command Bar, click the Print arrow.
• Click Print Preview.
Print a web page, selection from a web page
using available printing options.
• On the Command Bar, click the Print arrow.
• Click Print.
• To print a web page, click All and click Print.
• To print a selection from a web page, select
the text, click Selection and click Print.
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Search
Define the term search engine and name some
common search engines.
• Search engine - A website used to search for
information on the World Wide Web, based on
the criteria entered
• Examples-www.google.com, www.yahoo.com,
www.bing.com
Carry out a search using a keyword, phrase.
• Open a search engine.
• Click into the search box in the search engine
window.
• Enter the keyword or phrase and press the
Return key.
Refine a search using advanced search
features like: exact phrase, date, language,
media type.
• After initial search, click the More search tools
link from the search engine window.
• Enter a combination of criteria and selections
from the advanced choices.
Search a web-based encyclopaedia.
• Click into the Address Bar.
• Enter the URL http://en.wikipedia.org/wiki/
Main_Page.
• Click into the search box at the top right of
Wikipedia.
• Enter a keyword or phrase.
• Press the Return key.
Search a web-based dictionary.
• Click into the Address Bar.
• Enter the URL http://www.collinslanguage.
com.
• Click into the search box at the top of Collins
dictionary.
• Enter a word.
• Click the Search button.
Critical Evaluation
Understand the importance of critically
evaluating online information.
• Online data should be checked or questioned
rather than accepted as fact.
Understand the purpose of different sites like:
• Information - Giving readers facts on current
affairs, special interests
• Entertainment - Providing humorous or
engaging content
• Opinion - Sites, such as blogs, that provide the
author’s view on topics
• Sales - Online shopping and promoting
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products or services
Outline factors that determine the credibility of
a website like:
• Author- The author or authors should be
clearly identified
• Referencing - Referencing of all sources
quoted or mentioned should be clear
• Up-to-date content - Material should be
current and maintained
Recognise the appropriateness of online
information for a particular audience.
• Web content should be adapted to the needs
of the audience
• For example, those sites geared towards
children should have age-appropriate material,
higher graphic content, lower text volume.
Copyright, Data Protection
Define the terms copyright, intellectual
property.
• Copyright - Exclusive rights to a work for a
specified period of time
• Intellectual property - Creative ideas or
inventions that can be protected by the owner
Recognise the need to acknowledge sources
and/or seek permission as appropriate.
• To avoid plagiarism any content referenced or
quoted should be properly acknowledged
• Permission should be sought to quote
someone particularly for interviews or e-mail
exchanges
Recognise the main data protection rights and
obligations in your country.
• Note that rights can vary between countries
and states
• Destroy personal information no longer needed
by the business
• Notify data subjects if data about them
acquired in an unauthorised way
• Implement reasonable security
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Online Communities
Understand the concept of an online (virtual)
community.
• Like-minded individuals who interact online
Identify examples like:
• Social networking websites
• Internet forums
• Web conferencing
• Chat
• Online computer games
Outline ways that users can publish and share
content online:
• Blog - A shared on-line journal
• Microblog - A shared on-line journal with
smaller updates
• Podcasts - Digital media files released
regularly and can be downloaded through an
RSS feed
• Images - Digital photos and graphics
• Audio and video clips - typically shared on
sites like YouTube and Flickr
Recognise ways to protect yourself when using
online communities:
• Apply appropriate privacy settings- Make your
profile private
• Restrict available personal information- Help
avoid identity theft and fraud
• Use private messaging when appropriate- Do
not make personal communications public
• Disable location information- If not, your
current location is displayed
• Block/report unknown users- Unless you can
verify their identity
Communication Tools
Define the term Instant Messaging (IM).
• IM - Real-time text-based communication via
the Internet
Define the terms short message service (SMS),
multimedia message service (MMS).
• SMS - The sending and receiving of short text
messages between mobile devices.
• MMS - The sending and receiving of audio and
video clips between mobile devices.
Define the term Voice over Internet Protocol
(VoIP).
• Allows users to talk to each other in real time
over the Internet
Recognise good practice when using
electronic communication:
• Be accurate and brief
• Use clear subject headings
• Do not inappropriately disclose personal
details
• Do not circulate inappropriate content

4.3
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• Spell check content
E-mail Concepts
Define the term e-mail and outline its main
uses.
• An electronic message sent or received over
the Internet
• Used for sending and receiving messages and
attachments
Identify the structure of an e-mail address.

jdoe@ecdl.org
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UserName @ Sign Domain Name Extension
• UserName - A unique name identifying the
user’s e-mail name
• @ - Used to separate the user name from the
domain
• Domain Name - The location/company of the
e-mail address
• Extension - Typically identifies the type of
organisation or the country the e-mail address
is associated with
Be aware of possible problems when sending
file attachments like:
• File size limits - E-mail attachments may
exceed the e-mail provider’s maximum file size
limit
• File type restrictions - Executable files are
often rejected by e-mail servers
Outline the difference between the To, Copy
(Cc), Blind copy (Bcc) fields and recognise their
appropriate use.
• To - Main recipient of the e-mail and has to act
on the e-mail
• Cc - Included for informational purposes only
• Bcc - Blind carbon copy address not visible to
other recipients
Be aware of the possibility of receiving
fraudulent and unsolicited e-mail. Be aware
of the possibility of an e-mail infecting the
computer.
• E-mail users may receive e-mail or junk mail
from unscrupulous sources.
• Viruses may be activated when an e-mail
messages or attachments from unknown
sources are opened.
Define the term phishing.
• A fraudulent e-mail message that often has a
link to a fake website
• Encourages recipients to divulge personal and
financial details

5 Using E-mail
5.1
5.1.1

5.1.2

5.1.3

Sending E-mail
Access an e-mail account.
• Click the Start button.
• Select All Programs.
• Click Microsoft Office.
• Click Microsoft Office Outlook 2010.
Outline the main purpose of standard e-mail
folders:
• Inbox - Folder all e-mails are sent to by default
• Outbox - Temporary folder that sores e-mails
until they have been sent
• Sent - Folder that stores all sent e-mails
• Deleted / Trash Items - Stores mails no longer
needed
• Draft - Stores mails before the user chooses to
send them
• Spam/Junk - Stores incoming mail from
unknown or suspicious senders
Create an e-mail.

Enter one or more e-mail addresses,
distribution list in the Blind copy (Bcc) field.
• Click in the Bcc field.
• Enter the e-mail address of the Bcc recipient
or the name of a contact group.
5.1.5 Enter an appropriate title in the subject field
• Click in the Subject field.
• Enter the subject of the e-mail.
5.1.5
Enter text into the body of an e-mail.
• Click in the body of the e-mail and enter text
required.
5.1.5
Paste text into the body of an e-mail.
• Select the text to copy, right-click and select
Copy.
• Open the e-mail message and click the
location where you want to paste the text.
• On the Message tab, in the Clipboard group,
click the Paste button.
5.1.5 Spell check an e-mail.
• Click at the beginning of the e-mail message.
• On the Review tab, in the Proofing group, click
the Spelling & Grammar button.
• Correct errors as suggested.
• Once the spell check is complete, click OK.
5.1.6 Add a file attachment.
• On the Message tab, in the Include group,
click the Attach File button.
• Locate and select the file to attach.
• Click Insert.
5.1.6 Remove a file attachment.
• Select the attachment in the Attached field.
• Press the Delete Key.
5.1.7 Send an e-mail with, without priority.
• On the Message tab, in the Tags group, click
the High Importance or the Low Importance
button.
• Click Send.
5.2 Receiving E-mail
5.2.1 Open an e-mail.
• Select the Inbox icon on the Navigation pane.
• Double-click the e-mail.
5.2.1 Close an e-mail.
• Click the Close button at the top right of the
window.
5.2.2 Use the reply, reply to all function.
• Open the message.
• On the Home tab, in the Respond group, click
the Reply or the Reply all button.
• Enter any text required.
• Click Send.
5.2.2 Identify when the reply, reply to all function
should be used.
• Use Reply to send message to the Sender.
• Use Reply All to send message to the Sender
and to all of those in the Cc field.
5.2.3 Forward an e-mail.
• Open the message.
• On the Home tab, in the Respond group, click
the Forward button.
• Enter e-mail addresses into the To field and
the Cc field as required.
• Enter any text required.
• Click Send.
5.2.4 Open, save a file attachment to a location.
• Open the message.
• Right-click on the attachment.
• Select Save As.
• Create a file name and select a location to
save the file.
• Click Save.
5.2.5 Preview a message using available printing
options.
• Open the message.
• Click the File menu, select Print.
• A print preview is displayed on the right of the
window.
5.2.5 Print a message using available printing
options.
• Open the message.
• Click the File menu, select Print, then click
Print.
• Select desired options.
• Click OK.
5.3 Tools and Settings
5.3.1 Use available help functions.
Click the Help button
on the Standard
toolbar.
Display built-in toolbars.
• Right-click on the Toolbar area at the top of
the window.
• Click on a Toolbar that is not currently
displayed.
Hide built-in toolbars.
• Right-click on the Toolbar area at the top of
the window.
• Click on a Toolbar that is currently displayed.
Restore, minimise the ribbon.
• Right-click any tab.
•

On the Home tab, in the New group, click the
New E-mail button.
Enter one or more e-mail addresses,
distribution list in the To field.
• Click in the To field.
• Enter the e-mail address of the recipient or the
name of a contact group.
Enter one or more e-mail addresses,
distribution list in the Copy (Cc) field.
• Click in the Cc field.
• Enter the e-mail address of the Cc recipient or
the name of a contact group.
•
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To minimise the ribbon, click Minimize the
ribbon.
• To restore the ribbon, click on the checked
Minimize the ribbon.
Create a text e-mail signature.
• Create a new e-mail.
• On the Message tab, in the Include group,
click the Signature arrow.
• Click Signatures.
• On the E-mail signature tab click New.
• In the Enter a name for your new
signature box, enter a name.
• Click OK.
• In the Edit signature box, enter the text to be
included in the signature.
• To format the text, select the text, and then
use the style and formatting buttons to select
the options preferred
• Click OK.
Insert a text e-mail signature.
• Create a new e-mail.
• If the signature is not shown automatically, on
the Message tab, in the Include group, click
the Signature arrow.
• Click the name of the signature previously
created.
Turn on, turn off an automatic out of office
reply.
•

5.1.4

Click on the File menu, then click Info.
Click the Automatic Replies button.
To turn on an automatic out of office reply,
check the I am currently Out of the Office
checkbox.
• To turn off an automatic out of office reply,
check the I am currently In the Office
checkbox.
• Click OK.
Recognise e-mail status as read, unread. Flag,
unflag an e-mail.
• Read e-mail messages appear in regular type
with an open envelope icon.
• Unread e-mail messages appear in bold type
with a closed envelope icon.
Mark an e-mail as read, unread.
• Select the message.
• On the Home tab, in the Tags group, click the
Unread/Read button.
Flag an e-mail.
•
•
•
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Select the message.
On the Home tab, in the Tags group, click the
Follow Up button.
• Click option preferred.
Unflag an e-mail.
• Select the message.
• On the Home tab, in the Tags group, click the
Follow Up button.
• Click Clear Flag.
Create, delete, update a contact, distribution
list/mailing list.
•
•

5.3.5
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Click on the Contacts button on the navigation
pane.
• On the Home tab, in the New group, click the
New Contact button.
• Enter the contacts details in the required fields.
• In the Contact tab, in the Actions group, click
the Save & Close button.
Create a distribution list / mailing list.
• Click on the Contacts button on the navigation
pane.
• On the Home tab, in the New group, click the
New Contact Group button.
• Enter a name for the group in the Name field.
• On the Contact Group tab, in the Members
group, click the Add Members button.
• Select from where to enter members details.
• In the Contact group tab, in the Actions group,
click the Save & Close button.
Delete a contact, distribution list / mailing list.
• Select the contact or contact group to delete.
• On the Home tab, in the Delete group, click the
Delete button.
Update a contact, distribution list / mailing list.
• Double-click on the contact or contact group
to update.
• Enter or delete required fields.
• In the Contact or Contact Group tab, in the
Actions group, click the Save & Close button.
Organising E-mails
Add, remove message inbox headings like:
sender, subject, date received.
• On the View tab, in the Current View group,
click the View settings button.
• On the Advanced View Settings:Compact
dialog box, click the Columns button.
• To add inbox headings, select a field in the left
column and click Add.
• To remove inbox headings, select a field in the
right column and click Remove.
• Click OK.
Search for an e-mail by sender, subject.
• Select the Inbox.
• Click in the Search field.
• On the Search tab, in the Refine group, click
the From button or Subject button.
• Enter the search criteria.
Search for an e-mail by e-mail content.
• Select the Inbox.
• In the Search box enter text to search by.
• All e-mails with this text will be listed in the
Search Results window.
Sort e-mails by name, by date, by size.
• Select the Inbox.
• On the View tab, in the Current View group,
click the View settings button.
• On the Advanced View Settings:Compact
dialog box, click the Sort button.
•
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• To sort by name, click From.
• To sort by date, click Received.
• To sort by size, click Size.
• Click OK.
Create an e-mail folder/label.
• Select the Inbox.
• On the Folder tab, in the New group, click the
New Folder button.
• Enter a name for the folder in the Name: field.
• In Select where to place the folder, Inbox
should be highlighted.
• Click OK.
Delete an e-mail folder/label.
• Select the folder for deletion.
• On the Folder tab, in the Actions group, click
the Delete Folder button.
• Click Yes to the displayed message.
Move e-mails to an e-mail folder/label.
• Select a message to move.
• On the Home tab in the Move group, click the
Move arrow.
• Click Other Folder.
• Select folder preferred.
• Click OK.
Delete an e-mail.
• Select the e-mail message for deletion.
• On the Home tab in the Delete group, click the
Delete button.
Restore a deleted e-mail.
• Select the Deleted Items folder.
• Select a message to restore.
• On the Home tab in the Move group, click the
Move button.
• Click Other Folder.
• Select a destination folder.
• Click OK.
Empty the e-mail bin/deleted items /trash
folder.
• Select the Deleted Items folder.
• On the Folder tab, in the Clean Up group, click
the Empty Folder button.
• Click Yes to the displayed message.
Move a message to a junk folder.
• Select the message.
• On the Home tab in the Move group, click the
Move arrow.
• Click Other Folder.
• Select Junk E-mail.
• Click OK.
Remove a message from a junk folder.
• Click the Folders button on the Navigation
pane.
• Click Junk E-mail.
• On the Home tab in the Move group, click the
Move arrow.
• Click Other Folder.
• Select Inbox.
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Using Calendars
Create a meeting in a calendar.
• On the Home tab, in the New group, click the
New Meeting button.
• Enter details in the To, Subject and Location
fields.
• Enter details in the Start time fields.
• Enter details in the End time fields.
• Click Send.
Cancel a meeting in a calendar.
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Select the meeting.
On the Meeting tab, in the Actions group, click
Cancel meeting.
• When prompted, click Send Cancellation.
Update a meeting in a calendar.
• Select the meeting.
• On the Meeting tab, in the Actions group, click
Open.
• Enter new details as required.
• Click Send Update.
Add invitees, resources to a meeting in a
calendar.
• On the Meeting tab, in the Attendees group,
click the Add or Remove Attendees button.
• Select names from address book displayed.
• Click OK.
Remove invitees, resources from a meeting in
a calendar.
• On the Meeting tab, in the Attendees group,
click the Add or Remove Attendees button.
• Select names from Required field.
• Press the Delete key.
• Click OK.
Accept, decline an invitation.
• Open the meeting request.
• On the Meeting tab, in the Respond group,
click the Accept button.
• Click Send the response now.
Accept, decline an invitation.
• Open the meeting request.
• On the Meeting tab, in the Respond group,
click the Decline button.
•
•
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Word Processing

This module allows candidates to demonstrate the
ability to use a word processing application to
accomplish everyday tasks associated with creating,
formatting, and finishing small-sized word processing
documents, such as letters and other everyday
documents.

Module Summary

SYLLABUS OUTLINE

CATEGORY

SKILL SET

Using the
Application

Working with Documents
Enhancing Productivity

Document
Creation

Enter Text
Select, Edit

Formatting

Text
Paragraphs
Styles

On completion of this module the candidate will be able to:
Work with documents and save them in different file formats.
Choose built-in options, such as the Help function, to enhance
productivity.
Create and edit small-sized word processing documents that will
be ready to share and distribute.
Apply different formats to documents to enhance them before
distribution; recognise good practice in choosing the appropriate
formatting options.
Insert tables, images, and drawn objects into documents.
Prepare documents for mail merge operations.
Adjust document page settings.
Check and correct spelling before finally printing documents.

Objects

Mail Merge

WHAT ARE THE BENEFITS OF THIS MODULE?

Covers the key skills needed to use a word processing
application.
Can be applied to a range of word processing software from
vendor packages to ‘freeware’.
Certifies best practice in effective word processing software use.
Developed with input from computer users, subject matter
experts, and practising computer professionals from all over the
world. This process ensures the relevance and range of module
content.

HOW DO I GET STARTED?
To find out more about this module and to locate your nearest
accredited test centre, please visit www.ecdl.org/programmes.
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Word Processing
The following is the Syllabus for Word Processing, which provides the basis for the
practice-based test in this module.

Module Goals
Module

Word Processing requires the candidate to demonstrate the ability to use a word
processing application to create everyday letters and documents.
The candidate shall be able to:
•

Work with documents and save them in different file formats.

•

Choose built-in options such as the Help function to enhance productivity.

•

Create and edit small-sized word processing documents that will be ready to
share and distribute.

•

Apply different formats to documents to enhance them before distribution
and recognize good practice in choosing the appropriate formatting options.

•

Insert tables, images and drawn objects into documents.

•

Prepare documents for mail merge operations.

•

Adjust document page settings and check and correct spelling before finally
printing documents.

CATEGORY
3.1 Using the
Application

SKILL SET
3.1.1 Working with
Documents

3.1.2 Enhancing Productivity

REF.

TASK ITEM

3.1.1.1

Open, close a word processing
application. Open, close documents.

3.1.1.2

Create a new document based on
default template, other available
template like: memo, fax, agenda.

3.1.1.3

Save a document to a location on a
drive. Save a document under
another name to a location on a
drive.

3.1.1.4

Save a document as another file type
like: text file, Rich Text Format,
template, software specific file
extension, version number.

3.1.1.5

Switch between open documents.

3.1.2.1

Set basic options/preferences in the
application: user name, default folder
to open, save documents.

3.1.2.2

Use available Help functions.

CATEGORY

3.2 Document
Creation

SKILL SET

3.2.1 Enter Text

3.2.2 Select, Edit

3.3 Formatting

3.3.1 Text

3.3.2 Paragraphs

REF.

TASK ITEM

3.1.2.3

Use magnification/zoom tools.

3.1.2.4

Display, hide built-in toolbars.
Restore, minimize the ribbon.

3.2.1.1

Switch between page view modes.

3.2.1.2

Enter text into a document.

3.2.1.3

Insert symbols or special characters
like: ©, ®, ™.

3.2.2.1

Display, hide non-printing formatting
marks like: spaces, paragraph
marks, manual line break marks, tab
characters.

3.2.2.2

Select character, word, line,
sentence, paragraph, entire body
text.

3.2.2.3

Edit content by entering, removing
characters, words within existing
text, by over-typing to replace
existing text.

3.2.2.4

Use a simple search command for a
specific word, phrase.

3.2.2.5

Use a simple replace command for a
specific word, phrase.

3.2.2.6

Copy, move text within a document,
between open documents.

3.2.2.7

Delete text.

3.2.2.8

Use the undo, redo command.

3.3.1.1

Change text formatting: font sizes,
font types.

3.3.1.2

Apply text formatting: bold, italic,
underline.

3.3.1.3

Apply text formatting: subscript,
superscript.

3.3.1.4

Apply different colours to text.

3.3.1.5

Apply case changes to text.

3.3.1.6

Apply automatic hyphenation.

3.3.2.1

Create, merge paragraph(s).

CATEGORY

SKILL SET

3.3.3 Styles

3.4 Objects

3.4.1 Table Creation

3.4.2 Table Formatting

REF.

TASK ITEM

3.3.2.2

Insert, remove soft carriage return
(line break).

3.3.2.3

Recognize good practice in aligning
text: use align, indent, tab tools
rather than inserting spaces.

3.3.2.4

Align text left, centre, right, justified.

3.3.2.5

Indent paragraphs: left, right, first
line.

3.3.2.6

Set, remove and use tabs: left,
centre, right, decimal.

3.3.2.7

Recognize good practice in
paragraph spacing: apply spacing
between paragraphs rather than use
the Return key.

3.3.2.8

Apply spacing above, below
paragraphs. Apply single, 1.5 lines,
double line spacing within
paragraphs.

3.3.2.9

Add, remove bullets, numbers in a
single level list. Switch between
different standard bullet, number
styles in a single level list.

3.3.2.10

Add a box border and
shading/background colour to a
paragraph.

3.3.3.1

Apply an existing character style to
selected text.

3.3.3.2

Apply an existing paragraph style to
one or more paragraphs.

3.3.3.3

Use copy format tool.

3.4.1.1

Create a table ready for data
insertion.

3.4.1.2

Insert, edit data in a table.

3.4.1.3

Select rows, columns, cells, entire
table.

3.4.1.4

Insert, delete, rows and columns.

3.4.2.1

Modify column width, row height.

3.4.2.2

Modify cell border line style, width,
colour.

CATEGORY

SKILL SET

3.4.3 Graphical Objects

3.5 Mail Merge

3.5.1 Preparation

3.5.2 Outputs

3.6 Prepare Outputs

3.6.1 Setup

3.6.2 Check and Print

REF.

TASK ITEM

3.4.2.3

Add shading/background colour to
cells.

3.4.3.1

Insert an object (picture, image,
chart, drawn object) to a specified
location in a document.

3.4.3.2

Select an object.

3.4.3.3

Copy, move an object within a
document, between open
documents.

3.4.3.4

Resize, delete an object.

3.5.1.1

Open, prepare a document, as a
main document for a mail merge.

3.5.1.2

Select a mailing list, other data file,
for use in a mail merge.

3.5.1.3

Insert data fields in a mail merge
main document (letter, address
labels).

3.5.2.1

Merge a mailing list with a letter,
label document as a new file or
printed output.

3.5.2.2

Print mail merge outputs: letters,
labels.

3.6.1.1

Change document orientation:
portrait, landscape. Change paper
size.

3.6.1.2

Change margins of entire document,
top, bottom, left, right.

3.6.1.3

Recognize good practice in adding
new pages: insert a page break
rather than using the Return key.

3.6.1.4

Insert, delete a page break in a
document.

3.6.1.5

Add, edit text in headers, footers.

3.6.1.6

Add fields in headers, footers: date,
page number information, file name.

3.6.1.7

Apply automatic page numbering to
a document.

3.6.2.1

Spell check a document and make
changes like: correcting spelling
errors, deleting repeated words.

CATEGORY

SKILL SET

REF.

TASK ITEM

3.6.2.2

Add words to a built-in custom
dictionary using a spell checker.

3.6.2.3

Preview a document.

3.6.2.4

Print a document from an installed
printer using output options like:
entire document, specific pages,
number of copies.

Quick Reference

Quick Reference

Word Processing

This quick reference is for Microsoft Word 2007 on Windows XP

Word 2007 Tabs

Certification Test Goals
This module sets out essential concepts and skills relating to the ability to use a
word processing application to create everyday letters and documents.

Home

Successful candidates will be able to:
Work with documents and save them in different file formats.
Choose built-in options such as the Help function to enhance productivity.

Insert

Create and edit small-sized word processing documents that will be ready to
share and distribute.
Apply different formats to documents to enhance them before distribution and
recognize good practice in choosing the appropriate formatting options.

Page Layout

Insert tables, images and drawn objects into documents.
Prepare documents for mail merge operations.
Adjust document page settings and check and correct spelling before finally
printing documents.

References

Mailings

Review

Keyboard Shortcuts
General

Navigation

Open a document CTRL+O

Up one screen PAGE UP

Save a document CTRL+S

Down one screen PAGE DOWN

Print a document CTRL+P

Beginning of line HOME

Close a document CTRL+W

End of line END

Undo CTRL+Z

Beginning of a document CTRL+HOME

Redo or Repeat CTRL+Y

End of a document CTRL+END

Help F1
Switch between apps ALT+TAB

View

1

Using the Application

1.1

Working with Documents
Open a word processing application.
Click the Start button.
Select All Programs.
Click Microsoft Word 2007.
Close a word processing application.
Click the Office button.
Click Exit Word.
Open documents.
Click the Office button.
Click Open.
Select document(s) to open and click Open.
Close documents.
Click the Office button.
Click Close.
Create a new document based on default template.
Click the Office button.
Click New.
Click Blank Document.
Click Create.
Create a new document based on other available
template like: memo, fax, agenda.
Click the Office button.
Click New.
Under templates, click Memos.
Click to select a memo template.
Click Download.
Save a document to a location on a drive.
Click the Office button.
Click Save.
Create a file name and select the location.
Click Save.

1.1.1

1.1.1

1.1.1

1.1.1

1.1.2

1.1.2

1.1.3

1.1.3

1.1.4

1.1.5

1.2
1.2.1

1.2.1

Editing

Formatting

Cut CTRL+X

Bold CTRL+B

Copy CTRL+C

Italics CTRL+I

Paste CTRL+V

Underline CTRL+U

Save a document under another name to a
location on a drive.
Click the Office button.
Click Save As.
Enter a new file name over the existing file name
and select the location.
Click Save.
Save a document as another file type like: text file,
Rich Text Format, template, software specific file
extension, version number.
Click the Office button.
Select Save As.
Click on the Save as type drop-down menu and
select a file type.
Click on Save.
Switch between open documents.
On the View tab, in the Windows group, click the
Switch Windows button.
Click the name of the document to switch to.
Enhancing Productivity
Set basic options/preferences in the application:
user name.
Click the Office button.
Click Word Options.
On the Popular tab, enter a user name in the
User name text box.
Click OK.
Set basic options/preferences in the
application: default folder to open,
save documents.
Click the Office button.
Click Word Options.

1.2.2

1.2.3

1.2.4

On the Save tab, enter a default file location
in the Default file location: text box.
Click OK.
Use available Help functions.
Click on the Help button
on the top right
of the ribbon.
Use magnification/zoom tools.

On the View tab, in the Zoom group, click
the Zoom button.
Select the magnification required.
Click OK.
Restore, minimize the ribbon.
Double click any tab to minimize the ribbon.
Double click any tab again to restore the
ribbon.

© 2012, ECDL Foundation. This Quick Reference may be used by candidates to assist in preparation for this ECDL module test. ECDL Foundation does not warrant that use of this guide will ensure passing of the test.
Screen shots used with permission from Microsoft.

2

Document Creation

2.1

Enter Text
Switch between page view modes.
On the View tab, in the Document Views group,
click on a view mode.
Print Layout view shows how a document will
look when printed.
Full Screen Reading view shows the document
at a size that is suitable for reading.
Web Layout view shows how a document will
look in a web browser.
Outline view shows the structure of the document
as nested levels of headings and body text.
Draft view shows the content of a document
with a simplified layout.
Enter text into a document.
Click in the document window.
Enter the text.
Insert symbols or special characters like: ©, ®, ™.

2.1.1

2.1.2

2.1.3

2.2.5

2.2.6

On the Insert tab, in the Symbols group, click the
Symbol button, and then click More Symbols.
On the Special Characters tab, select a special
character, like ©, ®, or ™, and click on the Insert
button.
2.2
2.2.1

2.2.2

2.2.3

2.2.3

2.2.4

Select, Edit
Display, hide non-printing formatting marks like:
spaces, paragraph marks, manual line break
marks, tab characters.
On the Home tab, in the Paragraph group, click
the Show/Hide button.
Select character, word, line, sentence, paragraph,
entire body text.

2.2.6

2.2.7

2.2.8

On the Home tab, in the Editing group, click the
Find button.
Enter the word or phrase to find into the Find what
box.
Click Find Next to select the first occurrence of the
word or phrase.
Use a simple replace command for a specific word,
phrase.

On the Home tab, in the Editing group, click the
Replace button.
Enter the word or phrase to find for replacement
into the Find what box.
Enter the word or phrase to replace into the Replace
with box.
Click Find Next.
Copy text within a document, between open
documents.
Select text to copy.
On the Home tab, in the Clipboard group, click the
Copy button.
Click in a new location within the document or within
another open document.
On the Home tab, in the Clipboard group, click the
Paste button.
Move text within a document, between open
documents.
Select the text to move.
On the Home tab, in the Clipboard group, click the
Cut button.
Click in a new location within the document or within
another open document.
On the Home tab, in the Clipboard group, click the
Paste button.
Delete text.
Select the text to delete.
Press the Delete Key.
Use the undo, redo command.
On the Quick Access Toolbar, click Undo or Repeat.

Select

Action

Word

Double-click the word

3

Formatting

Sentence

Ctrl + click in the sentence

3.1

Line

Click in the Selection Bar to the
left of the line

3.1.1

Paragraph

Triple-click the paragraph

Entire Body text

Triple-click in the Selection Bar

Text
Change text formatting: font sizes.
Select the text to format.
On the Home tab, in the Font group, click the Font
Size arrow.
Select a size from the list or enter a size into the
Font Size box.
Change text formatting: font types.
Select the text to format.
On the Home tab, in the Font group, click the Font
arrow.
Select a font from the list or enter a font name into
the Font box.
Apply text formatting: bold, italic, underline.
Select the text to format.
To embolden the text, on the Home tab, in the
Font group, click the Bold button.
To italicize the text, on the Home tab, in the
Font group, click the Italic button.
To underline the text, on the Home tab, in the
Font group, click the Underline button.
Apply text formatting: subscript, superscript.

Edit content by entering, removing characters,
words within existing text.
Select the text for editing in the document
window.
Begin typing.
Edit content by over-typing to replace existing
text.
To switch to Overtype mode, right-click on the
Status Bar and then click Overtype.
The Insert button will show on the left side of the
status bar.
Click the Insert button and the word Overtype
replaces the word Insert.
Click immediately before the text to replace.
Begin entering new text.
Use a simple search command for a specific
word, phrase.

3.1.1

3.1.2

3.1.3

Select the text to format.
On the Home tab, in the Font group, click the
Superscript or Subscript button.

3.1.5

Apply different colors to text.
Select the text to color.
On the Home tab, in the Font group, click the Font
Color arrow.
Click on a color.
Apply case changes to text.

3.1.6

Select the text to change case.
On the Home tab, in the Font group, click the
Change Case button.
To capitalize the first letter of a sentence, click
Sentence case.
To make all letters lowercase, click lowercase.
To capitalize all of the letters, click UPPERCASE.
To capitalize the first letter of each word, click
Capitalize Each Word.
To shift between two case views, click tOGGLE
cASE.
Apply automatic hyphenation.

3.1.4

Make sure that no text is selected.
On the Page Layout tab, in the Page Setup group,
click Hyphenation, and then click the Automatic
button.
3.2
3.2.1

3.2.2

3.2.3

3.2.4

3.2.4

3.2.4

3.2.5

Paragraphs
Create, merge paragraph(s).
To create a paragraph, press the Return key.
To merge paragraphs, click directly before first
paragraph mark.
Press the Delete key.
Insert, remove soft carriage return (line break).
To insert the line break, press the Shift + Return
keys.
To delete the line break, select line break and
press the Delete key.
Recognize good practice in aligning text.
Use align, indent, tab tools rather than inserting
spaces.
Align text left, right.
Select the text to align.
On the Home tab, in the Paragraph group,
click the Align Left or Align Right buttons.
Align text center.
Select the text to center.
On the Home tab, in the Paragraph group,
click the Center button.
Align text justified.
Select the text to justify.
On the Home tab, in the Paragraph group,
click the Justify button.
Indent paragraphs: left, right
Select the paragraph.
On the Page Layout tab, in the Paragraph group,
click the Paragraph group arrow.
To indent to the left, click in the Left box and enter
the indent required.
To indent to the right, click in the Right box and
enter the indent required.

3.2.5

3.2.6

3.2.7

3.2.8

3.2.8

Indent paragraphs: first line.
Click in front of the line to indent.
On the Page Layout tab, in the Paragraph group,
click the Paragraph group arrow.
Under Indentation, click the Special box arrow and
click First line.
Set, remove and use tabs: left, center, right,
decimal.
On the Page Layout tab, in the Paragraph group,
click the Paragraph group arrow.
In the Paragraph dialog box, click Tabs.
A Left Tab stop sets the start position of text; the
text entered moves to the right.
A Center Tab stop sets the position of the middle
of the text; the text entered centers on this position.
A Right Tab stop sets the right end of the text; the
text entered moves to the left.
A Decimal Tab stop aligns numbers around a
decimal point.
Recognize good practice in paragraph spacing.
Apply spacing between paragraphs rather than use
the Return key.
Apply spacing above, below paragraphs.
Select the paragraph to change.
On the Page Layout tab, in the Paragraph group,
click the Paragraph group arrow.
To adjust the spacing before the paragraph, click
the Before arrow up or down.
To adjust the spacing after the paragraph, click
the After arrow up or down.
Apply single, 1.5 lines, double line spacing within
paragraphs.

3.2.9

4.1.2

4.1.3

4.1.4

3.2.10

3.3
3.3.1

3.3.2

Select

3.2.9

Action

Select the paragraph to change.
On the Page Layout tab, in the Paragraph group,
click the Paragraph group arrow.
On the Indents and Spacing tab, click the Line
spacing arrow and select Single, 1.5 lines, or
Double line.
Add bullets, numbers in a single level list.

3.3.3

3.2.9

3.2.9

Select the bulleted list.
On the Home tab, in the Paragraph group,
click the Bullets arrows.
Click a bullet style in the Bullet Library.

Select the bulleted list.
On the Home tab, in the Paragraph group, click
the Numbering arrow.
Click a number style in the Numbering Library.
Add a box border and shading/background color
to a paragraph.
Select a paragraph.
On the Home tab, in the Paragraph group, click the
Border button arrow.
Click Borders and Shading.
Click the Borders tab.
Under Setting, click box border.
On the Shading tab, click the Fill arrow.
Click on a color.
Click OK.
Styles
Apply an existing character style to selected text.
Select the word to format.
On the Home tab, in the Styles group, move the
mouse over Quick Styles to preview various styles.
Click a character style to format the word.
Apply an existing paragraph style to one or more
paragraphs.
Select the paragraph to format.
On the Home tab, in the Styles group, move the
mouse over Quick Styles to preview various styles.
Click a paragraph style to format the paragraph.
Use copy format tool.
Select the text that has the format to copy.
On the Home tab, in the Clipboard group, click the
Format Painter button.
Select the text to apply the format.

4

Objects

4.1

Table Creation
Create a table ready for data insertion.

4.1.1

Select the list to bullet.
On the Home tab, in the Paragraph group, click
the Bullets button or Numbering button.
Remove bullets, numbers in a single level list.
Select the bulleted or numbered list.
On the Home tab, in the Paragraph group, click
the Bullets arrow or Numbering arrow.
Click None.
Switch between different standard bullet styles
in a single level list.

Switch between different standard number styles
in a single level list.

4.1.4

4.1.4

4.2
4.2.1

4.2.1

4.2.2

Click in the document where the table is required.
On the Insert tab, in the Tables group, click the
Table button.
Move the mouse cursor to the upper left cell.
Move the mouse cursor across to define number
of columns and down to define the number of rows.
Insert, edit data in a table.
Click in a cell and enter or delete text.
Select rows, columns, cells, entire table.
Click into the table.
On the Layout tab, in the Table group, click the
Select arrow and click Select Row, Select Column
or Select Table button.
Insert rows.

Click in the table.
On the Layout tab, in the Rows & Columns group,
click the Insert Above or Insert Below button.
Insert columns.
Click in the table.
On the Layout tab, in the Rows & Columns group,
click the Insert Left or Insert Right button.
Delete rows and columns.
Select the row or column to delete.
On the Layout tab, in the Rows & Columns group,
click the Delete button.
Click Delete Rows or Delete Columns.
Table Formatting
Modify column width.
Select a column.
On the Layout tab, in the Table group, click
Properties.
On the Column tab, select the Preferred width
box and enter the required width.
Click the Measure in box arrow to select
Centimeters or Percent.
Modify row height.
Select a row.
On the Layout tab, in the Table group, click
Properties.
On the Row tab, select the Specify height box and
enter the required height.
Click the Row height is box arrow to select At
least or Exactly.
Modify cell border line style, width, color.

Select a cell.
On the Layout tab, in the Table group, click
Properties.
On the Table tab, click the Borders and Shading
button.
On the Borders tab, select a line style from the
Style box.
Click the Width box to select a line width.
Click the Color box to select a color.
Click OK.
Click OK again.

4.2.3

4.3
4.3.1

4.3.2

4.3.3

4.3.3

4.3.4

4.3.4

Add shading/background color to cells.
Select cells.
On the Layout tab, in the Table group,
click Properties.
On the Table tab, click the Borders and Shading
button.
On the Shading tab, click the Fill box.
Under Theme Colors, click on a color.
Click OK.
Click OK again.
Graphical Objects
Insert an object (picture, image, chart, drawn
object) to a specified location in a document.
Click on the location to insert image.
On the Insert tab, in the Illustrations group,
click Picture, Shapes or Chart.
Select the object to insert.
Select an object.
Click on the picture, image, chart or drawn
object.
Copy an object within a document, between
open documents.
Select the object.
On the Home tab, in the Clipboard group,
click the Copy button.
Click in the document or in another open
document and click the Paste button.
Move an object within a document, between
open documents.
Select the object.
On the Home tab, in the Clipboard group,
click the Cut button.
Click in the document or in another open
document and click the Paste button.
Resize an object.
Click on the picture, image, chart, or drawn
object.
Drag the object’s sizing handles to the required
size.
Delete an object.
Click on the picture, image, chart, or drawn
object.
Press the Delete key.

5

Mail Merge

5.1

Preparation

In the Select Data Source dialog box, navigate to
and select the file which contains the recipient
details.
Click Open.
The Mail Merge Recipients dialog box opens,
displaying the records contained in the data source.
Click OK.
Click Next: Write your letter.
Under Write your letter, click Address block.
In the Insert Address Block dialog box, click OK to
accept the default settings.
Click Next: Preview your letters.
Under Preview your letters, click the arrows next to
the Recipient button to preview the letters.
Click Next: Complete the merge.
Click Edit individual letters.
Select All in the Merge to New Document dialog box.
Click OK.

6.1.5

6.1.5

6.1.6

6.1.6

6.1.6
5.2

Outputs
On the Quick Access Toolbar, click the Save button.
The document is saved as Letter1.
To print the merged document, open the merged
document.
Click the Office button.
Click Print.

6

Prepare Outputs

6.1

Setup
Change document orientation: portrait, landscape.

6.1.1

6.1.7

6.2
6.2.1

Action

6.1.1

6.1.2

6.1.3

6.1.4

On the Mailings tab, in the Start Mail Merge
group, click the Start Mail Merge button.
Click Step by Step Mail Merge Wizard.
Select Letters under Select document type.
Click Next: Starting document.
Under Select starting document, select Use the
current document.
Click Next: Select recipients.
Under Select Recipients, select Use an existing
list.
Click Browse.

6.1.5

6.1.4

6.1.5

On the Page Layout tab, in the Page Setup group,
click the Orientation button.
Click Portrait or Landscape.
Change paper size.
On the Page Layout tab, in the Page Setup group,
click the Size button.
Select a paper size.
Change margins of entire document: top, bottom,
left, right.
On the Page Layout tab, in the Page Setup group,
click the Margins button.
Click on Custom Margins.
On the Margins tab, enter a top, bottom, left, right
margin.
Recognize good practice in adding new pages:
Insert a page break rather than using the Return key.
Insert a page break in a document.
Click in the document where the page break should
be inserted.
On the Insert tab, in the Pages group, click the Page
Break button.
Delete a page break in a document.
On the Home tab, in the Paragraph group, click the
Show/Hide button.
In the document, click before the page break code.
Press the Delete key.
Add text in headers.
On the Insert tab, in the Header & Footer group,
click the Header button.
Select a header design.
Click in the header area at the top of the page and
enter text.

6.2.2

6.2.3

6.2.4

Edit text in headers.
Double click in the header area at the top of the
page and edit text.
Add text in footers.
On the Insert tab, in the Header & Footer group,
click the Footer button.
Select a footer design.
Click in the footer area at the bottom of the page
and enter text.
Edit text in footers.
Double click in the footer area at the bottom of the
page and edit text.
Add fields in headers, footers: date
Click in the header or footer.
On the Design tab, in the Insert group, click Date
& Time.
Select a format from the Available formats list.
Click OK.
Add fields in headers, footers: page number
information.
Double-click the header or footer.
On the Insert tab, in the Header & Footer group,
click Page Number.
Select Current Position.
Select a page number design.
Add fields in headers, footers: file name.
Double-click in the header or footer.
On the Design tab, in the Insert group, click
Quick Parts and then click the Field button.
In the Field names list, select FileName and
click OK.
Apply automatic page numbering to a document.
On the Insert tab, in the Header & Footer group,
click the Page Number button.
Select a page number position from the list.
Click on a page number design.
Check and Print
Spell-check a document and make changes like:
correcting spelling errors, deleting repeated
words.
On the Review tab, in the Proofing group, click the
Spelling & Grammar button.
When an incorrect spelling is found, select a
correct spelling from the list and click the
Change button.
When a repeated word is found, click the Delete
button.
Add words to a built-in custom dictionary using
a spell-checker.
On the Review tab, in the Proofing group, click the
Spelling & Grammar button.
When the spelling checker finds a word it does not
recognise, click the Add to Dictionary button.
Preview a document.
Click the Office button.
Select Print.
Click Print Preview.
Print a document from an installed printer using
output options like: entire document, specific
pages, number of copies.
Click the Office button.
Select Print.
Click the Print button.
To print the complete document, under
Print Range, select All.
To print specific pages, under Print Range, select
Pages and enter specific page numbers and/or
page ranges to print.
Under Copies, enter the number of copies to print.
Click OK.

For more information, visit:
www.ecdl.org
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Screen shots used with permission from Microsoft.
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Spreadsheets

This module allows candidates to understand the
concept of spreadsheets and to demonstrate an ability
to use a spreadsheet to produce accurate work
outputs.
On completion of this module the candidate will be able to:
Work with spreadsheets and save them in different file formats.
Choose built-in options, such as the Help function, within the
application to enhance productivity.
Enter data into cells; use good practice in creating lists.
Select, sort and copy, move and delete data.
Edit rows and columns in a worksheet.
Copy, move, delete, and appropriately rename worksheets.
Create mathematical and logical formulas using standard
spreadsheet functions; use good practice in formula creation;
recognise error values in formulas.
Format numbers and text content in a spreadsheet.
Choose, create, and format charts to communicate information
meaningfully.
Adjust spreadsheet page settings.
Check and correct spreadsheet content before finally printing
spreadsheets.

Module Summary

SYLLABUS OUTLINE

CATEGORY

SKILL SET

Using the
Application

Working with Spreadsheets
Enhancing Productivity

Cells

Insert, Select
Edit, Sort
Copy, Move, Delete

Managing
Worksheets

Rows and Columns
Worksheets

Formulas and
Functions

Arithmetic Formulas
Functions

Formatting

Charts

WHAT ARE THE BENEFITS OF THIS MODULE?

Covers the key skills needed to use spreadsheets.
Can be applied to a range of spreadsheets software from vendor
packages to ‘freeware’.
Certifies best practice in effective spreadsheets software use.
Developed with input from computer users, subject matter
experts, and practising computer professionals from all over the
world. This process ensures the relevance and range of module
content.

HOW DO I GET STARTED?
To find out more about this module and to locate your nearest
accredited test centre, please visit www.ecdl.org/programmes.

Prepare
Outputs

Numbers/Dates
Contents
Alignment, Border Effects

Create
Edit

Setup
Check and Print

Spreadsheets
The following is the Syllabus for Spreadsheets, which provides the basis for the
practice-based test in this module.

Module Goals
Module

Spreadsheets requires the candidate to understand the concept of spreadsheets
and to demonstrate an ability to use a spreadsheet to produce accurate work
outputs.
The candidate shall be able to:
•

Work with spreadsheets and save them in different file formats.

•

Choose built-in options such as the Help function within the application to
enhance productivity.

•

Enter data into cells and use good practice in creating lists. Select, sort and
copy, move and delete data.

•

Edit rows and columns in a worksheet. Copy, move, delete and
appropriately rename worksheets.

•

Create mathematical and logical formulas using standard spreadsheet
functions. Use good practice in formula creation and recognize error values
in formulas.

•

Format numbers and text content in a spreadsheet.

•

Choose, create and format charts to communicate information meaningfully.

•

Adjust spreadsheet page settings and check and correct spreadsheet
content before finally printing spreadsheets.

CATEGORY

SKILL SET

REF.

TASK ITEM

4.1 Using the
Application

4.1.1 Working with
Spreadsheets

4.1.1.1

Open, close a spreadsheet
application. Open, close
spreadsheets.

4.1.1.2

Create a new spreadsheet based on
default template.

4.1.1.3

Save a spreadsheet to a location on a
drive. Save a spreadsheet under
another name to a location on a drive.

4.1.1.4

Save a spreadsheet as another file
type like: template, text file, software
specific file extension, version
number.

4.1.1.5

Switch between open spreadsheets.

CATEGORY

4.2 Cells

SKILL SET

REF.

4.1.2 Enhancing Productivity

4.1.2.1

Set basic options/preferences in the
application: user name, default folder
to open, save spreadsheets.

4.1.2.2

Use available Help functions.

4.1.2.3

Use magnification/zoom tools.

4.1.2.4

Display, hide built-in toolbars.
Restore, minimize the ribbon.

4.2.1.1

Understand that a cell in a worksheet
should contain only one element of
data, (for example, first name detail in
one cell, surname detail in adjacent
cell).

4.2.1.2

Recognize good practice in creating
lists: avoid blank rows and columns in
the main body of list, insert blank row
before Total row, ensure cells
bordering list are blank.

4.2.1.3

Enter a number, date, text in a cell.

4.2.1.4

Select a cell, range of adjacent cells,
range of non-adjacent cells, entire
worksheet.

4.2.2.1

Edit cell content, modify existing cell
content.

4.2.2.2

Use the undo, redo command.

4.2.2.3

Use the search command for specific
content in a worksheet.

4.2.2.4

Use the replace command for specific
content in a worksheet.

4.2.2.5

Sort a cell range by one criterion in
ascending, descending numeric order,
ascending, descending alphabetic
order.

4.2.3.1

Copy the content of a cell, cell range
within a worksheet, between
worksheets, between open
spreadsheets.

4.2.3.2

Use the autofill tool/copy handle tool
to copy, increment data entries.

4.2.3.3

Move the content of a cell, cell range
within a worksheet, between
worksheets, between open
spreadsheets.

4.2.1 Insert, Select

4.2.2 Edit, Sort

4.2.3 Copy, Move, Delete

TASK ITEM

CATEGORY

4.3 Managing
Worksheets

SKILL SET

4.3.1 Rows and Columns

4.3.2 Worksheets

4.4 Formulas and
Functions

4.4.1 Arithmetic Formulas

4.4.2 Functions

REF.

TASK ITEM

4.2.3.4

Delete cell contents.

4.3.1.1

Select a row, range of adjacent rows,
range of non-adjacent rows.

4.3.1.2

Select a column, range of adjacent
columns, range of non-adjacent
columns.

4.3.1.3

Insert, delete rows and columns.

4.3.1.4

Modify column widths, row heights to
a specified value, to optimal width or
height.

4.3.1.5

Freeze, unfreeze row and/or column
titles.

4.3.2.1

Switch between worksheets.

4.3.2.2

Insert a new worksheet, delete a
worksheet.

4.3.2.3

Recognize good practice in naming
worksheets: use meaningful
worksheet names rather than accept
default names.

4.3.2.4

Copy, move, rename a worksheet
within a spreadsheet.

4.4.1.1

Recognize good practice in formula
creation: refer to cell references rather
than type numbers into formulas.

4.4.1.2

Create formulas using cell references
and arithmetic operators (addition,
subtraction, multiplication, division).

4.4.1.3

Identify and understand standard error
values associated with using formulas:
#NAME?, #DIV/0!, #REF!.

4.4.1.4

Understand and use relative, absolute
cell referencing in formulas.

4.4.2.1

Use sum, average, minimum,
maximum, count, counta, round
functions.

4.4.2.2

Use the logical function if (yielding one
of two specific values) with
comparison operator: =, >, <.

CATEGORY

SKILL SET

REF.

4.5 Formatting

4.5.1 Numbers/Dates

4.5.1.1

Format cells to display numbers to a
specific number of decimal places, to
display numbers with, without a
separator to indicate thousands.

4.5.1.2

Format cells to display a date style, to
display a currency symbol.

4.5.1.3

Format cells to display numbers as
percentages.

4.5.2.1

Change cell content appearance: font
sizes, font types.

4.5.2.2

Apply formatting to cell contents: bold,
italic, underline, double underline.

4.5.2.3

Apply different colours to cell content,
cell background.

4.5.2.4

Copy the formatting from a cell, cell
range to another cell, cell range.

4.5.3.1

Apply text wrapping to contents within
a cell, cell range.

4.5.3.2

Align cell contents: horizontally,
vertically. Adjust cell content
orientation.

4.5.3.3

Merge cells and centre a title in a
merged cell.

4.5.3.4

Add border effects to a cell, cell range:
lines, colours.

4.6.1.1

Create different types of charts from
spreadsheet data: column chart, bar
chart, line chart, pie chart.

4.6.1.2

Select a chart.

4.6.1.3

Change the chart type.

4.6.1.4

Move, resize, delete a chart.

4.6.2.1

Add, remove, edit a chart title.

4.6.2.2

Add data labels to a chart:
values/numbers, percentages.

4.6.2.3

Change chart area background
colour, legend fill colour.

4.6.2.4

Change the column, bar, line, pie slice
colours in the chart.

4.5.2 Contents

4.5.3 Alignment, Border
Effects

4.6 Charts

4.6.1 Create

4.6.2 Edit

TASK ITEM

CATEGORY

4.7 Prepare
Outputs

SKILL SET

4.7.1 Setup

4.7.2 Check and Print

REF.

TASK ITEM

4.6.2.5

Change font size and colour of chart
title, chart axes, chart legend text.

4.7.1.1

Change worksheet margins: top,
bottom, left, right.

4.7.1.2

Change worksheet orientation:
portrait, landscape. Change paper
size.

4.7.1.3

Adjust page setup to fit worksheet
contents on a specified number of
pages.

4.7.1.4

Add, edit, delete text in headers,
footers in a worksheet.

4.7.1.5

Insert and delete fields: page
numbering information, date, time, file
name, worksheet name into headers,
footers.

4.7.2.1

Check and correct spreadsheet
calculations and text.

4.7.2.2

Turn on, off display of gridlines,
display of row and column headings
for printing purposes.

4.7.2.3

Apply automatic title row(s) printing on
every page of a printed worksheet.

4.7.2.4

Preview a worksheet.

4.7.2.5

Print a selected cell range from a
worksheet, an entire worksheet,
number of copies of a worksheet, the
entire spreadsheet, a selected chart.

Quick Reference

Spreadsheets

Quick Reference

This quick reference is for Microsoft Excel 2007 on Windows XP

Excel 2007 Tabs

Certification Test Goals
This module sets out essential concepts and skills relating to understanding the concept
of spreadsheets and demonstrating an ability to use a spreadsheet to produce accurate
work outputs.

Home

Successful candidates will be able to:
Work with spreadsheets and save them in different file formats.
Choose built-in options such as the Help function within the application to enhance
productivity.
Enter data into cells and use good practice in creating lists. Select, sort and copy, move
and delete data.
Edit rows and columns in a worksheet. Copy, move, delete and appropriately rename
worksheets.
Create mathematical and logical formulas using standard spreadsheet functions. Use
good practice in formula creation and recognize error values in formulas.
Format numbers and text content in a spreadsheet.
Choose, create and format charts to communicate information meaningfully.
Adjust spreadsheet page settings and check and correct spreadsheet content before
finally printing spreadsheets.

Insert

Page Layout

Formulas

Keyboard Shortcuts

Data

General

Editing

Open a workbook CTRL+O

Cut CTRL+X

Save a workbook CTRL+S

Copy CTRL+C

Print a workbook CTRL+P

Paste CTRL+V

Close a workbook CTRL+W

Clear cell contents DELETE

Undo CTRL+Z

Edit active cell F2

Redo or Repeat CTRL+Y

Absolute reference F4

Help F1

Review

Switch between apps ALT+TAB

View

Navigation

Formatting

Up one screen PAGE UP

Bold CTRL+B

Down one screen PAGE DOWN

Italics CTRL+I

To cell A1 CTRL+HOME

Underline CTRL+U

To the last cell CTRL+END

1

Using the Application

1.1

Working with Spreadsheets
Open a spreadsheet application.
Click the Start button.
Select All Programs.
Click Microsoft Excel 2007.
Close a spreadsheet application.
Click the Office button.
Click Exit Excel.
Open spreadsheets.

1.1.2
1.1.1

1.1.1

1.1.1

1.1.3

1.1.3

1.1.4

1.1.1

Click the Office button.
Click Open.
Select spreadsheet(s) to open and click Open.
Close spreadsheets.
Click the Office button.
Click Close.

1.1.5

Create a new spreadsheet based on default
template.
Click the Office button.
Click New.
A blank workbook is highlighted, click Create.
Save a spreadsheet to a location on a drive.
Click the Office button.
Click Save.
Create a file name and select the location.
Click Save.
Save a spreadsheet under another name to a
location on a drive.
Click the Office button.
Click Save As.
Enter a new file name over the existing file name and
select the location.
Click Save.
Save a spreadsheet as another file type like:
template, text file, software specific file extension,
version number.
Click the Office button.
Click Save As.
Click on the Save as type arrow and select a file type.
Click Save.
Switch between open spreadsheets.
On the View tab, in the Windows group click the
Switch Windows button and then click the name
of the spreadsheet to switch to.

1.2
1.2.1

1.2.1

1.2.2

1.2.3

1.2.4

Enhancing Productivity
Set basic options/preferences in the application:
user name.
Click the Office button.
Click Excel Options.
On the Popular tab, enter a user name in the
User name: text box.
Click OK.
Set basic options/preferences in the application:
default folder to open, save spreadsheets.
Click the Office button.
Click Excel Options.
On the Save tab, enter a default file location in the
Default file location text box.
Click OK.
Use available Help functions.
Click on the Help button on the top right of
the ribbon.
Use magnification/zoom tools.
On the View tab, in the Zoom group, click the
Zoom button.
Select the magnification required.
Click OK.
Restore, minimize the ribbon.
Double-click any tab to minimize the ribbon.
Double-click any tab again to restore the ribbon.
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2

Cells

2.1

Insert, Select
Understand that a cell in a worksheet should contain
only one element of data.
For example, first name detail in one cell, surname
detail in adjacent cell.
Recognize good practice in creating lists:
Avoid blank rows and columns in the main body of list
Insert blank row before Total row
Ensure cells bordering list are blank
Enter a number, date, text in a cell.
Click into the cell.
Enter a number, date or text.
Select a cell.
Ensure the mouse cursor is a white cross.
Click on the cell.
Select a range of adjacent cells.
Ensure the mouse cursor is a white cross.
Click into the first cell and drag to the last cell in the
range.
Select a range of non-adjacent cells.
Ensure the mouse cursor is a white cross.
Select the first cell or range of cells.
Hold the Ctrl key down and continue highlighting
additional non-adjacent ranges.
Select an entire worksheet.

2.1.1

2.1.2

2.1.3

2.1.4

2.1.4

2.1.4

2.1.4

Click the Select All button found above Row 1 and to
the left of Column A.
2.2
2.2.1

2.2.1

2.2.2

2.2.3

Edit, Sort
Edit cell content.
Click into the cell.
Edit content.
Modify existing cell content.
Click into the cell.
Enter additional content or delete existing content.
Use the undo, redo command.
Go to the Quick Access Toolbar.
Click on the Undo or Redo buttons.
Use the search command for specific content in a
worksheet.

2.2.5

2.2.4

3.1.3

Click into the cell range to sort.
On the Data tab, in the Sort & Filter group, click
on one of the two Sort buttons.
Click on the Sort A to Z button to sort in
ascending order.
Click on the Sort Z to A button to sort in
descending order.
2.3
2.3.1

2.3.2

2.3.3

3
3.1
3.1.1

3.1.1

3.1.1

3.1.2

3.1.2

On the Home tab in the Editing group, click the
Find & Select button.
Click Replace.
Enter the word or phrase to find for replacement
in the Find what box.
Enter the word or phrase to replace in the Replace
with box.
Click Find Next to select the first occurrence of the
word or phrase.
Click Replace or Replace All.

3.1.3

3.1.3

2.3.4

On the Home tab, in the Editing group, click the
Find & Select button.
Click Find.
Enter the word or phrase to find in the Find what box.
Click Find Next to select the first occurrence of the
word or phrase.
Use the replace command for specific content in a
worksheet.

Sort a cell range by one criterion in ascending,
descending numeric order, ascending,
descending alphabetic order.

3.1.2

Copy, Move, Delete
Copy the content of a cell, cell range within a
worksheet, between worksheets, between open
spreadsheets.
Select the cell content to copy.
On the Home tab, in the Clipboard group, click
the Copy button.
Click on a new location within the worksheet or
within another open spreadsheet.
On the Home tab, in the Clipboard group, click
the Paste button.
Use the autofill tool/copy handle tool to copy,
increment data entries.
Select the cell or cell range to copy.
Move the mouse pointer over the lower right hand
corner of the selected cell or cell range.
Use the fill handle to drag through the range
required.
Move the content of a cell, cell range within a
worksheet, between worksheets, between open
spreadsheets.
Select the cell content to move.
On the Home tab, in the Clipboard group, click the
Cut button.
Click on a new location within the worksheet or
within another open spreadsheet.
On the Home tab, in the Clipboard group, click the
Paste button.
Delete cell contents.
Select the cell content to delete.
Press the Delete key.

3.1.3

3.1.4

3.1.4

3.1.5

3.1.5

3.1.5

Managing Worksheets
Rows and Columns
Select a row.
Click on the row heading.
Select a range of adjacent rows.
Click on the first row heading.
Drag to highlight through to the last row heading.
Select a range of non-adjacent rows.
Click on the first row heading or range of rows.
Hold the Ctrl key down and continue highlighting
additional row headings.
Select a column.
Click on the column heading.
Select a range of adjacent columns.
Click on the first column heading.
Drag to highlight through the last column heading.
Select a range of non-adjacent columns.
Click on the first column heading or range of
columns.
Hold the Ctrl key down and continue highlighting
additional column headings.

3.2
3.2.1

3.2.2

3.2.2

3.2.3

3.2.4

Insert rows.
Click on the row heading(s) above which the
row will appear.
On the Home tab, in the Cells group, click
the Insert button.
Insert columns.
Click on the column heading(s) immediately
to the right of where the column will appear.
On the Home tab, in the Cells group, click
the Insert button.
Delete rows.
Click on the row heading(s) to delete.
On the Home tab, in the Cells group,
click the Delete button.
Delete columns.
Click on the column heading(s) to delete.
On the Home tab, in the Cells group, click
the Delete button.
Modify column widths to a specified value,
to optimal width.
Click on the column heading(s) to modify.
On the Home tab, in the Cells group, click
the Format button.
To modify column width to a specified value,
click Column Width and enter a width, then
click OK.
To modify column width to optimal width,
click Autofit Column Width.
Modify row heights to a specified value, to
optimal height.
Click on the row heading(s) to modify.
On the Home tab, in the Cells group, click
the Format button.
To modify row height to a specified value,
click Row Height and enter a row height,
then click OK.
To modify row height to optimal height,
click Autofit Row Height.
Freeze row titles.
Select the row immediately below the row
to freeze.
On the View tab, in the Window group,
click the Freeze Panes arrow.
Click the Freeze Panes button.
Freeze column titles.
Select the column immediately to the right
of the column to freeze.
On the View tab, in the Window group,
click the Freeze Panes arrow.
Click the Freeze Panes button.
Unfreeze row and/or column titles.
On the View tab, in the Window group, click
the Freeze Panes arrow.
Click the Unfreeze Panes button.
Worksheets
Switch between worksheets.
Click on the worksheet tab at the bottom of
the workbook window.
Insert a new worksheet.
On the Home tab, in the Cells group, click the
Insert arrow.
Click the Insert Sheet button.
Delete a worksheet.
Select the sheet to delete.
On the Home tab, in the Cells group, click the
Delete arrow.
Click the Delete Sheet button.
Recognize good practice in naming
worksheets.
Use meaningful worksheet names rather than
accept default names.
Copy a worksheet within a spreadsheet.
Right-click the worksheet tab at the bottom
of the workbook window.
Click Move or Copy.
Select the location to copy the worksheet to.
Click Create a copy.
Click OK.

3.2.4

3.2.4

Move a worksheet within a spreadsheet.
Right-click the worksheet tab at the bottom of the
workbook window.
Click Move or Copy.
Select the location to move the file to.
Click OK.
Rename a worksheet within a spreadsheet.
Right-click the worksheet tab at the bottom of the
workbook window.
Click Rename.
Enter the worksheet name into the highlighted
worksheet tab.

4

Formulas & Functions

4.1

Arithmetic Formulas
Recognize good practice in formula creation:
Refer to cell references rather than type numbers into
formulas.
Create formulas using cell references and arithmetic
operators (addition, subtraction, multiplication,
division)
Click into the cell to enter the formula.
Enter the = (equals) sign.
Enter a formula using cell references and operators.

4.1.1

4.1.2

Symbol

Arithmetic Operator

+

Addition

*
/

4.1.3

Click into the cell to enter the formula.
On the Formulas tab, in the Function Library group,
click the Insert Function button.
Enter the function name in the highlighted Search
for a function text box.
Click Go.
Ensure the function is highlighted in the Select a
function drop-down list.
Click OK.
Enter the arguments for the function.
Click OK.

Subtraction
Multiplication
Division

Identify and understand standard error values
associated with using formulas:
Error

Cause
Column is not wide enough to display value

#Value!

Wrong type of argument or operand is used

#DIV/0!

Number is divided by zero

Name

Description

Sum

SUM

The sum of the values

Average

AVERAGE

The average of the values

Minimum MIN

The smallest value

Maximum MAX

The largest value

Count

4.2.2

#####

Function

5
5.1
5.1.1

COUNT

The number of data values

Counta

COUNTA

The number of data values in
non-blank cells

Round

ROUND

Numbers rounded to whole numbers

Use the logical function if (yielding one of two
specific values) with comparison operator: =, >, <.
The if function returns one value if a condition
specified evaluates to TRUE and another value if it
evaluates to FALSE.
Click into the cell to enter the formula.
Enter if in the highlighted Search for a function text
box.
Click Go.
Enter the arguments for the function.
Click OK.

5.1.2

5.1.3

5.2
5.2.1

5.2.1

5.2.2

Formatting
Numbers/Dates
Format cells to display numbers to a specific
number of decimal places.

#NAME? Doesn't recognize text in formula

4.1.4

4.2
4.2.1

#N/A

Value is not available to a function or formula

#REF!

Cell reference is not valid

#NUM!

Invalid numeric values in a formula or function

#NULL!

Cell references are not separated correctly in a formula

Understand and use relative, absolute cell
referencing in formulas.
A relative cell reference is based on the relative
position of the cell that contains the formula and the
cell the reference refers to.
An absolute cell reference always refers to a cell in a
specific location and is preceded by the $ sign.
Press F4 after selecting cell to make it an absolute cell
reference.
Either the row or column reference will be preceded
by the $ sign.
Functions
Use sum, average, minimum, maximum,
count, counta, round functions.

4.5.2.3

5.1.1

5.1.2

Select the cell or cell range.
On the Home tab, in the Number group, click the
Increase Decimal or Decrease Decimal button.
Each click will increase or decrease the number
by one decimal.
Format cells to display numbers with, without a
separator to indicate thousands.
Select the cell or cell range.
On the Home tab, in the Number group, click the
Comma Style button to use commas as a
separator or not.
Format cells to display a date style.

5.2.4

5.3
5.3.1

5.3.2

5.3.2

Select the cell or cell range.
On the Home tab, in the Cells group, click the
Format arrow.
Select Format Cells.
On the Number tab, select the Date category.
Select a date type from the Type: box.
Click OK.
Format cells to display a currency symbol.
Select the cell or cell range.
On the Home tab, in the Number group,
click the Currency arrow.
Click on a currency.
Format cells to display numbers as
percentages.
Select the cell or cell range.
On the Home tab, in the Number group, click
the Percent Style button.
Contents
Change cell content appearance: font sizes.

Select the cell or cell range.
On the Home tab, in the Font group, click the
Font Size arrow.
Select a size from the list or enter a size into
the Font Size box.
Change cell content appearance: font types.
Select the cell or cell range.
On the Home tab, in the Font group, click the
Font arrow.
Select a font from the list or enter a font into the
Font box.
Apply formatting to cell contents: bold, italic,
underline, double underline.
Select the text to format.
To embolden the text, on the Home tab, in the
Font group, click the Bold button.
To italicize the text, on the Home tab, in the
Font group, click the Italic button.
To underline the text, on the Home tab, in the
Font group, click the Underline button.
To double underline the text, on the Home tab,
in the Font group, click the Underline arrow
and click the Double Underline button.
Apply different colors to cell content, cell
background.
Select the cell or cell range to color.
On the Home tab, in the Font group, click the
Fill Color arrow.
Click on a color.
Copy the formatting from a cell, cell range to
another cell, cell range.
Select the cell or cell range to copy from.
On the Home tab, in the Clipboard group,
click the Format Painter button.
Select the cell or cell range to apply the format.
Alignment, Border Effects
Apply text wrapping to contents within a cell,
cell range.
Select the cell or cell range.
On the Home tab, in the Alignment group,
click the Wrap Text button.
Align cell contents: horizontally, vertically.
Select the cell or cell range.
On the Home tab, in the Alignment group,
click an Align button.
Adjust cell content orientation.
Select the cell range.
On the Home tab, in the Alignment group,
click the Orientation arrow to select a cell
content orientation.

5.3.3

5.3.4

Merge cells and center a title in a merged cell.
Select the cell range.
On the Home tab, in the Alignment group, click the
Merge & Center arrow to select a merge option.
Add border effects to a cell, cell range: lines, colors.
Select the cell range.
On the Home tab, in the Font group, click the
Border arrow to select border options.

6

Charts

6.1

Create
Create different types of charts from spreadsheet
data: column chart, bar chart, line chart, pie chart.
Select the cell range of data on the spreadsheet.
On the Insert tab in the Charts group, click the chart
preferred.
Make chart type selection and finish steps in the Chart
Wizard.
Select a chart.
Click on the chart.
Change the chart type.
Select the chart.
On the Design tab, in the Type group, click the Change
Chart Type button.
Select a chart type from the available list.
Click OK.
Move a chart.
Select the chart.
To move the chart within the worksheet, drag it to the
new location.
To move the chart to another worksheet, on the Design
tab, in the Location group, click the Move Chart button.
Select the new location.
Click OK.
Resize a chart.
Click on the chart.
Drag the chart's sizing handles to the required size.
Delete a chart.
Click on the chart.
Press the Delete key.

6.1.1

6.1.2

6.1.3

6.1.4

6.1.4

6.1.4

6.2
6.2.1

6.2.1

6.2.1

6.2.2

6.2.3

6.2.4

6.2.5

Edit
Add a chart title.
Select the chart.
On the Layout tab, in the Labels group, click the Chart
Title arrow and click on a location for the chart title.
Enter a title in the text box that opens on the chart.
Remove a chart title.
Select the chart.
On the Layout tab, in the Labels group, click the
Chart Title arrow and select None.
Edit a chart title.
Click in the chart title and edit the chart title as
required.
Add data labels to a chart: values/numbers,
percentages.
Select the chart.
On the Layout tab, in the Labels group, click the
Data Labels arrow and select a location for the
data labels.
Change chart area background color, legend fill color.
Select the chart background or the legend as
desired.
On the Format tab, in the Shape Styles group,
click the Shape Fill arrow to select a color.
Change the column, bar, line, pie slice colors in
the chart.
Click into the column, bar, line or pie slice of the
chart to change.
On the Format tab, in the Shape Styles group,
click the Shape Fill arrow to select a color.
Change font size and color of chart title, chart
axes, chart legend text.
Select the chart title, chart axes or chart legend
text to change.
On the Home tab, in the Font group, click the
Font Size or Font Color buttons.

7
7.1
7.1.1

Prepare Outputs

7.2.1

Setup
Change worksheet margins: top, bottom, left, right.

7.2.2

7.2.2

7.2.3

7.1.2

7.1.2

7.1.3

7.1.4

7.1.4

7.1.5

7.1.5

7.2
7.2.1

On the Page Layout tab, in the Page Setup group,
click the Margins button.
Click on Custom Margins.
On the Margins tab, enter a top, bottom, left,
right margin.
Click OK.
Change worksheet orientation: portrait,
landscape.

On the Page Layout tab, in the Page Setup group,
click the Orientation button.
Click Portrait or Landscape.
Change paper size.
On the Page Layout tab, in the Page Setup group,
click the Size button.
Select a paper size.
Adjust page setup to fit worksheet contents on
a specified number of pages.
On the Page Layout tab, in the Scale to Fit group,
select the number of pages to fit the selection.
Add text in headers, footers in a worksheet.
On the Insert tab, in the Text group, click the
Header & Footer button.
By default, the header section opens; to go to the
footer, click the Go to Footer button.
Enter the text required in the headers and footers.
Edit, delete text in headers, footers in a
worksheet.
On the Page Layout tab, in the Page Setup group,
click the Page Setup group arrow.
Click on the Header/Footer tab.
Edit or delete the text.
Insert fields into headers, footers: page numbering
information, date, time, file name, worksheet
name.
On the Insert tab, in the Text group, click the
Header & Footer button.
Use the available tool buttons to add field(s).
Delete fields in headers, footers: page numbering
information, date, time, file name, worksheet
name.
On the Page Layout tab, in the Page Setup group,
click the Page Setup group arrow.
Click on the Header/Footer tab.
Delete fields.
Check and Print
Check and correct spreadsheet calculations.
On the Formulas tab, in the Formulas Auditing
group, click the Error Checking button.
When an incorrect formula is found, click Update
Formula or Ignore Error.

7.2.4

7.2.5

7.2.5

7.2.5

7.2.5

Check and correct spreadsheet text.
On the Review tab, in the Proofing group, click
the Spelling button.
When an incorrect spelling is found, select the
correct spelling from the list and click Change.
When a repeated word is found, click Delete.
Turn on, off display of gridlines for printing
purposes.
On the Page Layout tab, in the Sheet Options
group, click Print in the Gridlines group.
Turn on, off display of row and column
headings for printing purposes.
On the Page Layout tab, in the Sheet Options
group, click Print in the Headings group.
Apply automatic title row(s) printing on every
page of a printed worksheet.

On the Page Layout tab, in the Page Setup
group, click the Print Titles button.
Click into the Rows to repeat at top box and
enter the row references.
Click OK.
Preview a worksheet.
Click the Office button.
Select Print.
Click Print Preview.
Print a selected cell range from a worksheet.

Select the cell range.
Click the Office button.
Click Print.
Under Print what, click Selection.
Click OK.
Print an entire worksheet, the entire
spreadsheet.
Click the Office button.
Click Print.
To print an entire worksheet, under Print what,
click Active sheet(s).
To print the entire spreadsheet, under Print what,
click Entire workbook.
Click OK.
Print a number of copies of a worksheet.
Click the Office button.
Click Print.
Under Copies, enter the number of pages to print.
Click OK.
Print a selected chart.
Select the chart.
Click the Office button.
Click Print.
Click OK.
For more information, visit:
www.ecdl.org
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Screen shots used with permission from Microsoft.

Using Databases

This module allows candidates to understand the
concept of a database and demonstrate competence
in using a database.

Module Summary

SYLLABUS OUTLINE

CATEGORY

On completion of this module the candidate will be able to:
Understand what a database is and how it is organised and
operated.
Create a simple database and view the database content in
various modes.
Create a table; define and modify fields and their properties;
enter and edit data in a table.
Sort and filter a table or form; create, modify and run queries to
retrieve specific information from a database.
Understand what a form is; create a form to enter, modify, and
delete records and data in records.
Create routine reports and prepare outputs ready for distribution.

Understanding
Databases

Using the
Application

Tables

Retrieving
Information

SKILL SET
Key Concepts
Database Organisation
Relationships
Operation

Working with Databases
Common Tasks

Records
Design

Main Operations
Queries

WHAT ARE THE BENEFITS OF THIS MODULE?

Covers the key skills needed to organise and operate a database.
Can be applied to a range of database software from vendor
packages to ‘freeware’.
Certifies best practice in effective database software use.
Developed with input from computer users, subject matter
experts, and practising computer professionals from all over the
world. This process ensures the relevance and range of module
content.

HOW DO I GET STARTED?
To find out more about this module and to locate your nearest
accredited test centre, please visit www.ecdl.org/programmes.

Objects

Forms

Outputs

Reports, Data Export
Printing

Using Databases
The following is the Syllabus for Using Databases, which is the basis for the theory and
practice-based test in this module.

Module Goals
Module

Using Databases requires the candidate to understand the concept of a database
and demonstrate competence in using a database.
The candidate shall be able to:
•

Understand what a database is and how it is organized and operated.

•

Create a simple database and view the database content in various modes.

•

Create a table, define and modify fields and their properties; enter and edit
data in a table.

•

Sort and filter a table or form; create, modify and run queries to retrieve
specific information from a database.

•

Understand what a form is and create a form to enter, modify and delete
records and data in records.

•

Create routine reports and prepare outputs ready for distribution.

CATEGORY
5.1 Understanding
Databases

SKILL SET
5.1.1 Key Concepts

5.1.2 Database Organization

REF.

TASK ITEM

5.1.1.1

Understand what a database is.

5.1.1.2

Understand the difference between
data and information.

5.1.1.3

Understand how a database is
organized in terms of tables, records
and fields.

5.1.1.4

Know some of the common uses of
large-scale databases like: airline
booking systems, government records,
bank account records, hospital patient
details.

5.1.2.1

Understand that each table in a
database should contain data related
to a single subject type.

5.1.2.2

Understand that each field in a table
should contain only one element of
data.

5.1.2.3

Understand that field content is
associated with an appropriate data
type like: text, number, date/time,
yes/no.

CATEGORY

SKILL SET

5.1.3 Relationships

5.1.4 Operation

5.2 Using the
Application

5.2.1 Working with
Databases

5.2.2 Common Tasks

REF.

TASK ITEM

5.1.2.4

Understand that fields have
associated field properties like: field
size, format, default value.

5.1.2.5

Understand what a primary key is.

5.1.2.6

Understand what an index is.
Understand how it allows for faster
data access.

5.1.3.1

Understand that the main purpose of
relating tables in a database is to
minimize duplication of data.

5.1.3.2

Understand that a relationship is built
by matching a unique field in one table
with a field in another table.

5.1.3.3

Understand the importance of
maintaining the integrity of
relationships between tables.

5.1.4.1

Know that professional databases are
designed and created by database
specialists.

5.1.4.2

Know that data entry, data
maintenance and information retrieval
are carried out by users.

5.1.4.3

Know that a database administrator
provides access to specific data for
appropriate users.

5.1.4.4

Know that the database administrator
is responsible for recovery of a
database after a crash or major errors.

5.2.1.1

Open, close a database application.

5.2.1.2

Open, close a database.

5.2.1.3

Create a new database and save to a
location on a drive.

5.2.1.4

Display, hide built-in toolbars. Restore,
minimize the ribbon.

5.2.1.5

Use available Help functions.

5.2.2.1

Open, save and close a table, query,
form, report.

5.2.2.2

Switch between view modes in a table,
query, form, report.

CATEGORY

5.3 Tables

SKILL SET

5.3.1 Records

5.3.2 Design

5.4 Retrieving
Information

5.4.1 Main Operations

5.4.2 Queries

REF.

TASK ITEM

5.2.2.3

Delete a table, query, form, report.

5.2.2.4

Navigate between records in a table,
query, form.

5.2.2.5

Sort records in a table, form, query
output in ascending, descending
numeric, alphabetic order.

5.3.1.1

Add, delete records in a table.

5.3.1.2

Add, modify, delete data in a record.

5.3.2.1

Create and name a table and specify
fields with their data types like: text,
number, date/time, yes/no.

5.3.2.2

Apply field property settings: field size,
number format, date/time format,
default value.

5.3.2.3

Create a validation rule for number,
date/time, currency.

5.3.2.4

Understand consequences of
changing data types, field properties in
a table.

5.3.2.5

Set a field as a primary key.

5.3.2.6

Index a field (with, without duplicates
allowed).

5.3.2.7

Add a field to an existing table.

5.3.2.8

Change width of columns in a table.

5.4.1.1

Use the search command for a
specific word, number, date in a field.

5.4.1.2

Apply a filter to a table, form.

5.4.1.3

Remove the application of a filter from
a table, form.

5.4.2.1

Understand that a query is used to
extract and analyse data.

5.4.2.2

Create a named single table query
using specific search criteria.

5.4.2.3

Create a named two-table query using
specific search criteria.

CATEGORY

5.5 Objects

5.6 Outputs

SKILL SET

5.5.1 Forms

5.6.1 Reports, Data Export

REF.

TASK ITEM

5.4.2.4

Add criteria to a query using one or
more of the following operators: =
(Equal), <> (Not equal to), < (Less
than), <= (Less than or equal to), >
(Greater than), >= (Greater than or
equal to).

5.4.2.5

Add criteria to a query using one or
more of the following logical operators:
AND, OR, NOT.

5.4.2.6

Use a wildcard in a query, * or %, ? or
__.

5.4.2.7

Edit a query: add, modify, remove
criteria.

5.4.2.8

Edit a query: add, remove, move, hide,
unhide fields.

5.4.2.9

Run a query.

5.5.1.1

Understand that a form is used to
display and maintain records.

5.5.1.2

Create and name a form.

5.5.1.3

Use a form to insert new records.

5.5.1.4

Use a form to delete records.

5.5.1.5

Use a form to add, modify, delete data
in a record.

5.5.1.6

Add, modify text in headers, footers in
a form.

5.6.1.1

Understand that a report is used to
print selected information from a table
or query.

5.6.1.2

Create and name a report based on a
table, query.

5.6.1.3

Change arrangement of data fields
and headings within a report layout.

5.6.1.4

Present specific fields in a grouped
report by sum, minimum, maximum,
average, count, at appropriate break
points.

5.6.1.5

Add, modify text in headers, footers in
a report.

CATEGORY

SKILL SET

5.6.2 Printing

REF.

TASK ITEM

5.6.1.6

Export a table, query output in
spreadsheet, text (.txt, .csv), XML
format to a location on a drive.

5.6.2.1

Change the orientation (portrait,
landscape) of a table, form, query
output, report. Change paper size.

5.6.2.2

Print a page, selected record(s),
complete table.

5.6.2.3

Print all records using form layout,
specific pages using form layout.

5.6.2.4

Print the result of a query.

5.6.2.5

Print specific page(s) in a report, print
complete report.

Using Databases

Quick Reference

This quick reference is for Microsoft Access 2007 on Windows XP

Access 2007 Tabs

Certification Test Goals

Home

This module sets out essential concepts and skills relating to understanding the
concept of a database and demonstrating competence in using a database.
Successful candidates will be able to:
Understand what a database is and how it is organized and operated.
Create a simple database and view the database content in various modes.
Create a table, define and modify fields and their properties; enter and edit
data in a table.
Sort and filter a table or form; create, modify and run queries to retrieve
specific information from a database.
Understand what a form is and create a form to enter, modify and delete
records and data in records.
Create routine reports and prepare outputs ready for distribution.

Create

External Data

Database Tools

Keyboard Shortcuts

Datasheet

General

Navigation

Open a database CTRL+O

Next field TAB

Save a database CTRL+S

Previous field SHIFT+TAB

Print a databaseCTRL+P

Previous screen PAGE UP

Delete DELETE

Next screen PAGE DOWN

Undo CTRL+Z

First record CTRL+HOME

Redo or Repeat CTRL+Y

Last record CTRL+END

Help F1

Navigation Pane

Switch between apps ALT+TAB

Editing

Design View

Cut CTRL+X

Properties ALT+TAB

Copy CTRL+C

Open object in

Paste CTRL+V

design view CTRL+ENTER
Save object CTRL+S

6.1.1
1

Working with Spreadsheets
Understanding
Databases

1.1

Key Concepts
Understand what a database is.
A collection of related data organised for fast search
and retrieval
Understand the difference between data and
information.
Information is the processed output of data.
Understand how a database is organised in
terms of tables, records and fields.
Tables - Data arranged in rows and columns
Records - A complete set of information in a table
Fields - A space allocated for an item of information,
containing the same type of information for each item
Know some of the common uses of large-scale
databases like:
Airline booking systems
Government records
Bank account records
Hospital patient details
Database Organisation
Understand that each table in a database should
contain data related to a single subject type.
If tables contain data related to a single subject type,
it is easier to search for and locate data.

1.1.1

1.1.2

1.1.3

1.1.4

1.2
1.2.1

1.2.2

1.2.3

Understand that each field in a table should contain
only one element of data.
For example, first name in one field, surname in
second field.
Understand that field content is associated with an
appropriate data type like: text, number, date/time,
yes/no.
Data Type - The characteristic of a field that
determines what type of data it can hold
The following are examples of different data types:

1.2.4

1.2.5

1.2.6

1.3

Text

Text, numbers, or both up to 255 characters

Memo

Text, numbers, or both up to 63,999 characters

Number

Numbers used in calculations

Date/Time

Date, times, or both up to 8 bytes

Currency

Currency values, prevents rounding

AutoNumber

Unique sequential numbers automatically added to field

Yes/No

True/False, On/Off

OLE Object

Documents created in other Office programs up to 1GB

Hyperlink

Hyperlink to a UNC path or URL up to 2048 characters

1.3.1

1.3.2

1.3.3

Create a field that allows the choice of a value from

Lookup Wizard another table or list

Understand that fields have associated field
properties like: field size, format, default value.
Field Properties - A set of characteristics that
control how the field is stored, entered, or displayed
Understand what a primary key is.
It uniquely identifies each record in a table
It allows faster data access
Understand what an index is. Understand how it
allows for faster data access.
It helps find and sort records faster
Relationships
Understand that the main purpose of relating
tables in a database is to minimize duplication of
data.
Minimizing duplication of data helps to ensure the
integrity of the data.
Understand that a relationship is built by
matching a unique field in one table with a field
in another table.
It is not possible to match duplicate field names;
each field has its own unique identifier.
Understand the importance of maintaining the
integrity of relationships between tables.
Integrity ensures that relationships are valid.
Integrity avoids records being accidentally
deleted or altered.

© 2012, ECDL Foundation. This Quick Reference may be used by candidates to assist in preparation for this ECDL module test. ECDL Foundation does not warrant that use of this guide will ensure passing of the test.
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1.4
1.4.1

1.4.2

1.4.3

1.4.4

Operation
Know that professional databases are designed
and created by database specialists.
These are designed using specialised software to
meet the organisation’s needs for present and future
use.
Know that data entry, data maintenance and
information retrieval are carried out by users.
Users will be granted access rights as needed for
basic data entry and search.
Know that a database administrator provides
access to specific data for appropriate users.
The database administrator implements security
measures to safeguard the organisation’s database.
Know that the database administrator is responsible
for recovery of a database after a crash or major
errors.
The database administrator has overall responsibility
for the maintenance and repair of an organisation's
database.

2

Using the Application

2.1

Working with Databases
Open a database application.
Click the Start button.
Select All Programs.
Click Microsoft Access 2007.
Close a database application.
Click the Office button.
Click Exit Access.
Open a database.

2.1.1

2.1.1

2.1.2

2.2
2.2.1

2.2.1

2.2.1

2.2.2

2.2.3

2.2.4

2.2.5

Common Tasks
Open a table, query, form, report.
Select the table, query, form or report in the
Navigation Pane.
Double-click on the object to open.
Save a table, query, form, report.
Ensure the table, query, form or report is open.
On the Home tab, in the Records group, click the
Save button.
Close a table, query, form, report.
Click the close ‘x’ icon on the top-right of the object
window.
Switch between view modes in a table, query,
form, report.
On the Home tab, in the Views group, click the
View arrow and click view preferred.
Delete a table, query, form, report.
Select the table, query, form, or report in the
Navigation Pane.
On the Home tab, in the Records group, click the
Delete button.
Click Yes to confirm deletion.
Navigate between records in a table, query, form.

3.2.1

3.2.2

Use the Navigation Bar in the lower left corner of
the window to go forward or backwards through the
records.
Sort records in a table, form, query output in
ascending, descending numeric, alphabetic order.
Click into the field to sort.
On the Home tab, in the Sort & Filter group, click the
Ascending or Descending buttons.

3

Tables

3.1

Records
Add records in a table.
Open the table in Datasheet View.
On the Home tab, in the Records group, click
the New button.
Enter data in fields as required.
Delete records in a table.
Select the record to delete.
On the Home tab, in the Records group, click the
Delete button.
Click Yes to confirm deletion.
Add, modify data in a record.
In table Datasheet View, click into the record.
Click into each field to add or modify the data.
Delete data in a record.
In table Datasheet View, click into the record.
Click into each field and press the Delete key.

3.2.3

3.1.1

2.1.2

2.1.3

Click the Office button.
Click Open.
Select database to open and click Open.
Close a database.
Click the Office button.
Click Close Database.
Create a new database and save to a location on a
drive.

3.1.1

3.1.2

3.1.2

3.2
3.2.1

3.2.4

3.2.5

3.2.6

Design
Create and name a table.
3.2.7

3.2.8

2.1.4

2.1.5

Click the Office button.
Click New.
A blank database is selected; create a file name and
select the location.
Click Create.
Restore, minimize the ribbon.
Double-click any tab to minimise the ribbon.
Double-click any tab again to restore the ribbon.
Use available Help functions
Click on the Help button
on the top right of the
ribbon.

Specify fields with their data types like: text,
number, date/time, yes/no.

In table Design View, click into the Data Type
column for the field.
Click on the drop-down arrow and select a Data
Type.
Apply field property settings: field size, number
format, date/time format, default value.

In table Design View, click into a field row.
In the General tab at the bottom of the window,
click into the Format field.
Click on the drop-down arrow and select a Format.
Create a validation rule for number, date/time,
currency.
In table Design View, click into a field row.
In the General tab at the bottom of the window,
click into the Validation Rule field.
Enter the validation rule.
Understand consequences of changing data types,
field properties in a table.
Data already entered into the table may be lost when
changing a field size attribute.
Set a field as a primary key.
In table Design View, click into the field to select as
the primary key.
In the Design tab, in the Tools group, click the
Primary Key button.
Index a field (with, without duplicates allowed).
In table Design View, click into the field row.
In the General tab at the bottom of the window,
click into the Indexed field.
Click on the drop-down arrow and select Yes (No
Duplicates).
Add a field to an existing table.
In table Design View, click into an empty field row.
Enter a new field name.
Select a Data Type from the drop-down list.
Change width of columns in a table.

On the Create tab, in the Tables group, click the
Table button.
On the Datasheet tab, in the Views group, click the
View arrow and click the Design View button.
When prompted, enter a name for the table and
click OK.
Select the column heading.
On the Home tab, in the Records group, click the
More arrow and select Column Width.
Enter a column width.
Click OK.

4

Retrieving Information

4.1

Main Operations
Use the search command for a specific word,
number, date in a field.

4.1.1

4.2.3

4.1.2

On the Home tab, in the Find group, click the
Find button.
Enter the word, number or date to find in the
Find What box.
Click Find Next to select the next occurrence of the
word or phrase until the value is found.
Apply a filter to a table, form.
4.2.4

On the Create tab, in the Other group, click the
Query Design button.
Select the table to add from the Show Table
window.
Click Add and then click Close.
Click and drag the fields required into the window
below.
Click into the field’s Criteria text box.
Enter the criteria.
Create a named two-table table query using
specific search criteria.
In the Create tab, in the Other group, click the Query
Design button.
Select the two tables to add from the Show Table
window.
Click Add and click Close.
Click and drag the fields required into the window
below.
Click into the field’s Criteria text box.
Enter the criteria.
Add criteria to a query using one or more of the
following operators: = (Equal), <> (Not equal to),
< (Less than),<= (Less than or equal to),
> (Greater than), >= (Greater than or equal to).

4.2.8

4.2.8

4.2.9

On the Design tab, in the Results group, click
the Run button.

5
5.1
5.1.1

5.1.2

5.1.3

4.2.5

4.1.3

4.2
4.2.1

4.2.2

Open the table or form.
On the Home tab, in the Sort & Filter group,
click the Filter button.
Click the boxes to deselect the rows to filter.
Click OK.
Remove the application of a filter from a table, form.
On the Home tab, in the Sort & Filter group, click the
Advanced button.
Click Clear All Filters.
Queries
Understand that a query is used to extract and
analyze data.
It allows users to locate data according to specific
search criteria.
Create a named single table query using specific
search criteria.

4.2.6

4.2.7

4.2.8

4.2.8

In query Design View, click into the field's Criteria
text box.
Enter the criteria using an arithmetic operator.
Add criteria to a query using one or more of the
following logical operators: AND, OR, NOT.
In query Design View, click into the field's Criteria
text box.
Enter the criteria using a logical operator.
Use a wildcard in a query, * or %,? or _.
In query Design View, click into the field's Criteria
text box.
Enter the criteria using a wildcard.
Edit a query: add, modify, remove criteria.
In query Design View, click into the field’s Criteria
text box.
Add, modify, or remove criteria as required.
Edit a query: add fields.
In query Design View, click into a blank field's
column heading.
Click on the arrow and select the field required.
Edit a query: remove fields.

5.1.4

5.1.5

5.1.6

5.1.6

In query Design View, select the column heading
of the field to delete.
Press the Delete key.

Edit a query: move fields.
In query Design View, select the column heading
of the field to move.
Drag and drop the field's column heading to the
required location.
Edit a query: hide, unhide fields.
To hide a field, in query Design View, click Show
criteria to remove checkmark.
To unhide a field, in query Design View, click Show
criteria to show checkmark.
Run a query.

Objects
Forms
Understand that a form is used to display and
maintain records.
It allows users to navigate through records and add,
delete, or modify records as needed.
Create and name a form.
Select a table or query.
On the Create tab, in the Forms group, click the
Form button.
Close the form and when prompted, confirm the
name of the form and click OK.
Use a form to insert new records.
On the Home tab, in the Records group, click the
New button.
Enter new records as required.
Use a form to delete records.
Select the record to delete.
On the Home tab, in the Records group, click the
Delete arrow.
Click Delete Record.
Use a form to add, modify, delete data in a record.
Use the Navigation Bar in the lower left corner of the
form window to navigate to the required record.
Click into the field to alter and add, modify or delete
data as required.
Add text in headers, footers in a form.

On the Design tab, in the Controls group, click the
Text Box button.
Go to the header or footer and click and drag to
create a text box.
Add text.
Modify text in headers, footers in a form.
Open the form in Design View.
Click in the text box in the header or footer.
Modify text as required.

6

Outputs

6.2
6.2.1

6.1
6.1.1

6.1.2

6.1.3

6.1.4

Reports, Data Export
Understand that a report is used to print selected
information from a table or query.
It allows users to create a printed copy of all or
selected data for greater ease of reference and
understanding.
Create and name a report based on a table, query.
Select a table or query.
In the Create tab, in the Reports group, click the
Report button.
Close the report and, when prompted, confirm name
of report and click OK.
Change arrangement of data fields and headings
within a report layout.
Open a report in Design View.
Click on a data field or heading and drag to required
location.
Present specific fields in a grouped report by sum,
minimum, maximum, average, count, at appropriate
break points.

6.2.1

6.2.2

6.1.5

6.1.5

6.1.6

Add a text box to the page footer or report footer
section of the report.
On the Design menu, in the Tools group, click the
Property Sheet button.
Click the Data tab and click into the Control Source
box.
Create a formula beginning with = that will calculate
the field.
Add text in headers, footers in a report.
On the Design tab, in the Controls group, click the
Text Box button.
Click and drag to place in the header or footer of the
report.
Add text.
Modify text in headers, footers in a report.
Open the report in Design View.
Click in the text box in the header or footer.
Modify text as required.
Export a table, query output in spreadsheet, text
(.txt, .csv), XML format to a location on a drive.

6.2.2

6.2.2

6.2.3

6.2.4

6.2.5

On the External Data tab, in the Export group, click
the relevant Application button. Select a location.
Click Export data with formatting and layout.
Click OK.

Printing
Change the orientation (portrait, landscape) of a
table, form, query output, report.

For more information, visit:
www.ecdl.org

Open the table, form, query output or report.
Click the Microsoft Office Button, and then click Print
Preview.
On the Print Preview tab, in the Page Layout group,
click the Portrait or Landscape buttons.
Change paper size.
Open the table, form, query output or report.
Click the Microsoft Office Button, and then click Print
Preview.
On the Page Setup tab, in the Page Layout group,
click the Size button. Click on a size from the list
shown.
Print a page.

Open the object to print.
Click the Office button.
Click Print.
Under Print Range, click Pages and enter the
number reference in the From and To boxes.
Click OK.
Print selected record(s).
Open the record(s) to print.
Under Print Range, click Selected Record(s).
Click OK.
Print a complete table.
Open the table to print.
Under Print Range, click All.
Click OK.
Print all records using form layout, specific pages
using form layout.
Open the form to print.
Click the Office button.
Click Print.
To print all records, under Print Range, click All.
To print specific pages, under Print Range, click
Pages and enter the number reference in the From
and To boxes.
Click OK.
Print the result of a query.
Open the query to print.
Click on the Office button.
Click Print.
Click OK.
Print specific page(s) in a report, print complete
report.
Open the report to print.
Click on the Office button.
Click Print.
To print all pages, under Print Range, click All.
To print specific pages, under Print Range, click
Pages and enter the number reference in the From
and To boxes.
Click OK.

© 2012, ECDL Foundation. This Quick Reference may be used by candidates to assist in preparation for this ECDL module test. ECDL Foundation does not warrant that use of this guide will ensure passing of the test.
Screen shots used with permission from Microsoft.

Presentation

This module allows candidates to understand the
concept of presentations and to demonstrate
competence in using presentation software.
On completion of this module the candidate will be able to:
Work with presentations and save them in different file formats.
Choose built-in options, such as the Help function, within the
application to enhance productivity.
Understand different presentation views and when to use them;
choose different slide layouts and designs.
Enter, edit, and format text in presentations.
Recognise good practice in applying unique titles to slides.
Choose, create, and format charts to communicate information
meaningfully.
Insert and edit pictures, images, and drawn objects.
Apply animation and transition effects to presentations.
Check and correct presentation content before finally printing
and giving presentations.

Module Summary

SYLLABUS OUTLINE

CATEGORY
Using the
Application

Developing a
Presentation

Text

Charts

SKILL SET
Working with Presentations
Enhancing Productivity

Presentation Views
Slides
Master Slide
Handling Text
Formatting
Lists
Tables

Using Charts
Organisation Charts

Graphical Objects

Insert, Manipulate
Drawing

Prepare Outputs

Preparation
Check and Deliver

WHAT ARE THE BENEFITS OF THIS MODULE?

Covers the key skills needed to use presentation software.
Can be applied to a range of presentation software from vendor
packages to ‘freeware’.
Certifies best practice in effective presentation software use.
Developed with input from computer users, subject matter
experts, and practising computer professionals from all over the
world. This process ensures the relevance and range of module
content.

HOW DO I GET STARTED?
To find out more about this module and to locate your nearest
accredited test centre, please visit www.ecdl.org/programmes.

Presentation
The following is the Syllabus for Presentation, which is the basis for the practice-based
test in this module.

Module Goals
Module

Presentation requires the candidate to demonstrate competence in using
presentation software.
The candidate shall be able to:
•

Work with presentations and save them in different file formats.

•

Choose built-in options such as the Help function within the application to
enhance productivity.

•

Understand different presentation views and when to use them, choose
different slide layouts and designs.

•

Enter, edit and format text in presentations. Recognize good practise in
applying unique titles to slides.

•

Choose, create and format charts to communicate information meaningfully.

•

Insert and edit pictures, images and drawn objects.

•

Apply animation and transition effects to presentations and check and
correct presentation content before finally printing and giving presentations.

CATEGORY
6.1 Using the
Application

SKILL SET
6.1.1 Working with
Presentations

6.1.2 Enhancing Productivity

REF.

TASK ITEM

6.1.1.1

Open, close a presentation
application. Open, close
presentations.

6.1.1.2

Create a new presentation based on
default template.

6.1.1.3

Save a presentation to a location on a
drive. Save a presentation under
another name.

6.1.1.4

Save a presentation as another file
type: Rich Text Format, template,
show, image file format, version
number.

6.1.1.5

Switch between open presentations.

6.1.2.1

Set user preferences in the
application: user name, default folder
to open and save files.

6.1.2.2

Use available Help functions.

CATEGORY

6.2 Developing a
Presentation

SKILL SET

6.2.1 Presentation Views

6.2.2 Slides

6.2.3 Master Slide

6.3 Text

6.3.1 Handling Text

REF.

TASK ITEM

6.1.2.3

Use magnification/zoom tools.

6.1.2.4

Display, hide built-in toolbars.
Restore, minimize the ribbon.

6.2.1.1

Understand the uses of different
presentation view modes: normal
view, slide sorter view, outline view,
slide show view.

6.2.1.2

Recognize good practice in adding
slide titles: use a different title for each
slide to distinguish it in outline view,
when navigating in slide show view.

6.2.1.3

Change between presentation view
modes: normal view, slide sorter view,
slide show view.

6.2.2.1

Choose a different built-in slide layout
for a slide.

6.2.2.2

Apply an available design template to
a presentation.

6.2.2.3

Change background colour on specific
slide(s), all slides.

6.2.2.4

Add a new slide with a specific slide
layout like: title slide, chart and text,
bulleted list, table/spreadsheet.

6.2.2.5

Copy, move slides within the
presentation, between open
presentations.

6.2.2.6

Delete slide(s).

6.2.3.1

Insert a graphical object (picture,
image, drawn object) into a master
slide. Remove a graphical object from
a master slide.

6.2.3.2

Enter text into footer of specific slides,
all slides in a presentation.

6.2.3.3

Apply automatic slide numbering,
automatically updated date, nonupdating date into footer of specific
slides, all slides in a presentation.

6.3.1.1

Recognize good practice in creating
slide content: use short concise
phrases, bullet points, numbered lists.

6.3.1.2

Enter text into a placeholder in
standard, outline view.

CATEGORY

SKILL SET

6.3.2 Formatting

6.3.3 Lists

6.3.4 Tables

6.4 Charts

6.4.1 Using Charts

REF.

TASK ITEM

6.3.1.3

Edit text in a presentation.

6.3.1.4

Copy, move text within, between
presentations.

6.3.1.5

Delete text.

6.3.1.6

Use the undo, redo command.

6.3.2.1

Change text formatting: font sizes,
font types.

6.3.2.2

Apply text formatting: bold, italic,
underline, shadow.

6.3.2.3

Apply different colours to text.

6.3.2.4

Apply case changes to text.

6.3.2.5

Align text: left, centre, right in a text
frame.

6.3.3.1

Indent bulleted text. Remove indent
from bulleted text.

6.3.3.2

Adjust line spacing before and after
bulleted, numbered lists.

6.3.3.3

Switch between the different standard
bullet, number styles in a list.

6.3.4.1

Enter, edit text in a table slide.

6.3.4.2

Select rows, columns, entire table.

6.3.4.3

Insert, delete rows and columns.

6.3.4.4

Modify column width, row height.

6.4.1.1

Input data to create built-in charts in a
presentation: column, bar, line, pie.

6.4.1.2

Select a chart.

6.4.1.3

Change the chart type.

6.4.1.4

Add, remove, edit a chart title.

6.4.1.5

Add data labels to a chart:
values/numbers, percentages.

6.4.1.6

Change the background colour of a
chart.

6.4.1.7

Change the column, bar, line, pie slice
colours in a chart.

CATEGORY

SKILL SET
6.4.2 Organization Charts

6.5 Graphical Objects

6.5.1 Insert, Manipulate

6.5.2 Drawing

6.6 Prepare Outputs

6.6.1 Preparation

REF.

TASK ITEM

6.4.2.1

Create an organization chart with a
labelled hierarchy by using a built-in
organization chart feature.

6.4.2.2

Change the hierarchical structure of
an organization chart.

6.4.2.3

Add, remove co-workers,
subordinates in an organization chart.

6.5.1.1

Insert a graphical object (picture,
image, drawn object) into a slide.

6.5.1.2

Select a graphical object.

6.5.1.3

Copy, move graphical objects, charts
within the presentation, between open
presentations.

6.5.1.4

Resize, delete graphical objects,
charts in a presentation.

6.5.1.5

Rotate, flip a graphical object.

6.5.1.6

Align a graphical object relative to a
slide: left, centre, right, top, bottom.

6.5.2.1

Add different types of drawn object to
a slide: line, arrow, block arrow,
rectangle, square, oval, circle, text
box.

6.5.2.2

Enter text into a text box, block arrow,
rectangle, square, oval, circle.

6.5.2.3

Change drawn object background
colour, line colour, line weight, line
style.

6.5.2.4

Change arrow start style, arrow finish
style.

6.5.2.5

Apply a shadow to a drawn object.

6.5.2.6

Group, ungroup drawn objects in a
slide.

6.5.2.7

Bring a drawn object one level
forward, one level backward, to the
front, to the back of other drawn
objects.

6.6.1.1

Add, remove transition effects
between slides.

6.6.1.2

Add, remove preset animation effects
for different slide elements.

CATEGORY

SKILL SET

6.6.2 Check and Deliver

REF.

TASK ITEM

6.6.1.3

Add presenter notes to slides.

6.6.1.4

Select appropriate output format for
slide presentation like: overhead,
handout, on-screen show.

6.6.1.5

Hide, show slides.

6.6.2.1

Spell check a presentation and make
changes like: correcting spelling
errors, deleting repeated words.

6.6.2.2

Change slide setup, slide orientation
to portrait, landscape. Change paper
size.

6.6.2.3

Print entire presentation, specific
slides, handouts, notes pages, outline
view of slides, number of copies of a
presentation.

6.6.2.4

Start a slide show from first slide, from
current slide.

6.6.2.5

Navigate to next slide, previous slide,
specified slide during a slide show.

Presentation

Quick Reference

This quick reference is for Microsoft PowerPoint 2007 on Windows XP

PowerPoint 2007 Tabs

Certification Test Goals

Home

This module requires the candidate to demonstrate competence in using
presentation software.
Successful candidates will be able to:
Work with presentations and save them in different file formats.
Choose built-in options such as the Help function within the application to
enhance productivity.
Understand different presentation views and when to use them, choose different
slide layouts and designs.
Enter, edit and format text in presentations. Recognize good practise in applying
unique titles to slides.
Choose, create and format charts to communicate information meaningfully.
Insert and edit pictures, images and drawn objects.
Apply animation and transition effects to presentations and check and correct
presentation content before finally printing and giving presentations.

Insert

Design

Animations

Keyboard Shortcuts

Slide Show

Review

View

General

Editing

Open a presentation CTRL+O

Cut CTRL+X

Save a presentation CTRL+S

Copy CTRL+C

Print a presentation CTRL+P

Paste CTRL+V

Close a presentation CTRL+W

Bold CTRL+B

Undo CTRL+Z

Italics CTRL+I

Redo or Repeat CTRL+Y

Underline CTRL+U

Help F1
Switch between apps ALT+TAB
Format

1

1.1.3

1.1.3

1.1.4

1.1.2

Slide Show Delivery

Previous slide PAGE UP

End slide show ESC

Next slide PAGE DOWN

Toggle screen black B

First Slide CTRL+HOME

Toggle screen white W

Last Slide CTRL+END

Pause show S

Using the Application

Working with Presentations
1.1.1
Open a presentation application.
Click the Start button.
Select All Programs.
Click Microsoft PowerPoint 2007.
1.1.1
Close a presentation application.
Click the Office button.
Click Exit PowerPoint.
1.1.1
Open presentations.

1.1.1

Navigation

Click the Office button.
Click Open.
Select presentation(s) to open and click Open.
Close presentations.
Click the Office button.
Click Close.
Create a new presentation based on default
template.
Click the Office button.
Click New.
A blank presentation is selected, click Create.

1.1.5

1.2
1.2.1

Save a presentation to a location on a drive.
Click the Office button.
Click Save.
Create a file name and select the location.
Click Save.
Save a presentation under another name.
Click the Office button.
Click Save As.
Enter a new file name over the existing file name and
select the location.
Click Save.
Save a presentation as another file type: Rich
Text Format, template, show, image file format,
version number.
Click the Office button.
Click Save As.
Click on the Save as type arrow and select a file type.
Click Save.
Switch between open presentations.
On the View tab, in the Window group, click the
Switch Window button, and then click the name of the
presentation to switch to.
Enhancing Productivity
Set user preferences in the application: user name.
Click the Office button.
Click PowerPoint Options.
On the Popular tab, enter a user name in the
User name text box.
Click OK.

1.2.1

1.2.2

1.2.3

1.2.4

Set user preferences in the application: default
folder to open and save files.
Click the Office button.
Click PowerPoint Options.
On the Save tab, enter a default file location in the
Default file location text box.
Click OK.
Use available Help functions.
Click on the Help button
on the top right of
the ribbon.
Use magnification/zoom tools.

On the View tab, in the Zoom group, click the
Zoom button.
Select the magnification required.
Click OK.
Restore, minimise the ribbon.
Double-click any tab to minimize the ribbon.
Double-click any tab again to restore the ribbon.

© 2012, ECDL Foundation. This Quick Reference may be used by candidates to assist in preparation for this ECDL module test. ECDL Foundation does not warrant that use of this guide will ensure passing of the test.
Screen shots used with permission from Microsoft.

2

Developing a Presentation

2.1

Presentation Views
Understand the uses of different presentation view
modes.
Normal View is the main editing view to write and
design a presentation.
Slide Sorter View shows all slides in thumbnail form
so they are easy to sort.

2.1.1

2.2.4

2.2.5

2.2.5

2.1.2

2.1.3

Outline View displays all the text from the slides in a
list for ease of reference and editing.
Slide Show View uses the full computer screen and is
used when presenting a slide show to an audience.
Recognize good practice in adding slide titles.
Use a different title for each slide to distinguish it in
outline view, when navigating in slide show view.
Change between presentation view modes:
normal view, slide sorter view, slide show view.

2.2.6

2.3
2.3.1

Add a new slide with a specific slide layout like:
title slide, chart and text, bulleted list,
table/spreadsheet.
On the Home tab, in the Slides group, click the
New Slide button.
Then click the Layout arrow.
Click on a slide layout.
Copy slides within the presentation, between open
presentations.
Select slide to copy in the slide pane.
On the Home tab, in the Clipboard group, click the
Copy button.
Click on a new location within the presentation or
within another open presentation.
On the Home tab, in the Clipboard group, click the
Paste button.
Move slides within the presentation, between open
presentations.
Select the slide to move.
On the Home tab, in the Clipboard group, click the
Cut button.
Click on a new location within the presentation or
within another open presentation.
On the Home tab, in the Clipboard group, click the
Paste button.
Delete slide(s).
Select the slide(s) to delete.
On the Home tab, in the Slides group, click the
Delete button.
Master Slide
Insert a graphical object (picture, image, drawn
object) into a master slide.

2.3.3

Apply automatically updated date into footer
of specific slides, all slides in a presentation.
On the Insert tab, in the Text group, click the
Header & Footer button.
Check the Date and Time check box.
Click Update automatically.
Click Apply or Apply All.
Apply non-updating date into footer of specific
slides, all slides in a presentation.
On the Insert tab, in the Text group, click the
Header & Footer button.
Click in the Footer text box and check the
Date and Time check box.
Click Fixed and enter a date.
Click Apply or Apply to All.

3

Text

3.1

Handling Text
Recognise good practice in creating slide content.
Use short concise phrases
Use bullet points
Use numbered lists
Enter text into a placeholder in standard,
outline view.
In standard view, click into the text box on the
slide and enter the text.
In outline view, click next to the slide number
and enter the text.
Edit text in a presentation.
Click into the slide and insert or delete content.
Copy text within, between presentations.
Select the text to copy.
On the Home tab, in the Clipboard group, click
the Copy button.
Click on a new location within the presentation
or within another open presentation.
On the Home tab, in the Clipboard group, click
the Paste button.
Move text within, between presentations.
Select the text to move.
On the Home tab, in the Clipboard group, click
the Cut button.
Click on a new location within the presentation
or within another open presentation.
On the Home tab, in the Clipboard group, click
the Paste button.
Delete text.
Select the text to delete.
Press the Delete key.
Use the undo, redo command.
On the Quick Access Toolbar, click the Undo
or Redo buttons.

2.3.3

3.1.1

3.1.2

3.1.3

3.1.4

On the View tab, in the Presentation Views group,
click a view button.
2.2
2.2.1

Slides
Choose a different built-in slide layout for a slide.
3.1.4

2.3.1

2.3.2

2.2.2

2.2.3

On the Home tab, in the Slides group, click the Layout
arrow.
Click on a slide layout.
Apply an available design template to a presentation.

On the Design tab, in the Themes group, click the
Themes arrow.
Click on a theme.
Change background color on specific slide(s), all
slides.
On the Design tab, in the Background group, click the
Background group arrow.
Click on the Color button.
Click on a color.
To apply to all slides, click Apply to All.
Click Close.

On the View tab, in the Presentation Views group,
click the Slide Master button.
On the Insert tab, in the Illustrations group, click
the Picture, ClipArt, or Shapes button.
Select the picture, image, or shape to insert.
Click Insert to insert a picture or image or click in
the slide to insert a shape.
Remove a graphical object from a master slide.
On the View tab, in the Presentation Views group,
click the Slide Master button.
Click on the picture or image to remove.
Press the Delete key.
Enter text into footer of specific slides, all slides in
a presentation.

3.1.5

3.1.6

3.2
3.2.1

2.3.3

On the Insert tab, in the Text group, click the
Header & Footer button.
Check the Footer check box.
Click in the Footer text box and enter the text.
Click Apply or Apply to All.
Apply automatic slide numbering into footer of
specific slides, all slides in a presentation.
On the Insert tab, in the Text group, click the
Header & Footer button.
Check the Slide Number check box.
Click Apply or Apply to All.

3.2.1

Formatting
Change text formatting: font sizes.

Select the text to format.
On the Home tab, in the Font group, click the
Font Size arrow.
Select a size from the list or enter a size into the
Size box.
Change text formatting: font types.
Select the text to format.
On the Home tab, in the Font group, click the
Font arrow.
Select a font from the list or enter a font name
into the Font box.

3.2.2

3.2.3

3.2.4

Apply text formatting: bold, italic, underline,
shadow.
Select the text to format.
To embolden the text, on the Home tab, in the
Font group, click the Bold button.
To italicize the text, on the Home tab, in the Font
group, click the Italic button.
To underline the text, on the Home tab, in the Font
group, click the Underline button.
To shadow the text, on the Home tab, in the Font
group, click the Text Shadow button.
Apply different colors to text.
Select the text to color.
On the Home tab, in the Font group, click the Font
Color arrow.
Click on a color.
Apply case changes to text.

3.4.3

3.4.3

3.4.4

3.4.4

4

Charts

4.1

Using Charts
Input data to create built-in charts in a
presentation: column, bar, line, pie.
On the Insert tab, in the Illustrations group, click
the Chart button.
Click on a chart and click OK.
Click into the individual cells in the chart window
to enter data.
Select a chart.
Click into the chart.
Change the chart type.
Select the chart.
On the Design tab, in the Type group, click the
Change Chart Type button.
Click on a chart type.
Click OK.
Add a chart title.
Select the chart.
On the Layout tab, in the Labels group, click the
Chart Title arrow.
Click Centered Overlay Title or Above Chart.
Enter the title in the text box that opens on the chart.
Remove a chart title.
Select the chart.
On the Layout tab, in the Labels group, click the
Chart Title arrow.
Click None.
Edit a chart title.
Click in the chart title and edit text as required.
Add data labels to a chart: values/numbers,
percentages.
Select the chart.
On the Layout tab, in the Labels group, click the
Data Labels arrow.
Click Center, Inside End, Inside Base or Outside End.
Change the background color of a chart.
Select the chart background.
On the Format tab, in the Shape Styles group,
click the Shape Fill arrow.
Click on a color.
Change the column, bar, line, pie slice colors in a
chart.
Select the column, bar, line or pie slice of the chart
to change.
On the Format tab, in the Shape Styles group,
click the Shape Fill arrow.
Click on a color.

4.1.1

3.2.5

3.3
3.3.1

3.3.2

3.3.3

Select the text to change case.
On the Home tab, in the Font group, click the
Change Case button.
To capitalize the first letter of a sentence, click
Sentence case.
To make all letters lowercase, click lowercase.
To capitalize all of the letters, click UPPERCASE.
To capitalize the first letter of each word, click
Capitalize Each Word.
To shift between two case views, click tOGGLE cASE.
Align text: left, center, right in a text frame.
Select the text to align.
On the Home tab, in the Paragraph group, click the
Align Text Left, Center or Align Text Right buttons.
Lists
Indent bulleted text. Remove indent from bulleted
text.
Select the text to indent or to remove indentation from.
On the Home tab, in the Paragraph group, click the
Decrease List Level or Increase List Level buttons.
Adjust line spacing before and after bulleted,
numbered lists.
Select the list.
On the Home tab, in the Paragraph group, click the
Line Spacing arrow and select Line Spacing Options.
Set the spacing options.
Click OK.
Switch between the different standard bullet,
number styles in a list.

4.1.2

4.1.3

4.1.4

4.1.4

4.1.4

4.1.5

4.1.6

4.1.7

Select the bulleted or numbered list to change.
On the Home tab, in the Paragraph group, click
the Bullets or Numbering arrow.
Click on a bullet or numbering style.
3.4
3.4.1

3.4.2

Tables
Enter, edit text in a table slide.
Click in a cell and enter or edit text.
Select rows, columns, entire table.
Click into the table.
On the Layout tab, in the Table group, click the Select
arrow and click Select Row, Select Column or Select
Table button.

Insert rows and columns.
Click in a row or column.
On the Layout tab, in the Rows & Columns group,
to insert a row click the Insert Above or Insert Below
button, to insert a column click Insert Left or Insert
Right button.
Delete rows and columns.
Click in the row or column to delete.
On the Layout tab, in the Rows & Columns group,
click the Delete arrow.
Click the Delete Rows or Delete Columns button.
Modify column width.
Select the column to modify.
On the Layout tab, in the Cell Size group, enter the
width in the Table Column Width field.
Modify row height.
Select the row to modify.
On the Layout tab, in the Cell Size group, enter the
height in the Table Row Height field.

4.2
4.2.1

Organisation Charts
Create an organisation chart with a labeled
hierarchy by using a built-in organization chart
feature.
On the Insert tab, in the Illustrations group, click the
SmartArt button.

4.2.2

4.2.3

4.2.3

Click Hierarchy, then click Organization Chart.
Click OK.
Change the hierarchical structure of an
organization chart.
Select a shape.
On the Design tab, in the Create Graphic group,
click the Demote, Promote or Right to Left button.
Add co-workers, subordinates in an organisation
chart.
Select the shape to add the co-worker or
sub-ordinate to.
On the Design tab, in the Create Graphic group,
click the Add Shape button.
A subordinate is selected. To change
to co-worker click the Promote button.
Remove co-workers, subordinates
in an organisation chart.

Select co-worker or sub-ordinate shape.
Press the Delete key.

5

Graphical Objects

5.1

Insert, Manipulate
Insert a graphical object (picture, image, drawn
object) into a slide.

5.1.1

5.1.2

5.1.3

5.1.3

5.1.4

5.1.4

Click in a slide to insert the object.
On the Insert tab, in the Illustrations group, click
Picture, Clip Art, or Shapes button.
Select the object required and click Open to insert
or double-click on the object.
Select a graphical object.
Click on the picture, image, or drawn object.
Copy graphical objects, charts within the
presentation, between open presentations.
Select the object or chart.
On the Home tab, in the Clipboard group, click the
Copy button.
Click on a new location within the presentation or
within another open presentation.
On the Home tab, in the Clipboard group,
click the Paste button.
Move graphical objects, charts within the
presentation, between open presentations.
Select the object or chart.
On the Home tab, in the Clipboard group, click the
Cut button.
Click on a new location within the presentation or
within another open presentation.
On the Home tab, in the Clipboard group, click the
Paste button.
Resize graphical objects, charts in a presentation.
Select the object or chart.
Drag the object’s sizing handles to the required size.
Delete graphical objects, charts in a presentation.
Select the object or chart.
Press the Delete key.

5.1.5

Rotate, flip a graphical object.

5.2.5

5.2.6

5.2.7

5.1.6

5.2
5.2.1

5.2.1

5.2.2

5.2.3

5.2.3

5.2.3

5.2.3

5.2.4

Select the object.
On the Format tab, in the Arrange group, click
the Rotate arrow.
Click on a rotate or flip option.
Align a graphical object relative to a slide: left,
center, right, top, bottom.
Select the object.
On the Format tab, in the Arrange group, click the
Align arrow.
Click on an alignment option.
Drawing
Add different types of drawn object to a slide:
line, arrow, block arrow, rectangle, square, oval,
circle.
Select the location on the slide to insert object.
On the Insert tab, in the Illustrations group, click the
Shapes arrow.
Select the objects.
Click and drag to adjust the size of the object.
Add different types of drawn object to a slide:
text box.
Select the location on the slide to insert object.
On the Insert tab, in the Text group, click the
Text Box button.
Select the objects.
Click and drag to adjust the size of the text box.
Enter text into a text box, block arrow, rectangle,
square, oval, circle.
Click into the shape or text box.
Enter the text.
Change drawn object background color.
Select drawn object.
On the Format tab, in the Shape Styles group, click
the Shape Fill arrow.
Click on a color.
Change drawn object line color.
Select the object.
On the Format tab, in the Shape Styles group, click
the Shape Outline arrow.
Click on a color.
Change drawn object line weight.
Select the object.
On the Format tab, in the Shape Styles group, click
the Shape Outline arrow.
Click Weight and click on a line weighting.
Change drawn object line style.
Select the object.
On the Format tab, in the Shape Styles group, click
the Shape Outline arrow.
Click Dashes and click on More Lines.
Select the line style preferred and then click Close.
Change arrow start style, arrow finish style.
Select the arrow.
On the Home tab, in the Drawing group, click on the
Shape Outline arrow.
Click Arrows and click on More Arrows.
Select and click in a Begin Type and End Type.
Click Close.

Apply a shadow to a drawn object.
Select the object.
On the Format tab, in the Shape Styles group,
click the Shape Effects arrow.
Click Shadow and click on a shadow.
Group, ungroup drawn objects in a slide.
Select the objects.
On the Home tab, in the Drawing group, click the
Arrange arrow.
Click the Group or Ungroup buttons as required.
Bring a drawn object one level forward, one level
backward, to the front, to the back of other drawn
objects.
Select the object.
To bring a drawn object forward, on the Format tab,
in the Arrange group, click on the Bring to Front
arrow and click Bring to Front or Bring Forward.
To bring a drawn object backward, on the Format
tab, in the Arrange group, click on the Sent to Back
arrow and click Send to Back or Send Backward.

6

Prepare Outputs

6.1

Preparation
Add transition effects between slides.

6.1.1

6.1.1

6.1.2

6.1.3

6.1.4

6.1.5

On the Animations tab, in the Transition to this Slide
group, click the arrow at the bottom right of the
transition effects and click on an effect.
In the Advance Slide group, click On Mouse Click or
Automatically After and enter specified time if
required.
Click on a value in the Transition Speed drop-down
list.
Click the Apply to All button.
Remove transition effects between slides.
On the Animations tab, in the Transition to this Slide
group, click the No Transition effect.
Add, remove preset animation effects for different
slide elements.
Select the slide element to animate.
On the Animations tab, in the Animations group,
click the Animate arrow.
To add animation, click on an animation effect.
To remove animation, click No Animation.
Add presenter notes to slides.
Click into the notes pane at the bottom of Normal
view (Click to add notes should currently be visible).
Enter the text required.
Select appropriate output format for slide
presentation like: overhead, handout, on-screen
show.
On the Design tab, in the Page Setup group, click
the Page Setup button.
Click on an option in Slides sized for drop-down list.
Hide, show slides.
Select the slide to hide or show.
On the Slide Show tab, in the Set Up group, click the
Hide Slide button.
Click the Hide Slide button again to unhide the slide.

6.2.3

Check and Deliver
Spell check a presentation and make changes like:
correcting spelling errors, deleting repeated words.
On the Review tab, in the Proofing group, click the
Spelling button.
When an incorrect spelling is found, select the
correct spelling from the list and click Change.
When a repeated word is found, click Delete.
Change slide setup, slide orientation to portrait,
landscape.
On the Design tab, in Page Setup group, click the
Page Orientation button.
Click Portrait or Landscape.
Change paper size.
On the Design tab, in Page Setup group,
click the Page Setup button.
Select a paper size in the Slides sized for
drop-down list.
Print entire presentation, specific slides.
Click the Office button.
Click Print.
To print the entire presentation, under Print Range,
select All.
To print specific slides, under Print Range, select
Slides and enter the specific slides and/or slide
ranges to print.
Click OK.
Print handouts, notes pages, outline view of slides.

6.2.3

Click the Office button.
Click Print.
Click on the Print what drop-down list.
Select Slides, Handouts, Notes Pages, or Outline
view.
Click OK.
Print a number of copies of a presentation.

6.2
6.2.1

6.2.2

6.2.2

6.2.3

6.2.4

6.2.5

Click the Office button.
Click Print.
Under Copies, enter the number of pages to print.
Click OK.
Start a slide show from first slide, from current
slide.
On Slide Show tab, in Start Slide Show group,
click the From Beginning or From Current Slide
buttons.
Navigate to next slide, previous slide, specified
slide during a slide show.
During the slide show, right-click and click Next,
Previous, or Go to Slide, and click on slide number
to navigate as required.

For more information, visit:
www.ecdl.org
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Online Collaboration

This module sets out concepts and skills relating to
the setup and use of online collaborative tools, such
as storage, productivity applications, calendars, social
media, web meetings, learning environments, and
mobile technology.
On completion of this module the candidate will be able to:
Understand the key concepts relating to online collaboration and
cloud computing.
Set up accounts to prepare for online collaboration.
Use online storage and web-based productivity applications to
collaborate.
Use online and mobile calendars to manage and plan activities.
Collaborate and interact using social networks, blogs, and wikis.
Schedule and host online meetings and use online learning
environments.
Understand key mobile technology concepts and use features
such as e-mail, applications, and synchronisation.

Module Summary

SYLLABUS OUTLINE

CATEGORY

Collaboration Concepts

Preparation for
Online Collaboration

Using Online
Collaborative Tools

SKILL SET

Key Concepts
Cloud Computing

Common Setup Features
Setup

Online Storage and Productivity Applications
Online Calendars
Social Media
Online Meetings
Online Learning Environments

WHAT ARE THE BENEFITS OF THIS MODULE?

Covers the key skills needed to understand the main concepts
relating to online collaboration and cloud computing.
Certifies best practice in effective use of online collaboration
tools and mobile technology.
Developed with input from computer users, subject matter
experts, and practising computer professionals from all over the
world. This process ensures the relevance and range of module
content.
HOW DO I GET STARTED?
To find out more about this module and to locate your nearest
accredited test centre, please visit www.ecdl.org/programmes.

Mobile Collaboration

Key Concepts
Using Mobile Devices
Applications
Synchronisation

ECDL / ICDL Online Collaboration
This module sets out concepts and skills relating to the setup and use of online collaborative
tools, such as storage, productivity applications, calendars, social media, web meetings,
learning environments, and mobile technology.

Module Goals
Successful candidates will be able to:








Understand the key concepts relating to online collaboration and cloud computing.
Set up accounts to prepare for online collaboration.
Use online storage and web-based productivity applications to collaborate.
Use online and mobile calendars to manage and plan activities.
Collaborate and interact using social networks, blogs, and wikis.
Schedule and host online meetings and use online learning environments.
Understand key mobile technology concepts and use features such as e-mail,
applications, and synchronisation.
CATEGORY

1 Collaboration
Concepts

© 2012 ECDL Foundation

SKILL SET
1.1 Key Concepts

REF.

TASK ITEM

1.1.1

Recognise that ICT (Information
and Communication Technology)
can support and promote online
collaboration.

1.1.2

Identify the main types of services
supporting online collaboration
like: cloud computing, mobile
technology. Identify the main
types of tools supporting online
collaboration like: common
productivity applications, social
media, online calendars, online
meetings, online learning
environments.

1.1.3

Identify key characteristics of
online collaborative tools like:
multiple users, real time, global
reach, concurrent access.

1.1.4

Outline the benefits of using
online collaborative tools like:
shared files and calendars,
reduced travel expense, ease of
communication, enhanced
teamwork, global access.

Ref: ECDL / ICDL Online Collaboration - Syllabus - V1.0

CATEGORY

SKILL SET

1.2.Cloud Computing

2 Preparation for
Online
Collaboration

2.1 Common Setup
Features

2.2 Setup
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REF.

TASK ITEM

1.1.5

Be aware of the risks associated
with using online collaborative
tools like: unauthorised access to
shared files, insufficient
management of version control,
malware threats, identity/data
theft, service interruptions.

1.1.6

Recognise the importance of
intellectual property rights and the
appropriate use of content when
using online collaborative tools.

1.2.1

Understand ways in which cloud
computing facilitates online and
mobile collaboration like: storage
of shared documents and files,
access to a range of online
applications and tools.

1.2.2

Outline the benefits of cloud
computing for users like: reduced
costs, enhanced mobility,
scalability, automatic updates.

1.2.3

Outline the risks of cloud
computing like: dependence on
provider, data protection and
control, potential loss of privacy.

2.1.1

Understand that additional
applications, plug-ins may need to
be installed to use certain online
collaborative tools.

2.1.2

Identify common equipment used
to support online collaboration
like: webcam, microphone,
speakers.

2.1.3

Recognise that firewall restrictions
may cause access issues for
users of a collaborative tool.

2.2.1

Download software to support
online collaborative tools like:
VOIP, IM, document sharing.

2.2.2

Register and/or set up a user
account for a collaborative tool.
Deactivate, delete/close a user
account.
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CATEGORY
3 Using Online
Collaborative
Tools

SKILL SET
3.1 Online Storage and
Productivity
Applications

3.2 Online Calendars
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REF.

TASK ITEM

3.1.1

Understand the concept of online
storage solutions and identify
common examples.

3.1.2

Identify the limitations of online
storage like: size limit, time limit,
sharing restrictions.

3.1.3

Upload, download, delete online
files, folders.

3.1.4

Understand that common
productivity applications can be
accessed via the web. Identify
common examples of web-based
productivity applications like: word
processing, spreadsheets,
presentations.

3.1.5

Identify features of web-based
productivity applications: allows
files to be updated by multiple
users in real-time, allows files to
be shared.

3.1.6

Create, edit and save files online.

3.1.7

Share, unshare a file, folder to
allow other users to view, edit,
own a file, folder.

3.1.8

View, restore previous versions of
a file.

3.2.1

Share a calendar. Grant
permission to view, edit a shared
calendar.

3.2.2

Show, hide shared calendars.

3.2.3

Use a shared calendar to create
an event, recurring event.

3.2.4

Set a reminder for an event.

3.2.5

Invite, uninvite people, resources
to an event. Accept, decline an
invitation.

3.2.6

Edit, cancel an existing event.
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CATEGORY

SKILL SET
3.3 Social Media

3.4 Online meetings
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REF.

TASK ITEM

3.3.1

Identify social media tools that
support online collaboration like:
social networks, wikis, forums and
groups, blogs, micro blogs,
content communities.

3.3.2

Set up, modify available
permissions/privacy options like:
read access, write access, user
invites.

3.3.3

Find, connect to social media
users, groups. Remove
connections.

3.3.4

Use a social media tool to post a
comment, link.

3.3.5

Use a social media tool to reply
to, forward a comment.

3.3.6

Use a social media tool to upload
content like: images, videos,
documents.

3.3.7

Remove posts from social media.
Be aware that permanently
deleting posts and photos may be
difficult.

3.3.8

Use a wiki to add to or update a
specific topic.

3.4.1

Open, close online meeting
application. Create a meeting:
time, date, topic. Cancel the
meeting.

3.4.2

Invite, uninvite participants, set
access rights.

3.4.3

Start, end a meeting.

3.4.4

Share, unshare desktop, files in
an online meeting.

3.4.5

Use available chat features in an
online meeting.

3.4.6

Use video, audio features in an
online meeting.
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CATEGORY

SKILL SET
3.5 Online Learning
Environments

4 Mobile
Collaboration

4.1 Key Concepts

4.2 Using Mobile Devices

© 2012 ECDL Foundation

REF.

TASK ITEM

3.5.1

Understand the concept of an
online learning environment.
Identify online learning
environments like: Virtual
Learning Environments (VLEs)
and Learning Management
Systems (LMS).

3.5.2

Understand the features,
functions available within an
online learning environment like:
calendar, noticeboard, chat,
assessment records.

3.5.3

Access a course in an online
learning environment.

3.5.4

Upload, download a file in an
online learning environment.

3.5.5

Use a course activity like: quiz,
forum.

4.1.1

Identify types of mobile devices
like: smartphone, tablet.

4.1.2

Understand that mobile devices
use an operating system. Identify
common operating systems for
mobile devices.

4.1.3

Understand the term Bluetooth
and its use.

4.1.4

Understand internet connection
options available for mobile
devices: wireless (WLAN), mobile
internet (3G, 4G). Understand
associated features of these
options like: speed, cost,
availability.

4.1.5

Understand key security
considerations for mobile devices
like: use a PIN, backup content,
turn wireless/Bluetooth on/off.

4.2.1

Connect to the Internet securely
using wireless, mobile technology.

4.2.2

Search the web.

4.2.3

Send, receive e-mail.
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CATEGORY

SKILL SET

4.3 Applications

4.4 Synchronisation
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REF.

TASK ITEM

4.2.4

Add, edit, remove a calendar
event.

4.2.5

Share pictures, videos using
options like: e-mail, messaging,
social media, Bluetooth.

4.3.1

Identify common applications like:
news, social media, productivity,
maps, games, ebooks.

4.3.2

Understand that applications are
obtained from application stores.
Identify common application
stores for mobile devices.

4.3.3

Search for a mobile device
application in an application store.
Recognise that there may be
purchase, usage costs associated
with an application.

4.3.4

Install, uninstall an application on
a mobile device.

4.3.5

Update applications on a mobile
device.

4.3.6

Use an application on a mobile
device like: voice or video
communication, social media,
map.

4.4.1

Understand the purpose of
synchronising content.

4.4.2

Set up synchronisation settings.

4.4.3

Synchronise mobile devices with
mail, calendar, other devices.
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Online Collaboration

Quick Reference

This quick reference is for understanding the main concepts and skills relating to the setup and use of
online collaborative tools.

This module sets out concepts and skills relating to the setup and use
of online collaborative tools, such as storage, productivity applications, calendars, social media, web meetings, learning environments,
and mobile technology.
Successful candidates will be able to:

1 Collaboration Concepts
1.1
1.1.1

1.1.2

1.1.2

1.1.3

1.1.4

1.1.5

Key Concepts
Recognise that ICT (Information and
Communication Technology) can support and
promote online collaboration.
• ICT provides the infrastructure that enables
access to a wide range of online collaborative
tools that support real-time teamwork
Identify the main types of services supporting
online collaboration like:
• Cloud computing - A service that delivers
computing resources such as software and
hardware over the Internet
• Mobile technology - A collection of
technologies that allow devices such as
smartphones and tablets to communicate
Identify the main types of tools supporting
online collaboration like:
• Common productivity applications - Word
processing, spreadsheets, presentation
applications
• Social media - Websites that allow users to
connect with each other or share information
• Online calendars - Calendars on the Internet
for easier user access
• Online meetings - Meetings carried out via the
Internet with remote users
• Online learning environments - Teaching and
learning tools accessible via the Internet
Identify key characteristics of online
collaborative tools like:
• Multiple users - A number of people can use
the same application
• Real time - They allow files to be changed or
interactions to take place instantly
• Global reach - They are not confined to a
particular location
• Concurrent access - Several users can
participate and work on the same thing at the
same time
Outline the benefits of using online
collaborative tools like:
• Shared files and calendars - Easy access for
mobile users on different devices
• Reduced travel expense - Meetings can be
carried out virtually
• Ease of communication - Communication via
e-mail, VoIP, online meetings, chat etc.
• Enhanced teamwork - Users can connect with
each other more easily
• Global access - Internet access allows users
to log on from almost anywhere
Be aware of the risks associated with using
online collaborative tools like:
• Unauthorised access to shared files Unauthorised users may intercept and view
data
• Insufficient management of version control Several people may be working on the version
at the same time

•

Understand the key concepts relating to online collaboration
and cloud computing.

•

Set up accounts to prepare for online collaboration.

•

Use online storage and web-based productivity applications to
collaborate.

•

Use online and mobile calendars to manage and plan activities.

•

Collaborate and interact using social networks, blogs, and
wikis.

•

Schedule and host online meetings and use online learning
environments.

•

Understand key mobile technology concepts and use features
such as e-mail, applications, and synchronisation.

•

1.1.6

1.2
1.2.1

1.2.2

1.2.3

Malware threats - Viruses, worms, spyware or
Trojan horses may enter the network
• Identity/data theft - Personal details may be
used to commit online fraud
• Service interruptions - Downtime due to
Internet access issues or maintenance by
collaborative tool provider
Recognise the importance of intellectual
property rights and the appropriate use of
content when using online collaborative tools.
• Users need to avoid plagiarism by properly
crediting all material referenced or used
• Users should ensure any material shared is
appropriate for the intended audience
Cloud Computing
Understand ways in which cloud computing
facilitates online and mobile collaboration like:
• Storage of shared documents and files Multiple users can access and edit files
• Access to a range of online applications
and tools - Greater collaboration and
communication possible
Outline the benefits of cloud computing for
users like:
• Reduced costs - Costs typically lower than
installing locally on a number of machines
• Enhanced mobility - Applications can be used
in any location with Internet access
• Scalability - Amount of space or applications
used can be increased or decreased as
needed
• Automatic updates - Updates can be made via
the cloud rather than through local installations
Outline the risks of cloud computing like:
• Dependence on provider - Tied due to volume
of data held, convenience reasons, may not
have consistent service
• Data protection and control - Threat of
unauthorised access or malware issues
• Potential loss of privacy - More people may
have access to data

2.1.3

2.2
2.2.1

2.2.2

2.2.2

3 Web-Based Information

3.1
3.1.1

3.1.2

2 Preparation for Online Collaboration
2.1
2.1.1

2.1.2

Common Setup Features
Understand that additional applications,
plug-ins may need to be installed to use certain
online collaborative tools.
• Users may have to install or register for
extra applications or plug-ins before using
online collaborative tools
Identify common equipment used to support
online collaboration like:
• Webcam - A video camera used to capture a
digital video
• Microphone - A device used to digitally
capture sound
• Speakers - Devices that produce sound waves
audible to the human ear

Recognise that firewall restrictions may cause
access issues for users of a collaborative tool.
• Users may need to amend their firewall
settings and permissions to use certain
collaborative tools
Setup
Download software to support online
collaborative tools like:
• VoIP - Voice over Internet Protocol software
allows users to talk to each other in real time
over the Internet
• IM - Instant Messaging software allows
real-time text-based communication via the
Internet
• Document sharing - Software that allows
users to create, edit and maintain documents
collaboratively
Register and/or set up a user account for a
collaborative tool.
• Download or access the collaborative tool
required.
• Set up a user account by creating a user name
and a password.
Deactivate, delete/close a user account.
• Options to deactivate, delete/close a user
account are often found in account settings
and are unique to each account provider.

3.1.3

Online Storage and Productivity Applications
Understand the concept of online storage
solutions and identify common examples.
• Online storage - Data is saved and accessed
via the Internet rather than on a local device or
server
• Examples include Google Drive, SkyDrive,
Dropbox
Identify the limitations of online storage like:
• Size limit - Users have specified storage
amounts and additional storage will usually
cost more
• Time limit - Users may experience temporary
service interruptions or their account being
discontinued due to inactivity
• Sharing restrictions - Document owners need
to set up sharing and editing rights to allow
access to other users
Upload online files, folders.

• Log in to the Google account using a user
name and password.
• In My Drive click the Upload button.
• Click Files or Folder.
• Navigate to the location of the file or folder.
• Select and click Open.
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3.1.3

3.1.3

3.1.4

3.1.4

3.1.5

3.1.6

3.1.6

3.1.7

Download online files, folders.
• Select the file or folder, right-click and click
Download.
Delete online files, folders.
• Select the file or folder, right-click and click
Remove.
Understand that common productivity
applications can be accessed via the web.
• Applications can be installed locally on a
specific computer or device, on a network or
accessed via the cloud.
Identify common examples of web-based
productivity applications like:
• Word processing - Create text documents
• Spreadsheets - Calculate numerical data
• Presentations - Create, manipulate and display
slide shows
Identify features of web-based productivity
applications:
• Allows files to be updated by multiple users in
real time
• Allows files to be shared
Create files online.
• Click Create and select the type of file
required.
Edit and save files online.
• Click the Google document to open it.
• Edit as required.
• All changes are saved automatically.
Share a file, folder to allow other users to view,
edit, a file, folder.

3.2
3.2.1

3.1.7

3.1.7

3.1.8

3.2.4

3.2.5

3.2.2

3.2.3

Click the drop-down arrow to the right of the
calendar to share.
• Select the option to Share this Calendar.
• In Share with specific people, enter the e-mail
address of the user to share the calendar with.
• To grant permission to view a shared calendar,
under Permission Settings select See all event
details.
• To grant permission to edit a shared calendar,
under Permission Settings select Make
changes to events.
• Click Save.
Show shared calendars.
• By default, once shared these should be
visible under Other calendars.
• If hidden, click the Gear button.
• Click Settings and select the Calendars tab.
• Check the checkbox for Show in list next to
the calendar to show.
Hide shared calendars.
• Under Other calendars click the arrow and
click Hide this calendar from the list.
Use a shared calendar to create an event.

3.2.5

3.2.5

•
•

3.2.6

3.2.6

3.3
3.3.1

•
•
•

In Calendar, click the Create button.
Enter a title for the event and a time.
Select the relevant shared calendar in the
calendar drop-down list.
• Click Save.
3.2.3 Use a shared calendar to create a recurring
event.

•
•
•
•

In Calendar, click the Create button.
Enter a title for the event and a time.
Select the relevant shared calendar in the
calendar drop-down list.
Check the Repeat checkbox.
Select the frequency from the Repeats dropdown list.
Select a number in the Repeat every field.
Click Done when complete.

Open the event, and enter the e-mail
addresses in the field Enter email addresses.
Click Add after each guest as needed.
Click Add after each room or resource as
needed, if displayed.
• Click Save.
• When prompted, click Send to send an e-mail
to invite guests to the event.
Uninvite people, resources to an event.
• Click the event to edit.
• Under Guests, click the ‘X’ to the right of the
guest’s name.
• Under Rooms, if this displays, click the ‘X’ to
the right of the resource name.
• Click Save.
• When prompted, click Send to send an e-mail
to uninvited guests to the event.
Accept, decline an invitation.
•
•

•

•
•
•

Open the file.
Click the File menu, then See revision history.
Click the version to view this version.
Click Restore this version to restore this
version.

Click the event to edit.
Click Add a Reminder.
Select the reminder type and the reminder
time.
Invite people, resources to an event.

•

3.3.2

•
•
•
•

Set a reminder for an event.

•
•
•

3.2.2

• Right-click the file or folder.
• Select Share and then click Share.
• In Add people, enter the e-mail addresses of
the users you wish to share with.
• Select the Can edit drop-down list and give
rights to edit, comment or view.
• Click Share & save.
Share a file, folder to allow other users to own
a file, folder.
• To transfer ownership, users must be in the
same domain.
• Right-click the file or folder.
• Select Share and then click Share.
• In Add people, enter the e-mail addresses of
user you wish to transfer ownership to.
• Click Share & save.
• Click the drop-down list to the right of the
user’s name.
• Click Is owner.
• Click Save changes.
Unshare a file, folder.
• Right-click the file or folder.
• Select Share and then click Share.
• Select the recipient to unshare from, then click
on the ‘X’ next to their details.
• Click Save changes.
• Click Done.
View, restore previous versions of a file.

Online Calendars
Share a calendar. Grant permission to view,
edit a shared calendar.

Open the invitation in your e-mail account.
To accept the invite, click Yes beside the
question Going?
• To decline the invite, click No beside the
question Going?
• Click Save.
Edit an existing event.
• Click the event to edit.
• Change details as needed.
• Click Save.
Cancel an existing event.
• Click the event to cancel.
• Click Delete.
• When prompted, click Send to send an e-mail
to any invited guests to the event.
Social Media
Identify social media tools that support online
collaboration like:
• Social networks - Websites that allow users
to connect with each other for recreational or
business purposes
• Wikis - User generated sources of online
information about topics
• Forums and groups - People with shared
interests and knowledge that register with a
website
• Blogs - Shared online journals
• Micro blogs - Shared online journals with
smaller updates
• Content communities - Groups of people with
a shared interest
Set up, modify available permissions/privacy
options like: read access, write access.

•

3.3.2

On the Home Page of Google +, click the Gear
button.
• Click Settings
• Click Profile and privacy.
• Click Edit visibility on profile.
• Change Who can see this? as preferred.
• Click Save.
Set up, modify available permissions/privacy
options like: user invites.
• Click the Gear button.
• Click Settings.
• Click the drop-down list beside Who can send
you notifications?
• Select the preferred option.

3.3.3

Find, connect to social media users, groups.
•

3.3.3

Enter the social media user’s name or the
group name in the Find field.
• Click the Find button.
• Click Add to circles.
• Check the relevant checkbox to add to a
specific circle.
Remove connections.

3.3.7

3.3.7

3.3.8

•
•
•
3.3.4

Click the Find people button.
Click Your circles.
Hover over the connection and click the X
button on the top right of the connection.
Use a social media tool to post a comment.

•
•
3.3.4

3.3.5

Enter the text required in Share what’s new.
If prompted, choose who to share the post
with.
• Click Share.
Use a social media tool to post a link.
• Click the Add link button.
• Enter the link and click Add.
• Click Share.
Use a social media tool to reply to a comment.

3.4
3.4.1

3.4.1
3.4.1

3.3.5

• In Google+ account, click Start a hangout.
Close online meeting application.
• Click the ‘X’ on the top right of the screen.
Create a meeting: time, date, topic.

3.4.2

Go to Calendar.
Create a meeting entering a time, date and
topic.
• Click Add a Google+ hangout.
• Click Save.
Cancel the meeting.
• In Calendar, click the event, then click Delete.
• When prompted, click Send to send an e-mail
to any invited guests to the event.
Invite participants, set access rights.

•

•
•
•
•

3.3.6

Go to the comment to forward.
Click the Share this post arrow.
Enter text if required in Add a comment.
Check or add details of recipients to forward
comment to.
• Click Share.
Use a social media tool to upload content like:
images.

3.4.2

3.4.3

Click the Add photos button.
Click Add photos.
Navigate to where the image is stored and
select.
• Click Open.
• Click Share.
Use a social media tool to upload content like:
videos.

Open the event, and enter the e-mail
addresses in the field Enter email addresses.
• Click Add after each guest as needed.
• Check or uncheck rights of guests as required.
• Click Save.
• When prompted, click Send to send an e-mail
to invite guests to the event.
Uninvite participants.
• Click the event to edit.
• Under Guests, click the ‘X’ to the right of the
guest’s name.
• Click Save.
• When prompted, click Send to send an e-mail
to uninvited guests to the event.
Start a meeting.

•
•
•

3.3.6

3.3.6

Click the Add video button.
Click Upload video.
Click Choose videos to upload.
Navigate to where the video is stored and
select.
• Click Open.
• Click Share.
Use a social media tool to upload content like:
documents.
• Open Google Drive.
• Click the file to upload.
• Copy the URL for the file location from the
Address bar.
• Return to Google +.
• Click the Add link button.
• Paste the link in the highlighted field. The
document will then be displayed.
• Click Share.

3.4.5

3.4.6

3.4.6

3.5
3.5.1

3.5.1

3.5.2

3.5.3

3.5.4

3.5.4

3.5.5

3.4.4

3.4.4

3.4.4

In Google+ account, click Start a hangout.
Enter names of contacts in circles or the e-mail
addresses of guests to invite.
• Enter a name for the meeting.
• Click Hang out.
End a meeting.
•
Click on the Exit button on the top right of
the screen.
Share desktop in an online meeting.
• Click Screenshare.
• Select the window to show in the meeting.
• Click Start Screenshare.
Unshare desktop in an online meeting.
• Click Screenshare to stop current screenshare
from displalying.
Share files in an online meeting.

Unshare files in an online meeting.
• Click the X beside the file name under Hangout
to remove from the hangout.
Use available chat features in an online
meeting.

• On the sidebar of Hangout click Chat.
• Enter the text required.
• Press the Enter key.
Use video features in an online meeting.
• By default, the video is on. To turn video off,
click the Camera button on the top right of the
screen.
• To turn video back on, click the Camera button
on the top right of the screen.
Use audio features in an online meeting.
• By default the audio is on. To turn audio off,
click on the Microphone button on the top
right of the screen.
• To turn audio back on, click on the Microphone
button on the top right of the screen.
Online Learning Environments
Understand the concept of an online learning
environment.
• Online Learning Environment (OLE) - Teaching
and learning tools provided online, to improve
learning experience
Identify online learning environments like:
• Virtual Learning Environments (VLEs) Applications supporting online learning
through files, data, forums, quizzes etc.
• Learning Management Systems (LMS)Applications that help manage the
administration of online courses
Understand the features, functions available
within an online learning environment like:
• Calendar - Tracks course content and
timetable and key dates such as assignments
and exams
• Noticeboard - Lists key information for
students and classes
• Chat - Allows text based conversations
between learners and teachers
• Assessment records - Tracks results of
assessments and exams
Access a course in an online learning
environment.
• Log in to Moodle using username and
password.
• Click the relevant course title to access the
course.
Upload a file in an online learning environment.

• Click the relevant course and topic.
• Click the file or submission upload hyperlink.
• Click the Add file or Add submission button.
• Drag and drop file and then Save Changes.
Download a file in an online learning
environment.
• Click the relevant course and topic.
• Click the hyperlinked file.
Use a course activity like: quiz.

•
•

3.4.3

•
•
•
•

3.4.4

•
•

3.4.1

• Go to the comment to reply to.
• Enter text required in Add a comment.
• Click Post Comment.
Use a social media tool to forward a comment.

Remove posts from social media.
• Click the arrow on the top right corner of the
comment.
• Click Delete post.
• Click Delete.
Be aware that permanently deleting posts and
photos may be difficult.
• The privacy policies of each social media
website differ and can alter over time, so
permanent deletion may be difficult.
Use a wiki to add to or update a specific topic.
• Go to www.wikipedia.org
• Navigate to the desired topic content.
• Click Edit.
• Edit the content.
• Click Save page.
Online Meetings
Open online meeting application.

•
•
•
•
•
•
•
•

•
•
•
•

On the sidebar of Hangout click Google Drive.
Hover over each file and click to select the file.
Click Select and the file is added to the
hangout.
Click Add and repeat to share any additional
files to the hangout.

Click the relevant course and topic.
Select the quiz to complete.
Click Attempt quiz now.
Complete the quiz
Click Next to review summary of answers
given.
Click Return to attempt if an answer needs to
be changed, then Next.
Click Submit all and finish and then Submit all
and finish again.
Review summary of attempt and click Reattempt quiz if required.

3.5.5

Use a course activity like: forum.

4.2.4

4.2.4

•
•
•
•

Click the relevant course and topic.
Select the forum to participate in.
Click Discuss this topic.
Click Edit or Reply as required.

4.2.5

4 Mobile Collaboration
4.1
4.1.1

4.1.2

4.1.3

4.1.4

4.1.4

4.1.5

4.2
4.2.1

4.2.2

4.2.3

4.2.3
4.2.4

Key Concepts
Identify types of mobile devices like:
• Smartphone - A mobile phone used for phone
calls, e-mail, Internet browsing, and working
with mobile applications
• Tablet - A small , mobile, hand-held device that
combines computing and Internet access
Understand that mobile devices use an
operating system. Identify common operating
systems for mobile devices.
• Operating system - Software that schedules
tasks, manages storage and handles
communication with other devices
• Examples include Google Android, Apple iOS,
Windows phone
Understand the term Bluetooth and its use.
• Bluetooth - Wireless technology standard for
exchanging data securely over short distances
Understand internet connection options
available for mobile devices:
• Wireless (WLAN) - A network that connects
computers via radio, infrared or other wireless
technology
• Mobile internet (3G, 4G) - A third generation
and fourth generation wireless standard
Understand associated features of these
internet connection options like:
• Speed - How fast the connection is
• Cost - How expensive the connection is
• Availability - How reliable the connection is
and how few service interruptions
Understand key security considerations for
mobile devices like:
• Use a PIN - To secure the device and help
protect personal details
• Backup content - To avoid data loss and to
minimise downtime in the event of any service
interruption
• Turn wireless/Bluetooth on/off - To minimise
the threat of unauthorised access
Using Mobile Devices
Connect to the Internet securely using
wireless, mobile technology.
• Click Settings on the mobile device.
• Select the desired network and connect, using
a password if required.
Search the web.
• Click the Web Search button.
• Enter the search required and click Submit.
Send e-mail.
• Click the Mail application.
• In the Inbox, click Compose.
• Enter an e-mail address in the To field and the
subject in the Subject field.
• Enter the text required in the body of the
message and click Send.
Receive e-mail.
• In the Inbox, click Refresh.
Add a calendar event.

4.2.5

4.3
4.3.1

4.3.2

4.3.3

4.3.3

4.3.4

4.3.4

4.3.5

4.3.6

Edit a calendar event.
• In the Calendar application, click the event.
• Change details as required and click Save.
Remove a calendar event.
• In the Calendar application, click the event.
• Click Remove Event.
Share pictures using options like: e-mail,
messaging, social media, Bluetooth.
• Click the Photo application.
• Select the picture to share.
• Click Share.
• Select to send by e-mail, messaging, social
media or Bluetooth.
• Enter addresses in the To field.
• Click Share.
Share videos using options like: e-mail,
messaging, social media, Bluetooth.
• Click the Video application.
• Select the video to share.
• Click Share.
• Select to send by e-mail, messaging, social
media or Bluetooth.
• Enter addresses in the To field.
• Click Share.
Applications
Identify common applications like:
• News
• Social media
• Productivity
• Maps
• Games
• ebooks.
Understand that applications are obtained
from application stores. Identify common
application stores for mobile devices.
• Application stores - Online stores that allow
users to buy and upgrade their applications
• Examples include Google Play, Apple App
Store, Windows Store, Amazon Appstore,
Blackberry World Store
Search for a mobile device application in an
application store.
• Click the Application Store button.
• Enter the name of the application in the Search
field.
• Click Search.
• Navigate through the results.
Recognise that there may be purchase, usage
costs associated with an application.
• Not all application costs may be upfront, some
may have subscription fees and usage fees
Install an application on a mobile device.
• Click the Applications button.
• Click Search.
• Enter the name of the application in the Search
field.
• Select the application and click Install.
Uninstall an application on a mobile device.
• Click the Applications button.
• Select the application.
• Click Uninstall.
Update applications on a mobile device.
• Click the Applications button.
• Select the application.
• Click Update.
Use an application on a mobile device like:
Voice or video communication

4.3.6

4.4
4.4.1

4.4.2

4.4.3

Use an application on a mobile device like:
map
• Click the Map button.
• Enter the location required in the Search field.
• Click Submit.
Synchronisation
Understand the purpose of synchronising
content.
• Synchronisation ensures that the same content
is shown on different apps or tools on different
devices.
Set up synchronisation settings.
• Click the Settings button.
• Select to Synchronise e-mail.
• Edit settings as required
• Click Save.
Synchronise mobile devices with mail,
calendar, other devices.
• Click the application button.
• By default, the applications are synchronised,
if not click Refresh.

•
•
4.3.6

•
•
•
•

Click the Calendar application.
Click Add.
Enter a title, location, date and start and end
times.
Click Submit.

Click the VoIP button.
Navigate through contacts, select contact and
click Call.
Use an application on a mobile device like:
social media
• Click the Google+ application.
• Enter a username and password.
• Navigate through content.

© 2013, ECDL Foundation. This Quick Reference may be used by candidates to assist in preparation for this ECDL module test. ECDL Foundation does not warrant that use of this guide will ensure passing of the test.
Screen shots used with permission from Google and Moodle. Google and the Google logo are registered trademarks of Google Inc., used with permission.
Tool- and application-specific details are correct as of April 2013. Online Collaboration tools and applications are subject to frequent update and change.

Image Editing

This module enables the candidate to understand the
main concepts underlying digital images and to use an
image editing application to enhance images, apply
effects, and prepare an image for printing and
publishing.

Module Summary

SYLLABUS OUTLINE

CATEGORY

Imaging Concepts

SKILL SET
Digital Images
Graphic Formats
Colour Concepts

On completion of this module the candidate will be able to:
Understand the main concepts of using digital images;
understand graphic format options and colour concepts.
Open an existing image; save an image in different formats; set
image file options.
Use built-in options, such as displaying toolbars, palettes, to
enhance productivity.
Capture and save an image; use various selection tools;
manipulate images.
Create and use layers; work with text; use effects and filters; use
drawing and painting tools.
Prepare images for printing or publishing.

Image Capture

Using the Application

Image Creation
Settings
Enhancing Productivity

Working with Images

Selection
Image Manipulation
Layers
Text
Effects and Filters

Drawing and Painting

Drawing Tools
Painting Tools

WHAT ARE THE BENEFITS OF THIS MODULE?

Can be applied to a range of image editing software from
professional packages to ‘freeware’.
Certifies best practice in basic digital image editing.
Provides a solid grounding in working with digital images.
Developed with input from computer users, subject matter
experts, and practising computer professionals from all over the
world. This process ensures the relevance and range of module
content.

HOW DO I GET STARTED?
To find out more about this module and to locate your nearest
accredited test centre, please visit www.ecdl.org/programmes.

Capturing Images

Prepare Outputs

Setup
Print

ECDL / ICDL Image Editing
This module sets out essential concepts and skills relating to the ability to understand the
main concepts underlying digital images and to use an image editing application to enhance
images, apply effects, and prepare an image for printing and publishing.

Module Goals
Successful candidates will be able to:
 Know about the main concepts of using digital images and understand graphic format
options and colour concepts.
 Open an existing image, save an image in different formats, and set image file
options.
 Use built-in options such as displaying toolbars, palettes to enhance productivity.
 Capture and save an image, use various selection tools, and manipulate images.
 Create and use layers, work with text, use effects and filters, and use drawing and
painting tools.
 Prepare images for printing or publishing.
CATEGORY

SKILL SET

1 Imaging Concepts 1.1 Digital Images

1.2 Graphic Formats

Copyright © 2009 ECDL Foundation

REF.

TASK ITEM

1.1.1

Identify common uses of digital
images like: web and print
publishing, distribution by e-mail
and mobile phone, home printing,
digital photo frames.

1.1.2

Understand the terms pixel,
resolution and identify the key
features of a digital image:
composed of discrete pixels,
represented digitally in binary
code.

1.1.3

Understand the terms lossy,
lossless image file compression.

1.1.4

Understand the term copyright
and the implications for image
use. Understand the terms
royalty-free images and rightsmanaged images.

1.2.1

Understand the terms raster and
vector graphics and distinguish
between them. Identify common
raster (jpeg, gif) and vector (svg,
eps) formats.
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CATEGORY

SKILL SET

1.3 Colour Concepts

2 Image Capture

3 Using the
Application

Copyright © 2009 ECDL Foundation

2.1 Capturing Images

3.1 Image Creation

REF.

TASK ITEM

1.2.2

Recognize proprietary digital
image editing application
formats: psd, psp, xcf, cpt.

1.3.1

Understand the term colour
model and recognize common
colour models: RGB, HSB,
CMYK, grayscale.

1.3.2

Understand the terms colour
palette, colour depth.

1.3.3

Understand the terms hue,
saturation, colour balance.

1.3.4

Understand the terms contrast,
brightness, gamma.

1.3.5

Understand the term
transparency.

2.1.1

Save an image from a digital
camera to a location on a drive.

2.1.2

Use the print screen facility to
capture a full screen, active
window.

2.1.3

Save an image from an image
library, web page to a location on
a drive.

2.1.4

Open a scanning application and
scan an image: preview, set
scanning parameters, scan,
save.

3.1.1

Open, close an image editing
application. Open, close image
files.

3.1.2

Create a new image file and set
options: colour model, size,
resolution, background colour.

3.1.3

Create a new image file from
clipboard.

3.1.4

Switch between open image files.

3.1.5

Save an image to a location on a
drive. Save an image under
another name to a location on a
drive.

Ref: ECDL / ICDL Image Editing – Syllabus – V2.0
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CATEGORY

SKILL SET

3.2 Settings

3.3 Enhancing Productivity

4 Working with
Images

4.1 Selection

4.2 Image Manipulations

Copyright © 2009 ECDL Foundation

REF.

TASK ITEM

3.1.6

Save, export an image as
another file type like: jpeg, gif, tiff,
png.

3.2.1

Set background colour,
foreground colour.

3.2.2

Set grid properties: units,
horizontal spacing, vertical
spacing, colour.

3.3.1

Set basic options/ preferences in
the application like: transparency,
grid settings, measurement units.

3.3.2

Use available Help functions.

3.3.3

Use magnification/zoom tools.

3.3.4

Use the undo, redo command.
Use the undo history.

3.3.5

Display, hide built-in toolbars,
palettes, windows.

4.1.1

Select an entire image, layer(s).

4.1.2

Set selection tool properties:
relationship between multiple
selections, feathering,
antialiasing, width, height.

4.1.3

Select part of an image using
selection tools: rectangular,
elliptic, magic wand, magnetic
lasso, freehand image.

4.1.4

Inverse a selection.

4.1.5

Save a selection, load a saved
selection.

4.2.1

Change the canvas size of an
image.

4.2.2

Resize an image in pixels,
measurement units.

4.2.3

Crop an image.

4.2.4

Copy, move image(s), selection
within an image.
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CATEGORY

SKILL SET

4.3 Layers

4.4 Text

4.5 Effects and Filters

Copyright © 2009 ECDL Foundation

REF.

TASK ITEM

4.2.5

Rotate, mirror an image,
selection within an image.

4.3.1

Define and understand the term
layer.

4.3.2

Create, copy, delete a layer.

4.3.3

Set layer properties: name, hide,
show, lock, opacity, blending
mode.

4.3.4

Arrange, merge, link, flatten
layers.

4.3.5

Transform layer(s): scale, rotate,
flip, move, trim.

4.3.6

Convert a drawn object to a
raster layer.

4.3.7

Create an animated gif from
layers.

4.4.1

Add, edit, delete text.

4.4.2

Copy, move text.

4.4.3

Align text: left, centre, right,
justified.

4.4.4

Apply text formatting: font sizes,
font types, font colour.

4.4.5

Apply a text warp.

4.5.1

Apply artistic, distortion effects:
pixelate, emboss, wind, ripple,
twirl, desaturate.

4.5.2

Apply blur effects: gaussian,
motion.

4.5.3

Apply lighting effects: lighting,
flare.

4.5.4

Apply adjustments: brightnesscontrast, hue-saturation, colour
balance.

4.5.5

Apply sharpen, unsharpen mask.

4.5.6

Apply red eye reduction.

Ref: ECDL / ICDL Image Editing – Syllabus – V2.0

18

CATEGORY
5 Drawing and
Painting

SKILL SET
5.1 Drawing Tools

5.2 Painting Tools

6 Prepare Outputs

6.1 Setup

6.2 Print

Copyright © 2009 ECDL Foundation

REF.

TASK ITEM

5.1.1

Add a line to an image: straight
line, free drawn line, curves. Set,
modify line weight, style and
colour.

5.1.2

Add a shape to an image:
rectangle, ellipse, n-shaped
polygon. Set, modify line, fill style
and colour.

5.2.1

Pick up a colour value with the
dropper.

5.2.2

Fill a portion of an image with the
gradient tool, selecting
opacity/transparency, radial,
linear, position, rotation.

5.2.3

Colour a portion of an image with
the paintbrush tool, selecting
colour, shape, size.

5.2.4

Erase a portion of an image with
the eraser tool, selecting its
shape and size.

5.2.5

Fill a portion of an image with
colour using the paint bucket
tool.

5.2.6

Clone a portion of an image
using a clone tool, selecting size,
opacity.

6.1.1

Preview an image.

6.1.2

Select appropriate colour depth,
resolution, image size, graphic
format for web, screen, print use.

6.2.1

Change print output orientation:
portrait, landscape. Change
paper size.

6.2.2

Print an image to an installed
printer using defined options,
default settings.
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Image Editing

Quick Reference

This quick reference is for Adobe Photoshop Elements 9
Photoshop Elements Menus / Windows
Application Bar

{
{

Image Arranger

{

Menu Bar
Options Bar

Certification Test Goals
This module sets out essential concepts and skills relating to the ability to
understand the main concepts underlying digital images and to use an image
editing application to enhance images, apply effects, and prepare an image
for printing and publishing.

Edit /
Create /
Share
Panels

Toolbox

Edit
Workspace

Successful candidates will be able to:
Know about the main concepts of using digital images and understand
graphic format options and colour concepts.
Open an existing image, save an image in different formats, and set
image file options.
Use built-in options such as displaying toolbars, palettes to enhance
productivity.
Capture and save an image, use various selection tools, and manipulate
images.
Create and use layers, work with text, use effects and filters, and use
drawing and painting tools.
Prepare images for printing or publishing.

Layers
Panel

Status Bar

Keyboard Shortcuts

1

Imaging Concepts

1.1

Digital Images
Identify common uses of digital images like:
Web and print publishing – Publish images to
websites, social networks or photo sharing sites,
or use for print publishing (magazines, brochures)
Distribution by e-mail and mobile phone – Send your
images to friends, colleagues
Home printing – Using a printer, photo printer
Digital photo frames – Display images on a digital
photo frame
Understand the terms pixel, resolution.
Pixel is the smallest part of a digital image on a
screen or a single point in a raster image.
Resolution is the measure of the detail quality of a
digital image.
Identify the key features of a digital image:
Composed of discrete pixels
Represented digitally in binary code
Understand the terms lossy, lossless image file
compression.
Lossless compression ensures that the compressed
data can be reconstructed to the exact original
image without pixel loss.
Lossy compression creates a smaller sized
compressed file that results in a lower resolution
picture with pixel loss.
Understand the term copyright and the implications
for image use.
Copyright is the rights granted to use, publish or
distribute images, or other pieces of work for a
specific time period.

1.1.1

1.1.2

1.1.2

1.1.3

1.1.4

1.1.4

1.2
1.2.1

1.2.1

General

Editing

Selection

Open CTRL+O

Cut CTRL+X

Select All CTRL+A

Save CTRL+S

Copy CTRL+C

Deselect CTRL+D

Print CTRL+P

Paste CTRL+V

Inverse SHIFT+CTRL+I

Close CTRL+W

Revert SHIFT+CTRL+A

Undo CTRL+Z

Zoom In CTRL+=

Redo CTRL+Y

Zoom Out CTRL+-

Help F1

Auto Red Eye Fix CTRL+R

Understand the terms royalty-free images and
rights-managed images.
Royalty-free images incur a one-off fee that allows the
user to use the image as many times as required with
some restrictions.
Rights-managed images have a copyright license
which, if purchased by a user, allows the one time
use of a photo as specified by the license.
Graphic Formats
Understand the terms raster and vector graphics
and distinguish between them.
Raster graphics represent a grid of pixels and cannot
be scaled to a larger size without losing quality.
Vector graphics are created using points, lines and
curves, based on mathematical equations and can
be scaled to a large size without losing quality.
Identify common raster (jpeg, gif) and vector
(svg, eps) formats.
Raster File Format

1.2.2

File Format

1.3
1.3.1

1.3.1

File Extention

Joint Photographic Experts
Group (JPEG)

.jpeg

Graphics Interchange Format
(GIF)

.gif
1.3.2

Vector File Format

File Extention

Scalable Vector Graphics (SVG)

.svg

Encapsulated PostScript (EPS)

.eps

Recognize proprietary digital image editing
application formats:
File Ext

Photoshop Native Format

.psd

Paint Shop Pro Native Format

.psp

GIMP Native Format

.xcf

Corel Photo-Paint Format

.cpt

Colour Concepts
Understand the term colour model.
A mathematical model describing how
colours can be represented as lists of
numbers, typically as three or four values
or colour components.
Recognize common colour models:
RGB – Combines red, green and blue
HSB - Combines hue, saturation and
brightness
CMYK - Combines cyan, magenta, yellow
and key (black)
Grayscale – Combines shades of gray,
varying from black to white
Understand the terms colour palette,
colour depth.
Colour palette is the total colours available.
Colour depth is the maximum number of
distinct colours that are used in an image,
higher depth gives a broader range of distinct
colours and a more realistic image.
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1.3.3

1.3.4

1.3.5

2
2.1
2.1.1

2.1.2

2.1.3

2.1.4

Understand the terms hue, saturation, colour
balance.
Hue - A pure colour described by name like red or
yellow
Saturation - The dominance of hue in the colour
Colour balance – The overall adjustment of
the intensities of the colours
Understand the terms contrast, brightness, gamma.
Contrast – The difference in colour and light level in
an image
Brightness – The degree to which an image radiates
light
Gamma - The way brightness is changed for the
middle range of gray tones
Understand the term transparency.
The ability of light to transmit through an image.

Capturing Images
Save an image from a digital camera to a location
on a drive.
Connect the digital camera to the computer.
Follow the Wizard instructions to choose the image
to save.
Select the location on the drive and save the image.
Use the print screen facility to capture a full
screen, active window.
To capture a full screen, press the Print Screen key.
Open an image editing application.
Click the Edit menu.
Click Paste.
To capture an active window, open a window on the
desktop.
Press the Alt key + Print Screen key on the
keyboard.
Open an image editing application.
Click the Edit menu.
Click Paste.
Save an image from an image library, web page to
a location on a drive
Right-click on the item.
Select Save Target As.
Create a filename and select the location.
Click Save.
Open a scanning application and scan an image:
preview, set scanning parameters, scan, save.
Place the image on the scanner.
Select scan to view options.
Follow the instructions to choose the scanning
parameters.
Select the location to save the image and scan.

Using the Application

3.1

Image Creation
Open an image editing application.
Click the Start button.
Select All Programs.
Click Adobe Photoshop Elements 9.
Close an image editing application.
Click File.
Click Exit.
Open image files.
Click File.
Click Open.
Select file(s) to open and click Open.
Close image files.
Click File.
Click Close.
Create a new image file and set options:
colour model, size, resolution, background colour.
Click File.
Click New.
Click Blank File.
Name the file and set the file options.
Click OK.

3.1.1

3.1.1

3.1.1

3.1.2

3.1.4

Create a new image file from clipboard.
Ensure an item has been copied to the clipboard.
Click File.
Click New.
Click Image from Clipboard.
Switch between open image files.

3.3.2

3.3.3

3.3.4

3.3.4

3.3.5

3.1.5

Image Capture

3
3.1.1

3.1.3

3.1.5

3.1.6

3.2
3.2.1

3.2.2

3.3
3.3.1

Select the tab of the desired image file to switch
to that file.
Save an image to a location on a drive.
Click File.
Click Save.
Create a file name and select the location.
Click Save.
Save an image under another name to a location
on a drive.
Click File.
Click Save As.
Enter a new file name over the existing file
name and select the location.
Click Save.
Save, export an image as another file type like:
jpeg, gif, tiff, png.
Click File.
Select Save As.
Click on the Format drop-down menu and
select a file type.
Click on Save.

4

Working with Images

4.1

Selection
Select an entire image, layer(s).
On the Select menu, click All.
On the Select menu, click All Layers.
Set selection tool properties: relationship
between multiple selections, feathering,
antialiasing, width, height.
In the Toolbox, click the appropriate Selection
Tool, choosing from the Rectangular/Elliptic
Marquee, Lasso, Magic Wand, Quick Selection
Tool.
On the Options bar, select the desired
relationship between selections option,
feathering, antialiasing, width and height.
Select part of an image using selection tools:
rectangular, elliptic, magic wand, magnetic
lasso, freehand image.

4.1.1

4.1.2

4.1.3

Settings
Set background colour, foreground colour.
In the Toolbox, click the Set Background Color
or Set Foreground Color option.
Select the desired colour using the Color Picker.
Click OK.
Set grid properties: units, horizontal spacing,
vertical spacing, colour.
On the Edit menu, click Preferences and click
Guides & Grid.
Select the Guides Color and Style.
Select the Grid Color and Style and choose the
spacing of Gridlines and Frequency of subdivisions.
Click OK.
Enhancing Productivity
Set basic options/ preferences in the application
like: transparency, grid settings, measurement
units.
To set transparency, on the Edit menu, click
Preferences and click Transparency.
Select the Grid Size, Grid Colors and choose First
and Second Transparency Background Colors.
Click OK.

4.1.4

4.1.5

4.1.5

4.2

To set grid settings, on the Edit menu, click
Preferences and click Guides & Grid.
Select the Guides Color and Style.
Select the Grid Color and Style and choose the
spacing of Gridlines and Frequency of subdivisions.
Click OK.
To set measurements, on the Edit menu, click
Preferences and click Units & Rulers.
Select the appropriate Units, Column Size,
New Document Preset Resolutions and Photo
Project Units.
Click OK.

Use available Help functions.
Click on the Help menu.
Select Photoshop Elements Help.
Use magnification/zoom tools.
On the View menu, click Zoom In or Zoom Out.
Use the undo, redo command.
On the Application Bar, click Undo or Redo.
Use the undo history.
On the Window menu, click Undo History.
Select a state to revert to.
Display, hide built-in toolbars, palettes,
windows.
On the Window menu, select/deselect
appropriate toolbar, palette, window.

4.2.1

4.2.2

Selection Tool

Description

Rectangular /
Elliptical
Marquee tool

Draws square or rectangular
selection borders or draws round
or elliptical selection borders.

Magic Wand tool

Selects pixels of similar colour
with one click.

Magnetic Lasso
tool

Draws a selection border that
automatically snaps to edges you
drag over in the photo.

Lasso tool

Draws freehand selection borders.
This tool is great for making very
precise selections.

Polygonal
Lasso tool

Draws multiple straight-edged
segments of a selection border.

In the Toolbox, click the appropriate
Selection Tool.
Select the part of the image using the tool.
Inverse a selection.
On the Select menu, click Inverse.
Save a selection.
In the Toolbox, click the appropriate Selection
Tool.
Select the part of the image using the tool.
On the Select menu, click Save Selection.
Enter a Selection Name.
Click OK.
Load a saved selection
On the Select menu, click Load Selection.
Choose the desired selection.
Click OK.
Image Manipulation
Change the canvas size of an image.
On the Image menu, click Resize and click
Canvas Size.
Enter the new size details.
Click OK.
Resize an image in pixels, measurement units.
On the Image menu, click Resize and click
Image Size.
Enter the new size details.
Click OK.
Click the Green Tick to accept.

4.2.3

4.2.4

4.2.5

4.3
4.3.1

4.3.2

Crop an image.
In the Toolbox, click the Crop Tool.
Select the part of the image you wish to crop
using the tool.
Click the Green Tick to accept changes.
Copy, move image(s), selection within an
image.
To copy image(s), in the Toolbox, click the Move
Tool.
Select the image and click Ctrl + C to copy.
To move image(s), in the Toolbox, click the Move
Tool.
Select the image and click and drag to move.
Rotate, mirror an image, selection within an
image.
Select the image, part of image using a Selection
Tool from the Toolbox.
On the Image menu, click Rotate and click the
required rotation or flip (mirror) option.
Layers
Define and understand the term layer.
Layers are used to separate different elements
of an image and are stacked on top of each other.
Create a layer.
On the Layer menu, click New and Layer.
Enter Layer Name, Mode and Opacity details.
Click OK.

4.3.3

4.3.4

4.3.4

4.3.4

4.3.4

4.3.5

4.3.5

4.3.5

.4.3.5

4.3.5
4.3.2

4.3.2

4.3.3

4.3.3

4.3.3

4.3.3

Copy a layer.
On the Layer menu, click Duplicate Layer.
Enter Layer Name and Destination details.
Click OK.
Delete a layer.
On the Layer menu, click Delete Layer.
Click Yes.
Set layer properties: name.

In the Layers panel, double click the layer to open
layer properties.
Edit the Layer Name.
Click OK.
Set layer properties: hide, show.
In the Layers Panel, click the Eye symbol to
Show/Hide a layer.
Set layer properties: lock.
In the Layers panel, click the Lock symbol to lock
a layer.
Set layer properties: opacity.
In the Layers panel, click the Opacity arrow.
Adjust the slider to select the appropriate opacity.

4.3.6

4.3.7

Set layer properties: blending mode.
In the Layers panel, click the Blending Mode arrow.
Select the appropriate blending mode.
Arrange layers.
On the Layer Menu, click Arrange.
Select the appropriate option to bring the layer
Backward / Forward.
Merge layers.
In the Layers panel, click the layer you would like
to merge.
On the Layer menu, click Merge Down to merge to
the layer below or Merge Visible to merge all
visible layers.
Link layers.
In the Layers panel, click two or more layers to
link (use the Ctrl key to select these layers).
In the Layers panel, click the Link Symbol to link
the layers.
Flatten layers.
On the Layer menu, click Flatten.
Transform layer(s): scale.
Select a layer.
On the Image menu, click Resize
and Scale.
Use the handles around the image layer to scale,
or enter the new scale using the Options bar.
Click the Green Tick to accept changes.
Transform layer(s): rotate.
Select a layer.
On the Image menu, click Rotate
and select the appropriate layer rotation option.
Transform layer(s): flip.
Select a layer.
On the Image menu, click Rotate
and select the appropriate layer flip option.
Transform layer(s): move.
In the Layers panel, click on the layer to move.
Select the Move Tool, click and drag the layer to
the desired location.
Transform layer(s): trim.
Select a layer, in the Toolbox, click the Crop Tool.
Select the part of the layer to crop using the tool.
Click the Green Tick to accept changes.
Convert a drawn object to a raster layer.
Select a drawn object.
On the Layer menu, click Simplify Layer.
Create an animated gif from layers.
On the File menu, click Save for web and check
the Animate check box.

4.4

Text

4.4.1

Add text.
Select the desired Type Tool from the Toolbox.
Click and drag on the image to create a text
editing region.
On the Options bar, select text options and enter
text.
Click the Green Tick to accept changes.
Edit text.
Select the desired Type Tool from the Toolbox.
Double click on existing text to open the text
editing region.
Edit the text as required.
Click the Green Tick to accept.
Delete text.
Select the desired Type Tool from the Toolbox.
Double click on existing text to open the text
editing region.
Delete the text as required.
Click the Green Tick to accept.
Copy, move text.
Select the desired Type Tool from the Toolbox.
Double click on existing text to open the text
editing region.
Select the text to copy, move.
On the Edit menu, click Cut or Copy.
Paste the text into the desired location.
Align text: left, centre, right, justified.
Select the desired Type Tool from the Toolbox.
Double click on existing text to open the text
editing region.
Select the text to align.
On the Options bar, select the desired alignment.
Click the Green Tick to accept.
Apply text formatting: font sizes, font types,
font colour.
Select the desired Type Tool from the Toolbox.
Double click on existing text to open the text
editing region.
Select the text to format.
On the Options bar, select the desired font size,
font type or font colour.
Click the Green Tick to accept.
Apply a text warp.

4.4.1

4.4.1

4.4.2

4.4.3

4.4.4

4.4.5

Select the desired Type Tool from the Toolbox.
Double click on existing text to open the text
editing region.
Select the text to text warp.
On the Options bar, click the Text Warp option.
Select the desired Style and adjust settings for
Direction, Bend and Distortion.
Click the Green Tick to accept.
4.5
4.5.1

Select any additional loop and frame delay settings.
Click OK
Create a file name and select the location.
Click Save.
Note: You must have two or more layers to create an animated gif.

Effects and Filters
Apply artistic, distortion effects: pixelate,
emboss, wind, ripple, twirl, desaturate.
Select the image, part of image using a
Selection Tool from the Toolbox.
To apply a pixelate effect, on the Filter menu,
click Pixelate and click the required pixelate
sub-option.
Adjust the settings as required and click OK.
To apply an emboss effect, on the Filter menu,
click Stylize and Emboss.
Adjust the settings as required and click OK.

4.5.2

4.5.3

4.5.4

4.5.5

4.5.6

5
5.1
5.1.1

5.1.2

To apply a ripple effect, on the Filter menu,
click Stylize and Wind.
Adjust the settings as required and click OK.
To apply a ripple effect, on the Filter menu,
click Distort and Ripple.
Adjust the settings as required and click OK.
To apply a twirl effect, on the Filter menu,
click Distort and Twirl.
Adjust the settings as required and click OK.
To apply a desaturate effect, select the Sponge
Tool from the Toolbox.
On the Options bar, click the Desaturate mode
option and adjust other options as required.
Click and drag the tool over the image area to
desaturate.
Apply blur effects: gaussian, motion.
Select the image, part of image using a Selection
Tool from the Toolbox.
To apply a Gaussian blur effect, on the Filter menu,
click Blur and Gaussian Blur.
Adjust the settings as required and click OK.
To apply a motion blur, on the Filter menu, click
Blur and Motion Blur.
Adjust the settings as required and click OK.
Apply lighting effects: lighting, flare.
Select the image, part of image using a Selection
Tool from the Toolbox.
To apply a lighting effect, on the Filter menu,
click Render and Lighting Effects.
Adjust the settings as required and click OK.
To apply a flare effect, on the Filter menu, click
Render and Lens Flare.
Adjust the settings as required and click OK.
Apply adjustments: brightness-contrast,
hue-saturation, colour balance.
Select the image, part of image using a Selection
Tool from the Toolbox.
To adjust brightness-contrast, on the Enhance
menu, click Adjust Lighting and Brightness/Contrast.
Adjust the settings as required and click OK.
To adjust hue-saturation, on the Enhance menu,
click Adjust Color and Adjust Hue/Saturation.
Adjust the settings as required and click OK.
To adjust colour balance, on the Enhance menu,
click Adjust Color and choose Color Curves.
Adjust the settings as required and click OK.
Apply sharpen, unsharpen mask.
Select the image, part of image using a Selection
Tool from the Toolbox.
To apply sharpen mask, on the Enhance menu,
click Adjust Sharpness.
Adjust the settings as required and click OK.
To apply unsharpen mask, on the Enhance menu,
click Unsharp Mask.
Adjust the settings as required and click OK.
Apply red eye reduction.
Select the image, part of image using a Selection
Tool from the Toolbox.
On the Enhance menu, click Auto Red Eye Fix.

5.2
5.2.1

5.2.2

5.2.3

5.2.4

5.2.5

5.2.6

For more information, visit:

www.ecdl.org

In the Toolbox, click the Clone Stamp Tool.
On the Options bar, select the desired Size and
Opacity.
Holding the ALT key, make your clone selection.
Click in the desired location to place the cloned
content.

6
6.1
6.1.1

6.1.2

Drawing and Painting
Drawing Tools
Add a line to an image: straight line, free drawn
line, curves. Set, modify line weight, style and
colour.
In the Toolbox, click the Line Tool or Pencil Tool.
On the Options bar, select the desired Weight,
Style and Color.
Draw the line.
Add a shape to an image: rectangle, ellipse,
n-shaped polygon. Set, modify line, fill style and
colour.
In the Toolbox, click the Rectangle Tool, Ellipse Tool
or Polygon Tool.
On the Options bar, select the desired Line, Fill Style
and Color.
Draw the shape.

Painting Tools
Pick up a colour value with the dropper.
In the Toolbox, click the Eye Dropper Tool.
Select the colour of the image to pick and click that
colour to select.
Fill a portion of an image with the gradient tool,
selecting opacity/transparency, radial, linear,
position, rotation.
In the Toolbox, click the Gradient Tool.
On the Options bar, select the desired
Opacity/Transparency, Gradient Type, Position and
Rotation.
Click on the location to start the gradient and drag
to a finish location to apply the gradient.
Colour a portion of an image with the paintbrush
tool, selecting colour, shape, size.
In the Toolbox, click the Brush Tool and select a
Foreground Color.
On the Options bar, select the desired Shape and
Size.
Colour the portion of the image.
Erase a portion of an image with the eraser tool,
selecting its shape and size.
In the Toolbox, click the Eraser Tool.
On the Options bar, select the desired Shape and
Size.
Erase the portion of the image.
Fill a portion of an image with colour using the
paint bucket tool.
In the Toolbox, click the Paint Bucket Tool and
select a Foreground Color.
Fill the portion of the image with the colour.
Clone a portion of an image using a clone tool,
selecting size, opacity.

6.2
6.2.1

6.2.2

Prepare Outputs
Setup
Preview an image.
On the File menu, click Print.
A Print Preview will appear.
Select appropriate colour depth, resolution,
image size, graphic format for web, screen,
print use.
On the Image menu, click Mode.
Select the appropriate colour depth mode.
On the Image menu, click Resize, then click Image
Size.
Select the appropriate resolution or image size.
On the File menu, click Save As.
Select the appropriate file format.
Click Save.
On the File menu, click Save for Web.
Select the appropriate file format.
Click OK.
Choose a file name and click Save.
Print
Change print output orientation: portrait,
landscape. Change paper size.
On the File menu, click Print, then click Page Setup.
Click Portrait or Landscape.
Click OK.
On the File menu, click Print.
Select a paper size.
Print an image to an installed printer using
defined options, default settings.
On the File menu, click Print.
Select additional print options if required.
Click Print.

© 2012, ECDL Foundation. This Quick Reference may be used by candidates to assist in preparation for this ECDL module test. ECDL Foundation does not warrant that use of this guide will ensure passing of the test.
Adobe product screenshot(s) reprinted with permission from Adobe Systems Incorporated.

Web Editing

This module enables the candidate to understand key
web publishing concepts and to create, upload, and
maintain a web site.

Module Summary

SYLLABUS OUTLINE

CATEGORY

SKILL SET

On completion of this module the candidate will be able to:
Understand key web concepts and terms.
Know about the basic principles of HTML; use common HTML
mark-up tags to modify the layout of a web page.
Use a web authoring application to design and format web pages;
format text; work with hyperlinks and tables.
Recognise and use common web image formats; create forms in
a web page.
Understand and use cascading style sheets.
Prepare web pages for publishing to a web server.

Web Concepts

HTML

Web Authoring

Key Terms
Web Publishing
Legal Issues

Fundamentals of HTML
Using HTML

Design
Using the Application
Enhancing Productivity
Text Input and Formatting
Paragraph Formatting
Page Formatting
Hyperlinks
Tables

WHAT ARE THE BENEFITS OF THIS MODULE?

The following outlines the benefits of ECDL / ICDL - Web Editing:
Applicable to a variety of web publishing software.
Provides the candidate with the skills to develop, publish, and
maintain a website.
Certifies best practice in website creation.
Developed with input from computer users, subject matter
experts, and practising computer professionals from all over the
world. This process ensures the relevance and range of module
content.

HOW DO I GET STARTED?
To find out more about this module and to locate your nearest
accredited test centre, please visit www.ecdl.org/programmes.

Using Objects

Styles

Prepare Upload

Graphical Objects
Forms

CSS Concepts
Using CSS

Check
Publish

ECDL / ICDL Web Editing
This module sets out essential concepts and skills relating to the ability to understand key
web publishing concepts and to create, upload and maintain a static web site.

Module Goals
Successful candidates will be able to:
 Understand key web concepts and terms.
 Know about the basic principles of HTML and use common HTML mark-up tags to
modify the layout of a web page.
 Use a web authoring application to design and format web pages, format text, and
work with hyperlinks and tables.
 Recognise and use common web image formats and create forms in a web page.
 Understand and use cascading style sheets.
 Prepare web pages for publishing to a web server.
CATEGORY
1 Web Concepts

SKILL SET
1.1 Key Terms

1.2 Web Publishing

Copyright © 2009 ECDL Foundation
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TASK ITEM

1.1.1

Understand that the Internet
supports a range of services like
the World Wide Web (WWW), file
transfer, email, instant
messaging (IM).

1.1.2

Understand the term
client/server. Understand the
functionality and relationship
between the browser, web
server.

1.1.3

Understand the terms domain,
Uniform Resource Locator
(URL), hyperlink, web hosting,
search engine.

1.1.4

Understand the use of primary
protocols: Transmission Control
Protocol/Internet Protocol
(TCP/lP), Hypertext Transfer
Protocol (HTTP), File Transfer
Protocol (FTP).

1.2.1

Identify the main advantages of
having a website: access to a
global audience, ease of
updating, audience interactivity,
cost benefits.

Ref: ECDL / ICDL Web Editing – Syllabus – V2.0

CATEGORY

SKILL SET

1.3 Legal Issues

2 HTML

2.1 Fundamentals of HTML

2.2 Using HTML

Copyright © 2009 ECDL Foundation
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TASK ITEM

1.2.2

Understand the process of
getting a website online like:
registering a domain, choosing a
web hosting service.

1.2.3

Recognize search engine
optimization techniques like:
including relevant meta data,
including a site map and website
links, registering with a search
engine.

1.2.4

Recognize factors that impact on
web page download speed:
audio, video, graphical objects,
animation content, file
compression.

1.2.5

Recognize appropriate audio,
video, graphical file formats to
optimize web page download
speed.

1.3.1

Understand the term copyright
and its implications for text,
images, audio, video available on
websites.

1.3.2

Understand that website content
is subject to the laws of the
country in which it is hosted.

2.1.1

Understand the term Hypertext
Markup Language (HTML).

2.1.2

Understand the role of the W3C
consortium in developing HTML
recommendations. Understand
the benefits these
recommendations offer like:
interoperability of web sites
across browsers, enhanced
accessibility, consistent
document type declarations.

2.2.1

Use the browser to view web
page source code.

2.2.2

Use markup tags to structure a
web page layout: <html>,
<head>, <title>, <body>.

2.2.3

Use markup tags to develop the
layout of a web page: <h1>,
<h2>, <p>, <br />, <a href>, <img
/>.
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CATEGORY
3 Web Authoring

SKILL SET
3.1 Design

3.2 Using the Application

3.3 Enhancing Productivity

3.4 Text Input and Formatting

3.5 Paragraph Formatting

3.6 Page Formatting
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REF.

TASK ITEM

3.1.1

Recognize planning and design
techniques like: evaluating the
needs of the target audience,
creating storyboards, organizing
the site structure, creating a page
layout template, deciding on a
navigation scheme.

3.1.2

Recognize good practice in font
selection. Using sans serif fonts
like: Arial, Courier, Helvetica.

3.2.1

Open, close a web authoring
application. Open, close web
pages.

3.2.2

Create, save a new web page,
website to a location on a drive.

3.2.3

Create, save a new web page
based on an available template.

3.2.4

Add, edit a descriptive page title.

3.2.5

Change between source code
and design view.

3.3.1

Set basic options/ preferences in
the application: default preview
browser, default document type,
encoding, fonts.

3.3.2

Use available Help functions.

3.4.1

Insert, edit, delete text.

3.4.2

Understand and use relative font
size.

3.4.3

Apply text formatting: bold, italic,
font type and colour.

3.5.1

Set paragraph properties:
alignment, indentation.

3.5.2

Insert, remove paragraph break,
line break.

3.5.3

Create, modify a single-level
ordered (numbered), unordered
(bulleted) list.

3.6.1

Set page margins: top, bottom,
left, right.
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CATEGORY

SKILL SET

3.7 Hyperlinks

3.8 Tables

4 Using Objects

4.1 Graphical Objects

4.2 Forms
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TASK ITEM

3.6.2

Add, modify, remove a page
background colour, image.

3.6.3

Change a page hyperlink colour:
visited, active, unvisited.

3.7.1

Understand the terms absolute
and relative hyperlinks.

3.7.2

Insert, edit, remove a hyperlink:
text, image.

3.7.3

Insert, edit, remove an e-mail
hyperlink: text, image.

3.7.4

Define hyperlink target: same
window, new window.

3.7.5

Set an anchor, insert a link to an
anchor.

3.8.1

Insert, delete a table.

3.8.2

Insert, edit a table caption.

3.8.3

Align a table: left, centre, right.

3.8.4

Insert, delete rows and columns.

3.8.5

Modify column width, row height.

3.8.6

Merge, split cells.

3.8.7

Modify table border width, cell
padding, cell spacing.

3.8.8

Change background colour,
background graphic, image of
cells, entire table.

3.8.9

Add, remove a table background
graphic, image.

4.1.1

Add, remove an image on a web
page.

4.1.2

Set, modify attributes of an
image: size, border, alignment,
alternative text.

4.2.1

Insert a form on a web page.

4.2.2

Add, remove single-line, multiline text fields.
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5 Styles

SKILL SET

5.1 CSS Concepts

5.2 Using CSS

6 Prepare Upload

6.1 Check

6.2 Publish
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REF.

TASK ITEM

4.2.3

Add, remove form fields: dropdown, check box, radio button.

4.2.4

Set, modify form field properties:
text field, drop-down, check box,
radio button.

4.2.5

Add, remove submit, reset
buttons.

4.2.6

Set, modify properties for submit,
reset buttons.

4.2.7

Set, modify form action to send
form output by email.

5.1.1

Understand the term Cascading
Style Sheets (CSS), their use
and benefits.

5.1.2

Recognize the main approaches
to applying styles: inline, internal,
external.

5.1.3

Understand the structure of a
CSS rule: selector and
declaration (property, value).

5.2.1

Create, save a new CSS file.

5.2.2

Create, modify CSS rules: colour,
background, font

5.2.3

Attach an external CSS to a web
page.

6.1.1

Identify and fix broken links in a
website.

6.1.2

Recognize good practice in
webpage content: including a last
updated date, details of software
required to open, view files,
ensuring compatibility of content
with web browsers.

6.1.3

Spell check a web page and
make changes.

6.2.1

Understand the process of
uploading, downloading a web
site to, from a web server.

6.2.2

Upload, download a web site to,
from a server.
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Web Editing

Quick Reference

This quick reference is for Adobe Dreamweaver CS5.5 on Windows 7
Dreamweaver CS5.5 Opening Screen

Web Editing Goals
This module sets out essential concepts and skills relating to the
ability to understand key web publishing concepts and to create,
upload and maintain a static web site.

Application bar

Document window

Document toolbar

Workspace switcher

Insert panel

CSS Styles panel

CSS Rules panel
CSS Properties
panel

Tag selector

Property inspector

Files panel

Successful candidates will be able to:
Understand key web concepts and terms.
Know about the basic principles of HTML and use common HTML
mark-up tags to modify the layout of a web page.
Use a web authoring application to design and format web pages,
format text, and work with hyperlinks and tables.
Recognise and use common web image formats and create forms
in a web page.
Understand and use cascading style sheets.
Prepare web pages for publishing to a web server.

Keyboard Shortcuts
Editing

General
Open the file menu ALT+F

Open the edit menu ALT+E

New document CTRL+N

Cut CTRL+X

Open a document CTRL+O

Copy CTRL+C

Close the current document: CTRL+W

Paste CTRL+V

Navigation

Formatting

Up one screen PAGE UP

Bold CTRL+B

Down one screen PAGE DOWN

Italics CTRL+I
Underline CTRL+U

1

Web Concepts

1.1

Key Terms
Understand that the Internet supports a range of
services like:
The World Wide Web (WWW)
File transfer
Email
Instant messaging (IM)
Understand the term client/server.
In a client/server network, the server stores data
which can be requested and used by the client.
Understand the functionality and relationship
between the browser, web server.
A web server stores and delivers web documents.
A web browser displays pages sent by a web server.
Understand the terms domain, Uniform Resource
Locator (URL), hyperlink, web hosting, search engine.
Domain - Identifies ownership of a web address
Uniform Resource Locator (URL) - A website address
that is unique for every website
Hyperlink - A graphic or text with an embedded cross
reference that connects to web page, or portion of a
web page
Web hosting - A service which allocates space for
websites on computer servers
Search engine - Software designed to search for
information on the World Wide Web
Understand the use of primary protocols:
Transmission Control Protocol/Internet Protocol
(TCP/lP) - The protocol suite upon which the Internet
is based
Hypertext Transfer Protocol (HTTP) - Used to request
and transport World Wide Web pages across the
Internet
File Transfer Protocol (FTP) - Used to transfer files
from one computer to another over a TCP/IP network

1.1.1

1.1.2

1.1.2

1.1.3

1.1.4

1.2
1.2.1

1.2.2

1.2.3

1.2.4

1.2.5

Web Publishing
Identify the main advantages of having a website:
Access to a global audience
Ease of updating
Audience interactivity
Cost benefits
Understand the process of getting a website
online like:
Registering a domain - To obtain exclusive use of a
unique domain for a period of time
Choosing a web hosting service - To store and display
your website on computer servers that are connected
to the Internet
Recognize search engine optimization
techniques like:
Including relevant meta data
Including a site map and website links
Registering with a search engine
Recognize factors that impact on web page
download speed: audio, video, graphical
objects, animation content, file compression.
High quality Audio
High definition Video
Too many graphical objects on a web page
Animation Content - Too much on a web page can
decrease web page download speed
File compression - to decrease file size
Recognize appropriate audio, video,
graphical file formats to optimize web page
download speed.
Audio - MIDI, MP3
Video - Flash Video .flv files
Graphical file formats - jpeg, gif

1.3
1.3.1

1.3.2

Legal Issues
Understand the term copyright and its
implications for text, images, audio, video
available on websites.
Copyright is a legal way to protect the rights
of ownership of a website and any text, audio,
images and video it may contain.
Understand that website content is subject
to the laws of the country in which it is hosted.
Website content is subject to the laws of the
country in which it is hosted rather than the
country in which it was originally created.

2

HTML

2.1

Fundamentals of HTML
Understand the term Hypertext Markup
Language (HTML).
Hypertext Markup Language (HTML) is a tag
based notation language used to format
documents on the world wide web.
Understand the role of the W3C consortium in
developing HTML recommendations.
World Wide Web Consortium (W3C) is a
standards body that gives recommendations
for the development of open web standards,
HTML.
Understand the benefits these
recommendations offer like:
Interoperability of websites across browsers Allows the viewing of web pages across a
range of devices and browsers
Enhanced accessibility - Improves search
result rankings, reduces maintenance costs,
and increases audience reach
Consistent document type declarations - Give
web pages a consistent look

2.1.1

2.1.2

2.1.2

© 2012, ECDL Foundation. This Quick Reference may be used by candidates to assist in preparation for this ECDL module test. ECDL Foundation does not warrant that use of this guide will ensure passing of the test.
Adobe product screenshot(s) reprinted with permission from Adobe Systems Incorporated.

2.2
2.2.1

2.2.2

2.2.3

3
3.1
3.1.1

3.1.2

3.2
3.2.1

3.2.1

3.2.1

3.2.1

3.2.2

3.2.2

3.2.2

Using HTML
Use the browser to view web page source code.
Click to open Internet Explorer.
Browse to the web page you want to view.
Click the View menu.
Click Source.
Use markup tags to structure a web page layout:
<html>, <head>, <title>, <body>.
Open a text editor and enter the following tags:
<html>
<head>
<title> This is a title</title>
</head>
<body> This is body text. </body>
</html>
Use markup tags to develop the layout of a
web page: <h1>, <h2>, <p>, <br />, <a href>,
<img />.
Open a text editor and enter the following tags:
<html>
<head>
<title> This is a title</title>
</head>
<h1>This is a heading</h1>
<h2>This is a smaller heading</h2>
<br />creates a single line break in a block of text
<p>This is a paragraph.</p>
<a href="http://www.ecdl.org">This is a link</a>
<img src="school.jpg" width="104" height="142" />
</html>

3.2.2

3.2.3

3.2.3

3.2.4

Using the Application
Open a web authoring application.
Click the Start button.
Select All Programs.
Click Adobe Dreamweaver CS5.5.
Close a web authoring application.
Click the File menu.
Click Exit.
Open web pages.
Click the File menu.
Click Open.
Select web pages(s) to open and click Open.
Close web pages.
Click the File menu.
To close the selected open page, click Close.
To close all open pages, click Close All.
Create a new web page.
Click the File menu.
Click New.
Click Blank Page.
Click HTML for page type.
Click Create.
Create a new website.
Click the Site menu.
Click New Site.
Enter site name and local site folder details.
Click Save.
Save a new web page to a location on a drive.
Click the File menu.
Click Save.
Create a file name and select the location.
Click Save as type and select HTML Documents.
Click Save.

3.4.1

3.4.2

3.4.2

3.4.3

3.4.3

3.2.5

Web Authoring
Design
Recognize planning and design techniques like:
Evaluating the needs of the target audience
Creating storyboards
Organizing the site structure
Creating a page layout template
Deciding on a navigation scheme
Recognize good practice in font selection.
Using sans serif fonts like: Arial, Courier,
Helvetica.
A sans serif font is suitable for a web page
because it can be easily viewed in both high and
low resolution.

Save a website to a location on a drive.
Click the Site menu.
Click New Site.
Enter local site folder details.
Click Save.
Create a new web page based on an available
template.
Click the File menu.
Click New.
Click Page from Template.
Select a site that contains the template.
Select a template.
Click Create.
Save a new web page based on an available
template.
Click the File menu.
Click Save.
Create a file name and select the location.
Click Save as type and select HTML Documents.
Click Save.
Add, edit a descriptive page title.

3.3
3.3.1

Click the Design button.
Select the text Untitled Document in the Title
box located on the Document toolbar.
Type in a new page title and press the Return key.
Change between source code and design view.
Click the Code button on the Document toolbar
to show the source code.
Click the Design button on the Document toolbar
to show the design view.
Enhancing Productivity
Set basic options/ preferences in the
application: default preview browser.

3.4.3

3.5
3.5.1

3.5.1

3.5.2

3.3.1

3.3.1

3.3.2

3.4
3.4.1

3.4.1

Click the Edit menu.
Click Preferences.
Select Preview in Browser in the Category box.
Click the Browsers + button to add details.
Click OK twice.
Set basic options/ preferences in the
application: default document type, encoding.
Click the Edit menu.
Click Preferences.
Select New Document in the Category box.
Click Default document and select a document
type.
Click Default encoding and select a default
encoding.
Click OK.
Set basic options/ preferences in the application:
fonts.
Click the Edit menu.
Click Preferences.
In Category, select Fonts.
Select an encoding type from the Font Settings list.
Select a font and size.
Proportional font - Used to display normal text
Fixed font - Used to display text within pre, code,
and tt tags
Code view - Used for all text that appears in the
Code view and Code inspector
Click OK.
Use available Help functions.
Click the Help menu.
Click Dreamweaver Help.
Text Input and Formatting
Insert text.
Enter text into the design work area.
Edit text.
Edit text as required.

3.5.2

3.5.3

3.5.3

3.5.3

3.5.3

3.6
3.6.1

3.6.2

Delete text.
Select the text to delete.
Press the Delete key.
1
Understand relative font size.
Makes websites more accessible and readable
Can be set relative to surrounding elements
Allows a user to change the text size in browsers
Use relative font size.
Click the Modify menu, click CSS Styles.
Double click an existing rule or property in the top
pane of the CSS Styles panel.
In the CSS Rule Definition dialog box, select
Type, and then set the style properties.
Click the Font-size drop-down arrow and choose
a relative size, for example, medium.
Click OK.
Apply text formatting: bold, italic.
Select the text to format.
To embolden the text, click the Format menu,
select Style and click Bold.
To italicize the text, click the Format menu, select
Style and click italic.
Apply text formatting: font type.
Select the text to format.
Click the Format menu.
Select Font and click on a font from the list.
Apply text formatting: color.
Select the text to color.
Click the Format menu.
Click Colour and select a color.
Click OK.
Paragraph Formatting
Set paragraph properties: alignment.
Select the paragraph to align.
Click the Format menu.
Select Align.
Select Left, Centre, Right, Justify.
Set paragraph properties: indentation.
Select the paragraph to indent.
Click the Format menu.
Click Indent or Outdent.
Insert, remove paragraph break.
To insert press the Return key.
To remove click on the paragraph break and press
the Delete key.
Insert, remove line break.
To insert position the cursor to force a line break.
Click the Insert menu.
Select HTML and select Special Characters.
Click Line Break.
To remove click at the beginning of the line break
and press the Backspace key.
Create a single-level ordered numbered list.
Select the text to list.
Click the Format menu.
Select List and click Ordered List.
Modify a single-level ordered numbered list.
Click anywhere in the list.
Click the Format menu.
Select List and click Properties.
Create an unordered bulleted list.
Click anywhere in the list.
Click the Format menu.
Select List.
Click Properties.
Modify an unordered bulleted list.
Click anywhere in the list.
Click the Format menu.
Select List.
Click Properties.
Page Formatting
Set page margins: top, bottom, left, right.
Click the Modify menu.
Click Page Properties.
Enter a left, right, top, bottom, margin.
Click Apply.
Add, modify a page background color.
Click the Modify menu.
Click Page Properties.
Click Appearance (HTML).

3.6.2

3.6.2

3.6.2

3.6.3

Click the Background color box.
Select a color from the color picker.
Remove a page background color.
Click the Modify menu.
Click Page Properties.
Click Appearance (HTML).
Click the Background color box.
Click the Default Color button on the top of the
color picker.
Add, modify a background image.
Click the Modify menu.
Click Page Properties.
Click Appearance (HTML).
Beside Background image click the Browse button
in the Select Image Source dialog box.
Navigate to and select the image.
Click OK, click Apply and click OK.
Remove a background image.
Click the Modify menu.
Click Page Properties.
Click Appearance (HTML).
Select the text in the Background image box.
Press the Delete key.
Click Apply and click OK.
Change a page hyperlink colour: visited,
active, unvisited.

3.7.3

3.7.3

3.7.3

3.7.4

3.7.5

Click the Modify menu.
Click Page Properties.
Click Links (CSS).
Visited - Click the Visited links color picker and
select a color.
Click the appropriate links color picker and select
a color.
3.7
3.7.1

3.7.2

Hyperlinks
Understand the terms absolute and relative
hyperlinks.
Absolute hyperlinks are used when linking to pages
outside of the current site that have a different
domain name.
Relative hyperlinks are addresses that are relative
to the current domain or location.
Insert a hyperlink: text, image.

3.7.5

Insert, an e-mail hyperlink: text, image.
Click in the web page where the link should appear.
Click the Insert menu.
Click Email Link.
In the Text box, enter text for the hyperlink.
In the Email box, enter the email address.
Click OK.
Edit an e-mail hyperlink: text, image.
Select the link.
Click the Insert menu.
Click Email Link.
In the Text box, edit text for the hyperlink.
In the Email box, edit the email address.
Click OK.
Remove an e-mail hyperlink: text, image.
Click on the hyperlink to remove.
Click the Modify menu.
Click Remove Link.
Define hyperlink target: same window, new
window.
Click the Insert menu.
Click Hyperlink.
Click in the Target arrow:
_blank - loads the linked file into a new, unnamed
browser window
_self - loads the linked file into the same frame or
window as the link
Click OK.
Set an anchor.
Click in front of the first letter of the word to be
anchored.
Click the Insert menu.
Click Named Anchor.
Click in the Anchor name box and enter a name.
Click OK.
Insert a link to an anchor.
Select the text to be linked.
Click Point to File in the Properties inspector.
Drag the arrow to the anchor to link to and
release the mouse button.

3.8.4

3.8.4

3.8.5

3.8.5

3.8.6

3.8.6

3.8.7

3.8.8

3.8.8

3.8.9
3.8
3.8.1

Tables
Insert a table.

3.8.9

3.7.2

3.7.2

Click in the web page where the link should appear.
Click the Insert menu.
Click Hyperlink.
Click in the Text box and enter the link text.
Click in the Link box and enter the name of the file
to link to.
Click in the Target box and enter or select the name
of the window in which the file should open.
Click in the Title box and enter a title for the link.
Click in the Access Key box and enter a keyboard
equivalent (one letter) to select the link in the
browser.
Click in the Tab index box and enter a number for
the tab order.
Click OK.
Edit a hyperlink: text, image.
Click on the hyperlink for editing.
Click the Modify menu.
Click Change Link.
Enter the new file or URL details.
Click OK.
Remove a hyperlink: text, image.
Click on the hyperlink to remove.
Click the Modify menu.
Click Remove Link.

3.8.1

3.8.2

3.8.2

3.8.3

3.8.4

Click in the page where the table should appear.
Click the Insert menu, click Table.
In the Table dialog enter settings as required.
Delete a table.
Select the table and press the Delete key.
Insert a table caption.
Click where you want the table to appear.
Click the Insert menu.
Click Table, in the Table dialog enter the table
settings.
Caption - Enter a title in the Caption field.
Edit a table caption.
Click in the table caption and edit the text.
Align a table: left, centre, right.
Select the table and from the Properties inspector,
click the Align box.
Select Left, Center, Right.
Insert rows.
Click in a cell below the row to insert.
Click the Modify menu and select Table.
Click Insert Row for a row to appear above the
insertion point.

Insert columns.
Click the Modify menu and select Table.
Click Insert Column for a column to appear to
the left of the insertion point.
Delete rows and columns.
Click in a cell within the row or column to delete.
Click the Modify menu and select Table.
Click Delete Row or Delete Column.
Modify column width.
Drag the right border of the column you want to
change.
Modify row height.
Drag the lower border of the row you want to
change.
Merge cells.
Select the cells in a line or a rectangle shape.
Click the Modify menu and select Table.
Click Merge Cells.
Split cells.
Click in a cell.
Click the Modify menu and select Table.
Click Split Cell.
Modify table border width, cell padding, cell
spacing.
Select the table, in the Properties inspector, click
the Border box and enter a width.
Click the CellPad box and enter a value.
Click the CellSpace box and enter a value.
Change background colour of cells, entire table.
Select the cells and from the Properties inspector,
click on the Bg box.
Select a color from the colour picker.
Change background graphic, image of cells,
entire table.
Select the cell containing the background image
and from the Properties inspector, click on the
Browse for File folder adjacent to the Src box.
Click on an image in the Select Image Source
dialog.
Click OK.
Add a table background graphic, image.
Open the CSS Styles panel.
Double-click on a table rule in the Rules pane.
Click on Background in the Category pane. This
will open the CSS Rule Definition for table in
layout.css dialog box.
Beside Background-image click the Browse
button in the Select Image Source dialog box
and navigate to and select the image.
Click OK.
Click Apply and click OK.
Remove a table background graphic, image.
Select the table.
Open the CSS Styles panel.
Double-click on a table rule in the Rules pane.
Click on Background in the Category pane. This
will open the CSS Rule Definition for table in
layout.css dialog box.
Click the Background-image box arrow and select
None.
Click OK.
Click Apply and click OK.

4

Using Objects

4.1

Graphical Objects
Add an image on a web page.
Click the Insert menu.
Click on Image.
When the Select Image Source dialog box
appears, navigate to the image you want to use.
Click OK.
Remove an image on a web page.
Click on the image.
Press the Delete key.
Set, modify attributes of an image: size, border,
alignment, alternative text.
Select the image and use the Properties inspector
to set or modify various attributes of the image.

4.1.1

4.1.1

4.1.2

Click in the W box and enter the image width.
Click in the H box and enter the image height.
Click in the Border box and enter the width.
Click the Align drop-down box and select how the
text will wrap around the image.
Click in the Alt box and enter the image description.
4.2
4.2.1

4.2.2

4.2.2

4.2.3

4.2.3

4.2.4

4.2.4

4.2.4

4.2.4

4.2.5

4.2.5

Forms
Insert a form on a web page.
Click on the web page where the form appears.
Click the Insert menu and select Form.
Click Form and use the Properties inspector to set
various properties.
Click in the Form ID box and enter a unique name
for the form.
Click in the Action box and enter name and
location.
Click on the Method box arrow to select the method
to transmit the form data to the server.
Add single-line, multi-line text fields.
Click the Insert menu and select Form.
To add a single-line field click Text Field.
To add multi-line field click Text area.
Remove single-line, multi-line text fields.
Select the fields and press the Delete key.
Add form fields: drop-down, check box,
radio button.
Click the Insert menu and select Form.
To add a drop-down field click Select (List/Menu).
To add a check box field click Checkbox.
To add a radio button field click Radio Button.
Remove form fields: drop-down, check box,
radio button.
Select the fields and press the Delete key.
Set, modify form field properties: text field.
Click on the text field and set, modify properties
in the Properties inspector.
Char width - Enter the maximum number of
characters that can be displayed in the field
Max Chars - Enter the maximum number of
characters that can be entered in a text field
Num Lines - Enter the height of the field for a
multi-line text field
Type - Select single line or multi line
Init val - Enter default text or value
Set, modify form field properties: drop-down.
Click on the drop-down and set, modify properties
in the Properties inspector.
Select - Enter a unique name
Type - Select Menu to display a drop-down menu,
select List to display a scrollable list
Height - Enter the number of items displayed in List
Selections - Select Allow multiple to allow more than
one item to be selected from a menu
List Values - Click List Values to add, remove or
reorder items in the menu
Set, modify form field properties: check box.
Click on the check box and set, modify properties
in the Properties inspector.
Initial state - Select to have checked or unchecked
Set, modify form field properties: radio button.
Click on the radio button and set, modify properties
in the Properties inspector.
Checked Value - Enter the value to be sent to server
when radio button is selected
Initial State - Select to have radio button, selected
or not selected when initially displayed in a browser
Add submit button.
Click the Insert menu and select Form.
Click Button.
Add reset button.
Click the Insert menu and select Form.
Click Button.
Select the button in the form and click Reset
form as the action in the Properties pane.

4.2.5

4.2.6

4.2.7

Remove submit, reset buttons.
Select the button and press the Delete Key.
Set, modify properties for submit, reset buttons.
Click on the button and set, modify properties in the
Properties inspector.
Value - Enter the text to appear on the button
Action - Select Submit form to submit the form data
or select Reset form to clear the form contents
Set, modify form action to send form output by
email.
Click on the web page where you want the form to
appear.
Click the Insert menu and select Form.
Click Form and use the Properties inspector to set,
modify various properties.
Action - Enter the text mailto:emailaddress
Method - Select POST
Enctype - Enter the text, text/plain

5

Styles

5.1

CSS Concepts
Understand the term Cascading Style Sheets
(CSS), their use and benefits.
A CSS page layout uses the Cascading Style Sheets
format to organise the content on a web page.
The benefits are: easier to edit, load faster, smaller in
size, quick to develop, greater control of design.
Recognize the main approaches to applying
styles:
Inline
Internal
External
Understand the structure of a CSS rule:
selector and declaration (property, value).
Declaration - it has two parts, property and value
Selector - Specifies which items in the web page
will be affected by the declaration
Selector {property:value}
H2 {color:yellow}

5.1.1

5.1.2

5.1.3

5.2
5.2.1

5.2.2

5.2.2

5.2.2

Using CSS
Create, save a new CSS file.
Click the File menu and select New.
Click Blank Page in the New Document dialog.
Page Type - click CSS.
Click the Create button.
Create a file name and select the location.
Click Save as type and select Style Sheet File.
Click Save.
Create CSS rules: font.
Open the CSS Styles panel.
Click New CSS Rule.
In the New CSS Rule dialog box, select a
selector type, selector name, and rule definition.
Click OK.
In the CSS Rule Definition dialog box, select
Type and then set the style properties for fonts.
Click Apply.
Click OK.
Create CSS rules: background.
Open the CSS Styles panel.
Click New CSS Rule.
In the New CSS Rule dialog box, select a selector
type, selector name, and rule definition.
Click OK.
In the CSS Rule Definition dialog box, select
Background and set style properties for background.
Click Apply.
Click OK.
Modify CSS rules: font.
Open the CSS Styles panel.
Click the All button on the CSS Styles panel.
Double click the rule you want to modify.
In the CSS Rule Definition dialog box, select
Type and then modify the style properties for fonts.
Click Apply.
Click OK.

5.2.2

5.2.3

Modify CSS rules: background.
Open the CSS Styles panel.
Click the All button.
Double click the rule you want to modify.
In the CSS Rule Definition dialog box, select
Background and then modify the style properties
for background.
Click Apply.
Click OK.
Attach an external CSS to a web page.
Open the CSS Styles panel.
Click the Attach Style Sheet button.
In the Attach External Style Sheet dialog box,
click Browse to browse to a CSS style sheet.
Click OK.
Select Link to create a link between the current
document and an external style sheet.
Select a media for the style sheet.
Click Preview to view styles applied.
Click OK.

6

Prepare Upload

6.1

Check
Identify and fix broken links in a website.
Click the File menu and select Check Page.
Click Links.
Any broken links found will be displayed in the
results panel under the Link Checker tab.
Recognize good practice in web page content:
Including a last updated date
Details of software required to open, view files
Ensuring web browsers compatibility
Spell check a web page and make changes.
Click the File menu and select Check Page.
Click Spelling.

6.1.1

6.1.2

6.1.3

6.2
6.2.1

6.2.1

6.2.2

6.2.2

Publish
Understand the process of uploading, a
website to a web server.
Obtain a web hosting account.
Enter details about the web hosting account.
Create the web pages for upload to the website.
Define the upload method to be used, usually FTP.
Upload the web page files to the web server.
Test the website by using a web browser.
Understand the process of downloading a
website from a web server.
Create a local folder to contain the website files.
Set up an FTP connection.
Select and download files from the web server.
Upload a website to a server.
To create a local folder click the Site menu.
Click New Site.
Click in the Site Name box and enter the name of
the website.
Click in the Local Site Folder box and enter the
location to save web pages.
Click Save.
After creating your web pages define the website.
To set up a remote folder click the Site menu.
Click Manage Site, Edit, Servers.
Click the Add New Server + button.
Click Basic at the top of the dialog box.
Enter the Server name and FTP settings.
Click Save.
Click the Site menu, click Put and click Yes.
The files will begin uploading.
Download a website from a server.
Create a local folder to contain the existing site
and set up the folder as the local folder for the site.
Set up a remote folder, using the remote access
information about the existing site.
In the Files panel, click the Connects to Remote
Host button for FTP access.
To download the full website select root folder
and click Get Files.
To download only part of the website, select files
for download and click Get Files.
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IT Security

This module allows candidates to understand the main
concepts underlying the secure use of ICT in daily life
and to use relevant techniques and applications to
maintain a secure network connection, use the Internet
safely and securely, and manage data and information
appropriately.

Module Summary

SYLLABUS OUTLINE

CATEGORY

Security Concepts

On completion of this module the candidate will be able to:
Understand the key concepts relating to the importance of
secure information and data, physical security, privacy and
identity theft.
Protect a computer, device, or network from malware and
unauthorised access.
Understand the types of networks, connection types, and
network specific issues, including firewalls.
Browse the World Wide Web; communicate on the Internet
securely.
Understand security issues related to communications, including
e-mail and instant messaging.
Back up and restore data appropriately and safely; securely
dispose of data and devices.

WHAT ARE THE BENEFITS OF THIS MODULE?

Covers the skills needed to understand the key concepts relating
to the importance of secure information and data, physical
security, privacy, and identity theft.
Certifies best practice in IT security.
Developed with input from computer users, subject matter
experts, and practising computer professionals from all over the
world. This process ensures the relevance and range of module
content.

HOW DO I GET STARTED?
To find out more about this module and to locate your nearest
accredited test centre, please visit www.ecdl.org/programmes.

Malware

SKILL SET
Data Threats
Value of Information
Personal Security
File Security

Definition and Function
Types
Protection

Network Security

Networks
Network Connections
Wireless Security
Access Control

Secure Web Use

Web Browsing
Social Networking

Communications

E-mail
Instant Messaging

Secure Data
Management

Securing and Backing Up Data
Secure Destruction

ECDL / ICDL IT Security
This module sets out essential concepts and skills relating to the ability to understand the
main concepts underlying the secure use of ICT in daily life and to use relevant techniques
and applications to maintain a secure network connection, use the Internet safely and
securely, and manage data and information appropriately.

Module Goals
Successful candidates will be able to:
 Understand the key concepts relating to the importance of secure information and
data, physical security, privacy and identity theft.
 Protect a computer, device or network from malware and unauthorised access.
 Understand the types of networks, connection types and network specific issues
including firewalls.
 Browse the World Wide Web and communicate on the Internet securely.
 Understand security issues related to communications including e-mail and instant
messaging.
 Back up and restore data appropriately and safely, and securely dispose of data and
devices.
CATEGORY

SKILL SET

1 Security Concepts1.1.1 Data Threats

1.2 Value of Information

© 2010 ECDL Foundation

REF.

TASK ITEM

1.1.1

Distinguish between data and
information.

1.1.2

Understand the term
cybercrime.

1.1.3

Understand the difference
between hacking, cracking and
ethical hacking.

1.1.4

Recognise threats to data from
force majeure like: fire, floods,
war, earthquake.

1.1.5

Recognise threats to data from:
employees, service providers
and external individuals.

1.2.1

Understand the reasons for
protecting personal information
like: avoiding identity theft,
fraud.
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CATEGORY

SKILL SET

1.3 Personal Security

1.4 File Security
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REF.

TASK ITEM

1.2.2

Understand the reasons for
protecting commercially
sensitive information like:
preventing theft or misuse of
client details, financial
information.

1.2.3

Identify measures for
preventing unauthorised access
to data like: encryption,
passwords.

1.2.4

Understand basic
characteristics of information
security like: confidentiality,
integrity, availability.

1.2.5

Identify the main data/privacy
protection, retention and control
requirements in your country.

1.2.6

Understand the importance of
creating and adhering to
guidelines and policies for ICT
use.

1.3.1

Understand the term social
engineering and its implications
like: information gathering,
fraud, computer system access.

1.3.2

Identify methods of social
engineering like: phone calls,
phishing, shoulder surfing.

1.3.3

Understand the term identity
theft and its implications:
personal, financial, business,
legal.

1.3.4

Identify methods of identity theft
like: information diving,
skimming, pretexting.

1.4.1

Understand the effect of
enabling/ disabling macro
security settings.

1.4.2

Set a password for files like:
documents, compressed files,
spreadsheets.

1.4.3

Understand the advantages
and limitations of encryption.
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CATEGORY
2 Malware

SKILL SET
2.1 Definition and Function

2.2 Types

2.3 Protection

3 Network Security 3.1 Networks

3.2 Network Connections
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REF.

TASK ITEM

2.1.1

Understand the term malware.

2.1.2

Recognise different ways that
malware can be concealed like:
Trojans, rootkits and back
doors.

2.2.1

Recognise types of infectious
malware and understand how
they work like: viruses, worms.

2.2.2

Recognise types of data theft,
profit generating/extortion
malware and understand how
they work like: adware,
spyware, botnets, keystroke
logging and diallers.

2.3.1

Understand how anti-virus
software works and its
limitations.

2.3.2

Scan specific drives, folders,
files using anti-virus software.
Schedule scans using anti-virus
software.

2.3.3

Understand the term quarantine
and the effect of quarantining
infected/suspicious files.

2.3.4

Understand the importance of
downloading and installing
software updates, anti-virus
definition files.

3.1.1

Understand the term network
and recognise the common
network types like: local area
network (LAN), wide area
network (WAN), virtual private
network (VPN).

3.1.2

Understand the role of the
network administrator in
managing the authentication,
authorisation and accounting
within a network.

3.1.3

Understand the function and
limitations of a firewall.

3.2.1

Recognise the options for
connecting to a network like:
cable, wireless.
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CATEGORY

SKILL SET

3.3 Wireless Security

3.4 Access Control

4 Secure Web Use
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4.1 Web Browsing

REF.

TASK ITEM

3.2.2

Understand how connecting to
a network has implications for
security like: malware,
unauthorised data access,
maintaining privacy.

3.3.1

Recognise the importance of
requiring a password for
protecting wireless network
access.

3.3.2

Recognise different types of
wireless security like: Wired
Equivalent Privacy (WEP), WiFi Protected Access (WPA),
Media Access Control (MAC).

3.3.3

Be aware that using an
unprotected wireless network
can allow wireless
eavesdroppers to access your
data.

3.3.4

Connect to a protected/
unprotected wireless network.

3.4.1

Understand the purpose of a
network account and how it
should be accessed through a
user name and password.

3.4.2

Recognise good password
policies, like: not sharing
passwords, changing them
regularly, adequate password
length, adequate letter, number
and special characters mix.

3.4.3

Identify common biometric
security techniques used in
access control like: fingerprint,
eye scanning.

4.1.1

Be aware that certain online
activity (purchasing, financial
transactions) should only be
undertaken on secure web
pages.

4.1.2

Identify a secure website like:
https, lock symbol.

4.1.3

Be aware of pharming.
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CATEGORY

SKILL SET

4.2 Social Networking

5 Communications 5.1 E-Mail
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REF.

TASK ITEM

4.1.4

Understand the term digital
certificate. Validate a digital
certificate.

4.1.5

Understand the term one-time
password.

4.1.6

Select appropriate settings for
enabling, disabling
autocomplete, autosave when
completing a form.

4.1.7

Understand the term cookie.

4.1.8

Select appropriate settings for
allowing, blocking cookies.

4.1.9

Delete private data from a
browser like: browsing history,
cached internet files,
passwords, cookies,
autocomplete data.

4.1.10

Understand the purpose,
function and types of contentcontrol software like: internet
filtering software, parental
control software.

4.2.1

Understand the importance of
not disclosing confidential
information on social
networking sites.

4.2.2

Be aware of the need to apply
appropriate social networking
account privacy settings.

4.2.3

Understand potential dangers
when using social networking
sites like: cyber bullying,
grooming, misleading/
dangerous information, false
identities, fraudulent links or
messages.

5.1.1

Understand the purpose of
encrypting, decrypting an email.

5.1.2

Understand the term digital
certificate.

5.1.3

Create and add a digital
signature.
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CATEGORY

SKILL SET

5.2 Instant Messaging

6 Secure Data
Management

6.1 Securing and Backing Up
Data

6.2 Secure Destruction
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REF.

TASK ITEM

5.1.4

Be aware of the possibility of
receiving fraudulent and
unsolicited e-mail.

5.1.5

Understand the term phishing.
Identify common characteristics
of phishing like: using names of
legitimate companies, people,
false web links.

5.1.6

Be aware of the danger of
infecting the computer with
malware by opening an e-mail
attachment that contains a
macro or an executable file.

5.2.1

Understand the term instant
messaging (IM) and its uses.

5.2.2

Understand the security
vulnerabilities of IM like:
malware, backdoor access,
access to files.

5.2.3

Recognise methods of ensuring
confidentiality while using IM
like: encryption, non-disclosure
of important information,
restricting file sharing.

6.1.1

Recognise ways of ensuring
physical security of devices like:
log equipment location and
details, use cable locks, access
control.

6.1.2

Recognise the importance of
having a back-up procedure in
case of loss of data, financial
records, web
bookmarks/history.

6.1.3

Identify the features of a backup procedure like:
regularity/frequency, schedule,
storage location.

6.1.4

Back up data.

6.1.5

Restore and validate backed up
data.

6.2.1

Understand the reason for
permanently deleting data from
drives or devices.
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CATEGORY
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SKILL SET

REF.

TASK ITEM

6.2.2

Distinguish between deleting
and permanently destroying
data.

6.2.3

Identify common methods of
permanently destroying data
like: shredding, drive/media
destruction, degaussing, using
data destruction utilities.
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IT Security

Quick Reference

This quick reference guide is for Microsoft Internet Explorer 9.0 and Word 2010
Certification Test Goals

This module sets out essential concepts and skills relating to the ability to
understand the main concepts underlying the secure use of ICT in daily life
and to use relevant techniques and applications to maintain a secure network
connection, use the Internet safely and securely, and manage data and
information appropriately.
Successful candidates will be able to:
Understand the key concepts relating to the importance of secure
information and data, physical security, privacy and identity theft.
Protect a computer, device or network from malware and unauthorised
access.
Understand the types of networks, connection types and network
specific issues including firewalls.
Browse the World Wide Web and communicate on the Internet securely.
Understand security issues related to communications including e-mail
and instant messaging.
Back up and restore data appropriately and safely, and securely dispose
of data and devices.

1

Security Concepts

1.1

Data Threats
Distinguish between data and information.
Data is unprocessed information for data processing.
Data may be a collection of unprocessed numbers,
text, or images.
Information is the processed output of data making
it meaningful to the person who receives it.
Understand the term cybercrime.
Cybercrime is an illegal activity that uses the Internet
or a computer. Examples include identity theft and
social engineering.
Understand the difference between:
Hacking involves using computer expertise to gain
access to a computer system without authorisation.
The hacker may wish to tamper with programs and
data on the computer, use the computer’s resources,
or just prove they can access the computer.
Password cracking involves recovering passwords
from data that has been stored in or transmitted by a
computer system. This can be attempted manually by
guessing the password, or by using software.
Software cracking involves disabling or removing
certain features in software that are deemed
undesirable by the software cracker, for example,
copy protection, serial numbers, hardware keys, date
checks.
Ethical hacking involves attacking a computer
security system with permission from its owners to
find vulnerabilities that a malicious hacker could
exploit.
Recognise threats to data from force majeure.
Force majeure is a ‘superior force’ or an unforeseen
event that can threaten data like:
Fire
Floods
War
Earthquake
Recognise threats to data from:
Employees – Could steal company data such as new
product information
Service providers – Could lose, destroy, or steal
valuable company data
External individuals – Could gain access to a
computer system and steal/delete data

1.1.1

1.1.2

1.1.3

1.1.4

1.1.5

1.2
1.2.1

1.2.2

1.2.3

1.2.4

1.2.5

1.2.6

1.3
1.3.1

Value of Information
Understand the reasons for protecting personal
information like:
Avoiding identity theft
Avoiding fraud
Understand the reasons for protecting commercially
sensitive information like:
Preventing theft or misuse of client details
Preventing theft or misuse of financial information
Identify measures for preventing unauthorised
access to data like:
Encryption is the process of encoding data to make
it unintelligible to any unauthorised person who tries
to read the data.
Passwords are a string of characters used for
authentication, to prove identity or gain access to a
resource.
Understand basic characteristics of information
security like:
Confidentiality - Ensures information is protected
against unauthorised access or disclosure
Integrity - Refers to the trustworthiness of information
resources
Availability - Refers to the availability of information
resources
Identify the main data/privacy protection, retention
and control requirements in your country.
In EU countries the 1995 European Data Protection
Directive applies.
Understand the importance of creating and adhering
to guidelines and policies for ICT use.
They provide a standard for users to follow and
ensure that there is a clear position on how ICT should
be used to ensure the protection of the organisation’s
data.
Personal Security
Understand the term social engineering
Social engineering involves manipulating people into
performing actions or divulging confidential
information, rather than by hacking to obtain the
information.

1.3.1

1.3.2

1.3.3

1.3.4

1.4
1.4.1

Understand its implications like:
Information gathering – Gathering information
that may be confidential or valuable
Fraud – Using gathered information to commit
an act of fraud
Data access - It facilitates unauthorised
computer system access - potentially
revealing confidential information
Identify methods of social engineering like:
Phone calls - Misleading someone about
your identity in a phone call to gain valuable
information
Phishing - Misleading someone about your
identity online to gain valuable information
Shoulder surfing - Using direct observation
to get information
Understand the term identity theft.
Identity theft involves assuming another
person's identity for personal gain. This can
lead to the theft or misuse of personal,
business or legal information.
Identify methods of identity theft like:
Information diving - The practice of recovering
information from discarded material
Skimming – Using a scanner device to skim
information, often from a credit/debit card
Pretexting - Gaining personal information
through deception
File Security
Understand the effect of enabling/disabling
macro security settings.
Enabling a macro will ensure that the macro
will run but may harm your computer if the
source of the file is unknown.
Disabling a macro will ensure the macro will
not run but may prevent you from using all
the features in a file.
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1.4.2

Set a password for files like:
Documents:
Click File.
Click Info.
Click Protect Document.
Click Encrypt with Password.

Choose a password and click OK.
Reenter the password and click OK.
Compressed files:
On the Home tab, select Encrypt.
Select the files, folders to zip.
Click Zip.
Choose a password and reenter the password.
Click OK.
Spreadsheets:
Click File.
Click Info.
Click Protect Workbook.
Click Encrypt with Password.

2.2.2

2.3
2.3.1

2.3.2

2.3.2

2.3.3

2.3.4

1.4.3

Choose a password and click OK.
Reenter the password and click OK.
Understand the advantages and limitations of
encryption.
Advantages:
Encrypted data cannot be read without a key
Only an authorised receiver can read the message
Limitations:
If the encrypted key is lost it leaves the data
unusable

2

Malware

2.1

Definition and Function
Understand the term malware.
Malware is malicious software that is designed to
install itself on a computer without the owner's
consent.
Recognise different ways that malware can be
concealed like:
Trojan - Destructive program that masquerades as
an application
Rootkit – Used to enable continued access to a
computer while actively hiding its presence
Back door – Used to bypass system security

2.1.1

2.1.2

2.2
2.2.1

Types
Recognise types of infectious malware and
understand how they work like:
Viruses - Computer programs that can replicate
themselves and cause damage to a computer
Worms - Self-replicating malware that uses a
computer network to send copies of itself to other
computers

Recognise types of data theft, profit generating/
extortion malware and understand how they work
like:
Adware - Software package that automatically
plays, displays, or downloads advertisements to a
computer
Spyware - Malware that collects information on
user browser habits without their consent
Botnets - Can infect and control computers
without consent
Keystroke logging - Involves the capturing of
information that is typed on a keyboard
Dialers - Malicious programs that install onto a
computer and attempts to dial premium telephone
lines at other locations

3.1.3

Understand the limitations of a firewall.
Does not always provide automatic notification
if your network is hacked
Cannot protect against an attack generated
from within the network
May restrict some legitimate traffic

3.2

Protection
Understand how anti-virus software works and
its limitations.
Anti-virus software uses scans to detect and
block viruses before they infect your system.
Anti-virus software needs to be kept up to date
with definition files. It cannot always stop attacks
to system vulnerabilities or security flaws.
Scan specific drives, folders, files using
anti-virus software
Launch the Anti-Virus Application.
Select the Drives, Folders, Files to scan.
Click Scan.
Schedule scans using anti-virus software.
Launch the Anti-Virus Application.
Select the Schedule Scan options and select the
Scan Frequency, Date/Time.
Click on the Scan button.
Understand the term quarantine and the effect of
quarantining infected/suspicious files.
Quarantining a file moves the file to a safe location
on a drive that is managed by the anti-virus
software.
The file can still be restored from quarantine if
required.
Understand the importance of downloading and
installing software updates, anti-virus definition
files.
Installing software updates and anti-virus definition
files can fix a flaw or security risk in an application
and update against new security risks.

3.2.2

Network Connections
Recognise the options for connecting to a
network like:
Cable - Involves connecting to a
network using physical cables
Wireless - Connections that allow
you to wirelessly connect to a
network without the need for a
cable
Understand how connecting to a network
has implications for security like:
Computers connected to the network may be
infected with malware.
Connecting to a network may open your
system up to potential for unauthorised data
access.
Connecting to a network may increase the
challenge of maintaining privacy.

3.2.1

3.3
3.3.1

3.3.2

3.3.3

3.3.4

312.3.1 Network
Networks Security
3.1.1

3.1.1

3.1.2

3.1.3

Understand the term network.
A group of two or more computer systems linked
together by communications channels to allow for
sharing of resources and information.
Recognise the common network types like:
Local Area Network (LAN) - A network that
connects computers in close proximity, usually
in the same building
Wide Area Network (WAN) – A network that
connects computers over a long distance, using
telephone lines and satellite communications
Virtual Private Network (VPN) - A network that
allows users to privately share information between
remote locations, or between a remote location
and a business' home network
Understand the role of the network administrator.
Network administrators are involved in managing
the authentication, authorisation and accounting
within a network.
Tasks include maintaining staff access to required
data on the network and ensuring network usage
is in line with ICT policy.
Understand the function of a firewall.
Used to protect a network from intrusions from
outside sources.

3.4
3.4.1

3.4.2

3.4.3

4
4.1
4.1.1

Wireless Security
Recognise the importance of requiring a
password for protecting wireless network
access.
Requiring a password ensures that only
authorised users can access the network and
data.
Recognise different types of wireless security
like:
Wired Equivalent Privacy (WEP)
Wi-Fi Protected Access (WPA)
Media Access Control (MAC)
Be aware that using an unprotected wireless
network can allow wireless eavesdroppers to
access your data.
On an unprotected wireless network other
people may be able to access your data.
Connect to a protected/unprotected wireless
network.
Click Start.
Click Control Panel.
Click Network and Sharing Center.
Click Connect to a network.
Double click on the desired network.
Enter the wireless network password
(protected network only).
Click Connect.
Access Control
Understand the purpose of a network account
and how it should be accessed through a user
name and password.
For security reasons, a user name and
password should be required for a user to
access a network.
Recognise good password policies, like:
Not sharing passwords
Changing them regularly
Adequate password length
Adequate letter, number and special characters
mix
Identify common biometric security techniques
used in access control like:
Fingerprint scanning
Eye scanning
Secure
Web Use
Web Browsing
Be aware that certain online activity
(purchasing, financial transactions) should
only be undertaken on secure web pages:
Purchasing – e.g. Online shopping
Financial Transactions – e.g. Online banking,
fund transfers

4.1.2

Identify a secure website:
Check the web page URL for “https”

4.1.7

Check for the Lock Symbol in the browser window

4.1.3

4.1.4

4.1.5

4.1.6

Be aware of pharming.
Pharming - An attack that redirects a website's
traffic to a fake website
Understand the term digital certificate. Validate a
digital certificate.
A digital certificate is used to provide 3rd party
verification that the sender of a message is who
they claim to be. The file contains a public key and
other authentication information to allow it to be
validated.
Understand the term one-time password.
A one-time password is a password that is valid for
only one login session or transaction.
Select appropriate settings for enabling, disabling
autocomplete, autosave when completing a form.

4.1.8

Understand the term cookie.
Cookie - A small piece of text stored by the web
browser running on your computer
The cookie can store information like pages visited
on a site or information given to the site. When the
user revisits, the cookie allows the website to
recognise the user.
Select appropriate settings for allowing, blocking
cookies.
Click on the Tools button on the Command bar.
Select Internet Options.
Select the Privacy tab.
Click the Advanced button.

4.1.10

Autocomplete:
Click on the Tools button on the Command bar.
Select Internet Options.
Select the Content tab.

4.2
4.2.1

Check/uncheck the Cookies options as required.

4.2.2

4.2.3

Click the Settings button beside AutoComplete.
Check/uncheck the AutoComplete options as
required.
4.1.9

Click OK.
Block cookies if you are browsing on an unfamiliar
website.
Delete private data from a browser like: browsing
history, cached internet files, passwords,
cookies, autocomplete data.
Click on the Tools button on the Command bar.
Select Internet Options.
Select the General tab.
Click the Delete button beside Browsing history.

Click OK
Autosave:
Click on the Tools button on the Command bar.
Select Internet Options.
Select the Content tab.
Click the Settings button beside AutoComplete.
Check/uncheck the AutoComplete options for saving
user names and passwords as required.

5

Communications
E-Mail
Understand the purpose of encrypting,
decrypting an e-mail.
Encryption and decryption help to ensure only
the intended recipient can read an e-mail.
Understand the term digital signature.
A digital signature is an encrypted code that
demonstrates the authenticity of a message.
Create and add a digital signature.
Click File.
Click Info.
Click Protect Document.
Click Add a Digital Signature.

5.1.2

5.1.3

Click OK.

Social Networking
Understand the importance of not disclosing
confidential information on social networking
sites.
Examples of confidential information include
passwords, PIN numbers, certain company
information, client details.
Disclosing such information could lead to
personal information, company information,
client information or finances being stolen or
misused.
Be aware of the need to apply appropriate
social networking account privacy settings.
Making your account public will allow anybody
to view your personal details
Ensure that personal details are hidden
Understand potential dangers when using
social networking sites like:
Cyber bullying - Involves using the Internet
and related technologies to harm other people,
in a deliberate, repeated, and hostile manner
Grooming – Involves using the Internet and
related technologies to befriend a person, in
the negative context of preparing them to
accept inappropriate behaviour
Misleading/ dangerous information can be
posted by users
False identities may be assumed by social
network users to contact other users
Fraudulent links or message may be sent to
ellicit information from you

5.1
5.1.1

Check/uncheck the Browsing history options
as required.

Click Delete.
Understand the purpose, function and types
of content-control software like:
Internet filtering software - Designed to filter
and monitor access to websites
Parental control software - Used to restrict the
length of time spent on the Internet and restrict
access to certain content

6.1.3

6.1.4

5.1.4

5.1.5

5.1.5

5.1.6

5.2
5.2.1

5.2.2

5.2.3

Click OK.
Select Create your own digital ID and click OK.
Enter your Name, E-Mail Address, Organisation and
Location details.
Click Create.
Enter a Purpose for signing this document.
Click Sign.
Be aware of the possibility of receiving fraudulent
and unsolicited e-mail.
A fraudulent or unsolicited e-mail may contain a virus
or malware, or may be trying to gain information from
you and should not be opened.
Understand the term phishing.
Phishing involves misleading someone about your
identity online to gain valuable information.
Identify common characteristics of phishing like:
Using names of legitimate companies, people,
false web links.
Be aware of the danger of infecting the computer
with malware:
By opening an e-mail attachment that contains a
macro
By opening an executable file

6.2
6.2.1

Choose what data to back up or accept the
recommended default settings.

6.1

Securing and Backing Up Data
Recognise ways of ensuring physical security of
devices like:
Log equipment location and details
Use cable locks
Implement access control measures such as swipe
cards, biometric scans
Recognise the importance of having a back-up
procedure in case of loss of data, financial records,
web bookmarks/history.
Back-up procedures will ensure that data can be
recovered in the event it is lost.

6.1.1

6.1.2

6.2.2

6.2.3

Choose the back-up schedule.

Secure Destruction
Understand the reason for permanently
deleting data from drives or devices.
To ensure it is completely unrecoverable for
security reasons
Distinguish between deleting and permanently
destroying data.
Deleting data by moving it to the recycle bin
does not permanently destroy the data.
Permanently deleting data by shredding or
degaussing ensures that it cannot be recovered.
Identify common methods of permanently
destroying data like:
Shredding – Shredding disks like CD/DVD
Drive/media destruction – Physical destruction
of a drive or media
Degaussing - Leaves the magnetic domains
on a disk in random patterns rendering
previous data unrecoverable
Using data destruction utilities – Software/utility
to carry out the destruction of data on a drive

For more information, visit:

www.ecdl.org

6.1.5

Secure Data Management

Click Restore My Files.
Choose what you want to restore by using
Search, Browse for Files or Browse for Folders
to add files/folders to restore.
Click Next.
Choose to restore in the original location or
in the following location to choose a new
location.

Click Restore.

Instant Messaging
Understand the term instant messaging (IM) and
its uses.
Instant messaging is a form of real-time text-based
communication between two or more people.
IM can be used to have short text chats with
colleagues/friends, to share links or files. Some IM
programs also have VoIP and web camera functions.
Understand the security vulnerabilities of IM like:
Malware access
Backdoor access
Access to files
Recognise methods of ensuring confidentiality
while using IM like:
Encryption
Non-disclosure of important information
Restricting file sharing

6

Examples of items to back-up include:
Data
Financial records
Web bookmarks/history
Identify the features of a back-up procedure like:
Regularity/frequency – Set up how often you want
a back-up to occur
Schedule – Set up a back-up schedule
Storage location – Set up a location to store your
back-up to like an external hard drive
Back up data.
Click Start.
Click Backup and Restore.
Set up Backup.
Choose a back-up location (drive/network) and
click Next.

Save Settings and Backup.
Restore and validate backed up data.
Click Restore My Files.
Choose what you want to restore by using
Search, Browse for Files or Browse for Folders
to add files/folders to restore.
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Project Planning

This module enables candidates to use project
management software to prepare project plans and
monitor projects, including planning and managing
time, costs, tasks, and resources.
On completion of this module the candidate will be able to:
Understand the key concepts relating to managing projects.
Use a project management application to create a new project
and maintain an existing project.
Create and schedule tasks; add project constraints and deadlines.
Assign costs; create and assign resources to tasks.
View the critical path, monitor progress, and reschedule work.
Prepare and print outputs, including charts and reports.

Module Summary

SYLLABUS OUTLINE

CATEGORY

Project Management
Tools

Project Creation

Tasks

Resources and Costs

SKILL SET

Key Concepts

Working with Projects
Starting a New Project

Creating Tasks
Scheduling and Relationships
Constraints and Deadlines
Notes, Hyperlinks

Resources
Costs

WHAT ARE THE BENEFITS OF THIS MODULE?

Covers the key skills needed to use project planning applications.
Can be applied to a range of project planning software from
vendor packages to ‘freeware’.
Certifies best practice in effective project planning software use.
Developed with input from computer users, subject matter
experts, and practising computer professionals from all over the
world. This process ensures the relevance and range of module
content.

HOW DO I GET STARTED?
To find out more about this module and to locate your nearest
accredited test centre, please visit www.ecdl.org/programmes.

Project Monitoring

Prepare Outputs

Critical Path
Monitoring Progress and Rescheduling

Setup
Print

ECDL / ICDL Project Planning
This module sets out essential concepts and skills relating to the ability to use project
management software to prepare project plans and monitor projects including planning and
managing time, costs, tasks, and resources.

Module Goals
Successful candidates will be able to:
 Understand the key concepts relating to managing projects.
 Use a project management application to create a new project and maintain an
existing project.
 Create and schedule tasks and add project constraints and deadlines.
 Assign costs and create and assign resources to tasks.
 View the critical path, monitor progress and reschedule work.
 Prepare and print outputs, including charts and reports.
CATEGORY

SKILL SET

1 Project
1.1.1 Key Concepts
Management Tools

2 Project Creation

© 2011 ECDL Foundation

2.1 Working with Projects

REF.
1.1.1

Understand the term project.

1.1.2

Recognise the main elements
of managing a project like:
planning the project, managing
the schedule, communicating
project information.

1.1.3

Understand the advantages of
using a project management
application like: efficient project
design, ease of project plan
maintenance, effective activity
representation, ease of
monitoring and reporting.

1.1.4

Understand the tools and
features of a project
management application like:
Gantt chart, network diagram,
work breakdown structure.

1.1.5

Recognise that managing
projects involves balancing
work, time, resource, and cost.

2.1.1

Open, close a project
management application.
Open, close projects.

Ref: ECDL / ICDL Project Planning - Syllabus - V1.0

CATEGORY

SKILL SET

2.2 Starting a New Project

3 Tasks

© 2011 ECDL Foundation

3.1 Creating Tasks

REF.
2.1.2

Save a project to a location on
a drive. Save a project under
another name to a location on a
drive.

2.1.3

Save a project as another file
type like: template, web page,
spreadsheet, CSV, XML, text
file, pdf.

2.1.4

Change between project view
modes like: Gantt chart,
network diagram.

2.1.5

Use magnification/zoom tools.

2.2.1

Create a new project based on
default template, other
available template.

2.2.2

Understand how choosing to
schedule from a start date,
finish date will impact on the
project schedule.

2.2.3

Enter basic project information
such as start date or finish date,
scheduling options and project
properties like: project title,
project manager.

2.2.4

Set up calendar options like:
base calendar, working time,
nonworking time.

3.1.1

Create, modify tasks.

3.1.2

Copy, move, delete tasks.

3.1.3

Create, modify, view subtasks
and summary tasks.

3.1.4

Understand task duration
options: elapsed, duration,
effort, estimated.

3.1.5

Set, modify task duration.

3.1.6

Split tasks.

3.1.7

Understand the term milestone.

3.1.8

Create project milestones.

3.1.9

Create, modify recurring tasks.

Ref: ECDL / ICDL Project Planning - Syllabus - V1.0

CATEGORY

SKILL SET
3.2 Scheduling and
Relationships

3.3 Constraints and Deadlines

3.4 Notes, Hyperlinks

4 Resources and
Costs

4.1 Resources

4.2 Costs

© 2011 ECDL Foundation

REF.
3.2.1

Understand logical relationships
between tasks: finish to start,
start to start.

3.2.2

Create, modify, delete
relationships between tasks:
finish to start, start to start.

3.2.3

Understand the terms lead
time, lag time.

3.2.4

Add, edit task lag time, lead
time.

3.3.1

Understand task constraint
options like: as late as possible,
as soon as possible, must finish
on, must start on.

3.3.2

Add, modify, delete constraints
to tasks.

3.3.3

Understand the term deadline.

3.3.4

Create a deadline.

3.4.1

Add, edit, remove a note for a
task.

3.4.2

Insert, edit, remove a hyperlink
for a task.

4.1.1

Identify resource types like:
people, materials, equipment.

4.1.2

Understand the relationship
between duration, work and
resource. Understand that if
one element changes there is
an impact on another element.

4.1.3

Create, delete resources.
Modify resource details like:
name, type, units, rates.

4.1.4

Add, remove, replace resource
assignments and associated
units.

4.2.1

Understand the terms fixed
cost, variable cost.

4.2.2

Assign, modify fixed costs.

4.2.3

Assign, modify variable costs.
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CATEGORY

SKILL SET

5 Project Monitoring 5.1 Critical Path

5.2 Monitoring Progress and
Rescheduling

6 Prepare Outputs

6.1 Setup

6.2 Print

© 2011 ECDL Foundation

REF.
5.1.1

Understand the terms critical
task, critical path.

5.1.2

Identify critical tasks and show
the critical path.

5.2.1

Create, save, clear a baseline.

5.2.2

Show, hide progress line.

5.2.3

Show, hide columns like: %
complete, fixed cost, deadline.

5.2.4

Sort, filter tasks.

5.2.5

Update task progress.

5.2.6

Reschedule incomplete work.

5.2.7

Display current project
schedule and baseline.

6.1.1

Change page orientation:
portrait, landscape. Change
paper size.

6.1.2

Change page margins: top,
bottom, left, right.

6.1.3

Prepare a Gantt chart, network
diagram for print using options
like: columns to print, notes.

6.2.1

Preview a Gantt chart, network
diagram, report.

6.2.2

Print a Gantt chart, network
diagram, report from an
installed printer using output
options like: entire document,
specific pages, number of
copies.
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Quick Reference

Project Planning

This quick reference is for Microsoft Project Standard 2010 on Windows 7

Project 2010 Tabs

Certification Test Goals
This module sets out essential concepts and skills relating to the ability to use
project management software to prepare project plans and monitor projects
including planning and managing time, costs, tasks, and resources.

Task

Successful candidates will be able to:
Understand the key concepts relating to managing projects.
Use a project management application to create a new project and maintain an
existing project.
Create and schedule tasks and add project constraints and deadlines.
Assign costs and create and assign resources to tasks.
View the critical path, monitor progress and reschedule work.
Prepare and print outputs, including charts and reports.

Resource

Project

Keyboard Shortcuts

View

General

Editing

Open CTRL+O

Cut CTRL+X

Save CTRL+S

Copy CTRL+C

Print CTRL+P

Paste CTRL+V

Close CTRL+W

Format

Undo CTRL+Z

Outline

Redo CTRL+Y

Hide subtasks ATL+SHIFT+

Help F1

HYPHEN

Switch between apps ALT+TAB

Indent a selected task
ATL+SHIFT+RIGHT ARROW
Show subtasks ATL+SHIFT+=
Show all tasks ATL+SHIFT+*

113.1 Project Management Tools
1.1
1.1.1

1.1.2

1.1.3

1.1.4

1.1.5

Key Concepts
Understand the term project.
A temporary and often collaborative activity that is
carefully planned to achieve a particular aim.
Recognise the main elements of managing a
project like:
Planning the project
Managing the schedule
Communicating project information
Understand the advantages of using a project
management application like:
Efficient project design
Ease of project plan maintenance
Effective activity representation
Ease of monitoring and reporting
Understand the tools and features of a project
management application like:
A Gantt chart is a type of bar chart that illustrates a
project schedule, including start and finish dates.
A network diagram is a model designed to analyse
and represent the tasks involved in completing a
project.
A work breakdown structure is a tool used to define
and group a project's tasks, so as to organise and
define the total work of the project.
Recognise that managing projects involves
balancing:
Work
Time
Resources
Cost

2

Project Creation

2.1

Working with Projects
Open a project management application.
Click the Start button.
Select All Programs.
Click Microsoft Project 2010.

2.1.1

2.1.1

2.1.1

2.1.1

2.1.2

2.1.2

2.1.3

2.1.4

Close a project management application.
Click the File tab.
Click Exit.
Open projects.
Click the File tab.
Click Open.
Select project(s) to open and click Open.
Close projects.
Click the File tab.
Click Close.
Save a project to a location on a drive.
Click the File tab.
Click Save.
Create a file name and select the location.
Click Save.
Save a project under another name to a location on
a drive.
Click the File tab.
Click Save As.
Enter a new file name over the existing file name
and select the location.
Click Save.
Save a project as another file type like: template,
web page, spreadsheet, CSV, XML, text file, pdf.
Click the File tab.
Select Save As.
Click on the Save as type drop-down menu and
select a file type.
Click Save.
Change between project view modes like: Gantt
chart, network diagram.
On the Task tab, in the View group, click the Gantt
Chart arrow below the Gantt Chart button.
Click Gantt Chart or Network Diagram to switch to
the selected view.

2.1.5

Use magnification/zoom tools.
On the View tab, in the Zoom group, click the
Zoom button.
Select the zoom option required.
Click OK.

2.2

Starting a New Project
Create a new project based on default template.
Click the File tab.
Click New.
Click Blank project.
Click Create.
Create a new project based on other available
template.
Click the File tab.
Click New.
Click My templates.
Click to select a template.
Click OK.
Understand how choosing to schedule from a
start date, finish date will impact on the project
schedule.
Schedule from a start date - All tasks will start
as soon as possible by default
Schedule from a finish date – Tasks on the critical
path are started as late as possible by default
Enter basic project information such as start date
or finish date, scheduling options and project
properties like: project title, project manager.
Click the File tab.
Click Info.
Click Project Information and Advanced Properties.

2.2.1

2.2.1

2.2.2

2.2.3
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3.1.2

3.1.3

3.1.3

3.1.3

2.2.4

2.2.4

Enter a project title in the Title text box.
Enter a project manager in the Manager text box.
Click OK.
Set up calendar options like: base calendar.
On the Project tab, in the Properties group, click the
Project Information button.
Select a calendar from 24 Hours, Night Shift, Standard.
Click OK.
Set up calendar options like: working time.
On the Project tab, in the Properties group, click the
Change Working Time button.
Click the Work Weeks tab.
Double-click on [Default] in the Name column.
Edit a day(s) working time.
Click OK.

3.1.4

3.1.5

3.1.5

2.2.4

Set up calendar options like: nonworking time.
On the Project tab, in the Properties group, click the
Change Working Time button.
Click the Work Weeks tab.
Double-click on [Default] in the Name column.
Edit a day(s) nonworking time.
Click OK.

3

Tasks

3.1

Creating Tasks
Create tasks.
Click into an empty Task Name field.
Enter a task name.
Modify tasks.
Click into a Task Name field.
Enter additional task name content or delete existing
task name content.
Copy tasks.
Click on a task in the Task Name column.
On the Task tab, in the Clipboard group, click the
Copy button.
Click on a new location within the Task Name column.
On the Task tab, in the Clipboard group, click the
Paste button.
Move tasks.
Click on a task in the Task Name column.
On the Task tab, in the Clipboard group, click the Cut button.
Click on a new location within the Task Name column.
On the Task tab, in the Clipboard group, click the
Paste button.

3.1.1

3.1.1

3.1.2

3.1.2

3.1.6

Delete tasks.
Select the row containing the task to delete.
Press the Delete key.
Create subtasks and summary tasks.
To create a subtask, on the Task tab, in the
Schedule group, click the Indent Task button.
To create a summary task, on the Task tab, in the
Schedule group, click the Outdent Task button.
Modify subtasks and summary tasks.
To modify a summary task to be a subtask, on the
Task tab, in the Schedule group, click the Indent
Task button.
To modify a subtask to be a summary task, on the
Task tab, in the Schedule group, click the Outdent
Task button.
View subtasks and summary tasks.
To view subtasks, on the View tab, in the Data
group, click the Show Outline button.
Click Show Subtasks.
To view summary tasks, on the View tab, in the Data
group, click the Show Outline button.
Click Hide Subtasks.
Understand task duration options:
Elapsed task duration is based on a 24-hour day
and a 7-day week, including holidays and other
nonworking days.
Duration is the active working time to complete a
task.
Effort is the amount of work required to carry out
a task; for example, two people working for three
days is 6 days effort (or work).
Estimated task duration is the estimated working
time to complete a task, shown by a ?; for example,
1 day?
Set task duration.
In the Duration column, click on the Duration for a
task.
Enter the duration required; for example 1D for 1
day.
Press the Return key.
Modify task duration.
In the Duration column, click on the Duration for
the task to modify.
Change the duration or delete the duration.
Press the Return key.
Duration in

Time unit abbreviation

Minutes

M

Hours

H

Days

D

Weeks

W

Months

Mon

Split tasks.
On the Task tab, in the Schedule group, click the
Split Task button.
In the Gantt Chart, click the location on a task to
create a split.

Click OK.
3.2
3.2.1

Start to start – The second task can start as
soon as the first task starts.

3.2.2

3.2.2

3.2.2

3.2.2

3.2.3

3.1.7

3.1.8

3.1.9

Understand the term milestone.
A reference point used to mark a point in time or
a major event in a project.
Create project milestones.
On the Task tab, in the Insert group, click the
Milestone button.
Create, modify recurring tasks.
On the Task tab, in the Insert group, click the Task
arrow below the Task button.
Click Recurring Task.
Enter the recurring task information.

Scheduling and Relationships
Understand logical relationships between
tasks: finish to start, start to start.
Finish to start – The second task cannot start
until the first task finishes.

3.2.4

Create relationships between tasks:
finish to start.
To create a finish to start relationship, select
the tasks to create a relationship between.
On the Task tab, in the Schedule group, click
the Link Tasks button.
Create relationships between tasks:
start to start.
To create a start to start relationship, select
the tasks to create a relationship between.
On the Task tab, in the Schedule group, click
the Link Tasks button.
In the Gantt Chart, double-click on the
relationship arrow.
In the task dependency, change the Type to
Start-to-Start (SS).

Click OK.
Modify relationships between tasks: finish
to start, start to start.
In the Gantt Chart, double-click on the
relationship arrow between two tasks.
In the task dependency, change the Type to
Start-to-Start (SS) or Finish-to-Start (FS).
Click OK.
Delete relationships between tasks: finish
to start, start to start.
In the Gantt Chart, double-click on the
relationship arrow.
Click Delete.
Understand the terms lead time, lag time.
Lead time – An overlap between tasks that
have a dependency
Lag time - A delay between tasks that have
a dependency
Add task lag time, lead time.
On the Task tab, in the Properties group,
click the Information button.
In Task Information, click the Predecessors
tab and select the relevant lag cell.
To enter lead time, type a negative number
or negative percentage, such as -2d for two
days of lead time.

3.2.4

3.3
3.3.1

3.3.2

3.3.2

3.3.2

3.3.3

3.3.4

To enter lag time, type a positive number or
percentage, such as 50% for half the predecessor
task's duration in lag time.
Click OK.
Edit task lag time, lead time.
On the Task tab, in the Properties group, click the Information
button.
In Task Information, click the Predecessors tab and
select the relevant lag cell.
To edit lead time, type a negative number or negative
percentage.
To edit lag time, type a positive number or percentage.
Click OK.
Constraints and Deadlines
Understand task constraint options like:
As late as possible – Task will start as late as
possible based on other constraints and relationships
As soon as possible - Task will start as soon as
possible based on other constraints and relationships
Must finish on – Task will finish on the specified date
Must start on – Task will start on the specified date
Add constraints to tasks.
On the Task tab, in the Properties group, click the Information
button.
In the Task Information, click the Advanced tab.
Choose a Constraint type and a Constraint date.
Click OK.
Modify constraints to tasks.
On the Task tab, in the Properties group, click the Information
button.
In the Task Information, click the Advanced tab.
Modify the Constraint type and Constraint date.
Click OK.
Delete constraints to tasks.
On the Task tab, in the Properties group, click the Information
button.
In the Task Information, click the Advanced tab.
Modify the Constraint type to As Soon As Possible.
Click OK.
Understand the term deadline.
The latest date by which a task should be completed.
Create a deadline.
On the Task tab, in the Properties group, click the Information
button.
In the Task Information, click the Advanced tab.
Click a deadline from the Deadline drop-down box.

3.4.2

3.4.2

3.4.2

Delete the text of the note.
Click OK.
Insert a hyperlink for a task.
Right-click on the task and select Hyperlink.
Select the file, location or e-mail address to
hyperlink to.
Click OK.
Edit a hyperlink for a task.
Right-click on the task and select Hyperlink.
Edit the file, location or e-mail address to hyperlink
to.
Click OK.
Remove a hyperlink for a task.
Right-click on the task and select Hyperlink.
Click Clear Hyperlinks.
Click OK.

4

Resources and Costs

4.1

Resources
Identify resource types like:
People
Materials
Equipment
Understand the relationship between duration,
work and resource. Understand that if one element
changes there is an impact on another element.
Duration multiplied by Resource Units equals Work.
16 hours X 300% = 48 hours
Work divided by Resource Units equals Duration.
48 hours / 300% = 16 hours
Work divided by Duration equals Resource Units.
48 hours / 16 hours = 300%
If one element of the formula changes there is an
impact on another element, for example an increase
in duration will lead to an increase in work.
Create, delete resources.
On the Resource tab, in the View group, click the
Resource Sheet button.
Enter or delete the details of a resource.
Press the Return key.
Modify resource details like: name, type, units,
rates.
On the Resource tab, in the View group, click the
Resource Sheet button.
Enter or delete the details of a resource.
Press the Return key.
Add resource assignments and associated units.
Select a task.
On the Resource tab, in the Assignments group,
click the Assign Resources button.

4.1.1

4.1.2

4.1.3

4.1.3

4.1.4

Click Replace.
Choose a new resource.
Click OK.
4.2
4.2.1

4.2.2

4.2.3

Costs
Understand the terms fixed cost, variable
cost.
Fixed cost is a set cost for a task regardless
of task duration or work performed by a
resource.
Variable cost is a cost that changes
throughout the project depending on its
availability or use.
Assign, modify fixed costs.
In the task list, assign, modify the fixed cost
in the Fixed Cost column for the relevant task.
Press the Return key.
Assign, modify variable costs.
On the Resource tab, in the View group, click
the Resource Sheet button.
Enter the costs required for the resource.
Press the Return key.
In the task list, assign the resource to a task
and view the Cost column for the task.
Press the Return key.

5

Project Monitoring

5.1

Critical Path
Understand the terms critical task, critical
path.
Critical task - A task on the critical path
Critical path - A sequence of tasks that must
all be completed on time for the project to
finish on schedule
Identify critical tasks and show the critical
path.
On the Format tab, in the Bar Styles group,
check the Critical Tasks checkbox.
Critical tasks will now appear in red on the
Gantt chart.

5.1.1

5.1.2

5.2
5.2.1

Monitoring Progress and Rescheduling
Create, save a baseline.
On the Project tab, in the Schedule group,
click the Set Baseline button.
Click Set Baseline.
In the Set Baseline dialog box, click Set
Baseline and click for the Entire project or
Selected tasks.

Click OK.
3.4
3.4.1

3.4.1

3.4.1

Notes, Hyperlinks
Add a note for a task.
Select a task.
On the Task tab, in the Properties group, click the
Task Notes button.
Enter the note.
Click OK.
Edit a note for a task.
Select a task.
On the Task tab, in the Properties group, click the
Task Notes button.
Edit the text of the note.
Click OK.
Remove a note for a task.
Select a task.
On the Task tab, in the Properties group, click the
Notes button.

4.1.4

4.1.4

Select the resource to assign and enter the units
required.
Click Assign.
Remove resource assignments and associated
units.
Select a task.
On the Resource tab, in the Assignments group,
click the Assign Resources button.
Select the resource to remove.
Click Remove.
Replace resource assignments and associated
units.
Select a task.
On the Resource tab, in the Assignments group,
click the Assign Resources button.
Select the resource to replace.

5.2.1

Click OK.
Clear a baseline.
On the Project tab, in the Schedule group,
click the Set Baseline button.
Click Clear Baseline.
In the Clear Baseline dialog box, click on a
baseline in the Clear baseline plan
drop-down box.
Click to clear for the Entire project or
Selected tasks.
Click OK.

5.2.2

5.2.3

5.2.3

5.2.4

5.2.4

5.2.5

5.2.6

5.2.7

Show, hide progress line.
On the Format tab, in the Format group, click the
Gridlines button.
Click Progress Lines.
Select, deselect to display a current progress line.
Select, deselect to display at recurring intervals.
Click OK.
Show columns like: % complete, fixed cost,
deadline.
On the Format tab, in the Columns group, click the
Insert Column button.
Select a column type.
Hide columns.
Select the column to hide.
On the Format tab, in the Columns group, click the
Column Settings button.
Click Hide Column.
Sort tasks.
On the View tab, in the Data group, click the Sort
button.
Select a sort type to apply or select Sort By to create
a custom sort.
Filter tasks.
On the View tab, in the Data group, click the Filter drop-down
menu box.
Select a built in filter to apply or select More Filters
for additional filter options.
Update task progress.
On the Task tab, in the Schedule group, click the
desired % Complete button.
Reschedule incomplete work.
On the Project tab, in the Status group, click the
Update Project button.
Click Reschedule uncompleted work to start after and
select a date.
Select either to reschedule for the entire project or
selected tasks.

6

Prepare Outputs

6.1

Setup
Change page orientation: portrait, landscape.
On the File tab, click Print.
Click Portrait Orientation or Landscape Orientation.
Change paper size.
On the File tab, click Print.
Select a paper size.
Change page margins: top, bottom, left, right.
On the File tab, click Print.
Click Page Setup.
On the Margins tab, enter a top, bottom, left, right
margin.
Click OK.
Prepare a Gantt chart, network diagram for print
using options like: columns to print, notes.
On the File tab, click Print.
Click Page Setup.
Click the View tab.
To print all sheet columns, check the print all sheet
columns checkbox.
To print a specified number of columns, check the
print first [insert required number] columns on all
pages option and enter the required number.
Check the print notes checkbox to print notes.
Click OK.

6.1.1

6.1.1

6.1.2

6.1.3

6.2
6.2.1

6.2.2

Click OK.
Display current project schedule and baseline.
On the Format tab, in the Format group, click the
Gridlines button and click Progress Lines.
Select to display the Current progress line.
Select to display progress line in relation to the
Baseline plan.

Print
Preview a Gantt chart, network diagram, report.
On the File tab, click Print.
A preview is available on screen.
Print a Gantt chart, network diagram, report from
an installed printer using output options like: entire
document, specific pages, number of copies.
On the File tab, click Print.
Click the Print button.
To print the complete project, under Settings,
select Print Entire Project.
To print specific pages, under Settings, select Print
Specific Pages and enter specific page numbers and/or
page ranges (dates) to print.
Under Copies, enter the number of copies to print.
Click Print.

For more information, visit:
www.ecdl.org

13.5 Project Monitoring

If the baseline is not visible, on the Format tab, in the
Bar Styles group, click the Baseline button and click a baseline to
view.
Click OK.
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